• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Gimp - Werkzeug-Maus-"Pfeil" fehlt

Elwood

Naiver Mutmaßlicher
Themenstarter #1
Moin,

ich kann nicht genau sagen, ob dieser Effekt seit dem Umstieg auf 10 besteht. Wenn man einen Pinsel oder Radiergummi als Werkzeug auswählt, wird zwar ein Mauspfeil und rechts darunter das aktuell ausgewählte Werkzeug angezeigt, aber beispielsweise kein eingestellter Kreis, geschweige der eingestellte Radius, sodaß man mehr raten muß, was man weg löscht oder auch nicht.

Kann jemand diesen Effekt bestätigen? Portstree ist aktuell und quasi alle Ports nach Umstieg auf 10 neu durchkompiliert. Graka ist Nvidia GT630 und der Nvidiatreiber.
 

Elwood

Naiver Mutmaßlicher
Themenstarter #4
@foxit: Ja, bringt keinen Erfolg... hab das Problem auf 2 Maschinen.
@Kamikaze: Wollt auch schon den Vesa-Treiber probieren, der kommt aber wohl nicht mit 2 Screens klar?!
 

zuglufttier

Well-Known Member
#5
Ist bei mir auch so! Xorg ist selbstgebaut mit NEW_XORG und ich benutze dann den Intel Treiber. Gimp dagegen ist ein aktuelles Package aus den normalen Repositories. Ich habe Kernel und Userland selbstgebaut vor ein paar Wochen, also 10 stable.

Ich weiß, dass es vor einer ganzen Weile noch gut funktionierte, allerdings benutze ich Gimp selten auf dem Laptop und weiß daher nicht, ob's beim Umstieg auf 10 passiert ist.
 

Fusselbär

Makefile Voyeur
#8
Ich mache das über die /etc/make.conf, benutze aber immer noch portupgrade. Wenn ich beispielsweise lang/gcc47 für den graphics/gimp-app Build nehmen wollte würde ich das eintragen:
Code:
#----------------------------------------------------------------------------
# Build these ports with GCC47
#----------------------------------------------------------------------------
GCC47_BUILD_PORTS+=graphics/gimp-app
GCC47_BUILD_PORTS+=graphics/nvidia-texture-tools
.for port in ${GCC47_BUILD_PORTS}
.if !empty(.CURDIR:M*/${port})
CC=    gcc47
CXX=   c++47
CPP=   cpp47
.endif
.endfor
 

Fusselbär

Makefile Voyeur
#10
Oh, noch was.
Ich weiß nicht, ob das wirklich nötig ist, aber habe auf meiner Installation auch noch keinen Schaden dadurch feststellen können. Habe den Pfad für den gcc47 auch in die /etc/rc.d/ldconfig gesetzt:
Code:
_LDC="/usr/local/lib/gcc47 /lib /usr/lib /usr/local/openjdk7/jre/lib/amd64"
Mit dem Eintrag von openjdk7 dort im ldconfig Pfad gingen bei mir auch noch einige Fehlermeldungen beim gelegentlichen pkg_libchk weg.
 

Kamikaze

Warrior of Sunlight
#12
Die Ports haben eigentlich eine eigene Lösung dafür.

In meiner buildflags.conf steht:
Code:
*/graphics/gimp-app   {USE_GCC}
Das entspricht in make Syntax:
Code:
.if ${.CURDIR:M*/graphics/gimp-app}
USE_GCC=                yes
.endif