• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

gnome 2.24 via ports - falsche version libdrm

sbE

New Member
Themenstarter #1
hallo,

ich wollte soeben auf einem frisch installierten freebsd 7.1 (und via cvsup aktualisiertem portstree) gnome 2.24 installieren. nachdem ich "make install clean" eingegeben habe, läd, kompiliert und installiert das system fröhlich vor sich hin bis folgender fehler zum abbruch führt:

checking for LIBDRM... configure: error: Package requirements (libdrm >= 2.4.3) were not met:

Requested 'libdrm >= 2.4.3' but version of libdrm is 2.3.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBDRM_CFLAGS
and LIBDRM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

===> Script "configure" failed unexpectedly.
Please report the problem to x11@FreeBSD.org [maintainer] and attach the
"/usr/ports/graphics/libGLU/work/Mesa-7.3/config.log" including the output
of the failure of your make command. Also, it might be a good idea to provide
an overview of all packages installed on your system (e.g. an `ls
/var/db/pkg`).
*** Error code 1

Stop in /usr/ports/graphics/libGLU.
*** Error code 1

Stop in /usr/ports/graphics/libglut.
*** Error code 1

Stop in /usr/ports/graphics/jasper.
*** Error code 1

Stop in /usr/ports/graphics/jasper.
*** Error code 1

Stop in /usr/ports/x11-toolkits/gtk20.
*** Error code 1

Stop in /usr/ports/devel/gconf2.
*** Error code 1

Stop in /usr/ports/sysutils/gnome-settings-daemon.
*** Error code 1

Stop in /usr/ports/x11/gnome-applets.
*** Error code 1

Stop in /usr/ports/x11/gnome-applets.
*** Error code 1

Stop in /usr/ports/x11/gnome2.
*** Error code 1

Stop in /usr/ports/x11/gnome2.


per google finde ich nicht all zu viel, was mir weiterhilft... :(

vielleicht hat ja jemand von euch eine idee...
 

hippodriver

Well-Known Member
#2
Deine libdrm Version ist in der Tat ziemlich alt. Aktuell ist 2.4.4 in den Ports.
Vieleicht solltest Du erstmal Deine Ports aktualisieren ("portsnap fetch update").
Und libdrm aktualisieren natürlich.
 

sbE

New Member
Themenstarter #3
Deine libdrm Version ist in der Tat ziemlich alt. Aktuell ist 2.4.4 in den Ports.
Vieleicht solltest Du erstmal Deine Ports aktualisieren ("portsnap fetch update").
Und libdrm aktualisieren natürlich.
habe ich gemacht. die 2.4.4 ist nun installiert...ich mußte vorher via make deinstall & reinstall die alte version deinstallieren. nun habe ich aber während des compilierens folgende fehlermeldungen:

No package 'x11-xcb' found
No package 'xcb-glx' found

letzteres hat sich durch installieren der libxcb, xcb, xcb-proto & xcb-utils erledigt. die erste meldung bleibt noch übrig...habe erstmal keine ahnung wie ich die wegbekomme!?

...schon merkwürdig das man über die ports nicht so ohne weiteres auf ein aktuelles und frisch installiertes freebsd (x-user) ein frisches gnome installieren kann!?!
 

hippodriver

Well-Known Member
#4
Jetzt könnte ich viel Mist über die Verwaltung der Prots erzählen. Aber das spar ich mir einfach und gebe eine mögliche Kurzfassung.

  1. Portstree aktualisieren
  2. ports-mgmt/portmaster installieren (alternativ portupgrade)
  3. man page lesen
  4. mit 'portmaster -a' die installierten Ports aktualisieren
  5. neuen Port übersetzen

Das reicht meistens.
 

bsd5543

IT of the living dead
#5
Möchte das Problem nochmal aufwärmen:

Habe heute den aktuellen portstree gezogen und versuche via 'portmaster -au' alles auf die aktuellen Stände zu ziehen.

Nach diversen Abbrüchen von portmaster wegen ignorierter und broken Ports (habe diese dann mit 'pkg_delete' ins Nirvana geschickt), erhalte ich beim Update von dri ebenfalls die Meldung No package 'x11-xcb' found, obwohl ich diesen dann manuell per 'make install clean' nachgezogen habe.

Ich bin am verzweifeln.
 

hippodriver

Well-Known Member
#7
Nach diversen Abbrüchen von portmaster wegen ignorierter und broken Ports (habe diese dann mit 'pkg_delete' ins Nirvana geschickt), erhalte ich beim Update von dri ebenfalls die Meldung No package 'x11-xcb' found, obwohl ich diesen dann manuell per 'make install clean' nachgezogen habe.
Vieleicht wäre die komplette Fehlermeldung nützlich? Ich finde gar keinen x11-xcb Port.
Code:
[mickraus@gandalf ports]\$ make quicksearch name=xcb 
Port:	libxcb-1.1.93
Path:	/usr/ports/x11/libxcb
Info:	The X protocol C-language Binding (XCB) library

Port:	xcb-2.4_1
Path:	/usr/ports/x11/xcb
Info:	A tool for managing x11 cut-buffers

Port:	xcb-proto-1.3
Path:	/usr/ports/x11/xcb-proto
Info:	The X protocol C-language Binding (XCB) protocol

Port:	xcb-util-0.3.2
Path:	/usr/ports/x11/xcb-util
Info:	A module with libxcb/libX11 extension/replacement libraries

gandalf# find /usr -name '*x11-xcb*'
/usr/local/libdata/pkgconfig/x11-xcb.pc
gandalf# pkg_info -W /usr/local/libdata/pkgconfig/x11-xcb.pc
/usr/local/libdata/pkgconfig/x11-xcb.pc was installed by package libX11-1.1.99.2,1
 

pit234a

Well-Known Member
#8
sieh mal in die UPDATING:

20090123:
AFFECTS: users of x11/libxcb
AUTHOR: flz@FreeBSD.org

Libxcb shared library version was bumped from 1 to 2. You need to
rebuild any consumer of libxcb.so.1 or some applications will be
linked against two versions of libxcb once libX11 is upgraded.

For portupgrade users:

# portupgrade -rf libxcb

und dann mal in den Link, den ich oben schon erwähnte.

Du siehst, hier gibt es was zu tun, wenn du da durch willst.