Gnome 2.28 - Icons/Window-Borders verschwinden nach Login

reakktor

Well-Known Member
Aloha

folgendender Ausgangszustand:
- Habe über Snaphot FreeBSD8-STABLE Image 201002 (amd64) meine Desktop-Maschine frisch installiert
- Installation von gnome2.28 per sysinstall
- Desktop User zur Gruppe "operator" zugefügt
- "procfs" gemounted
- gnome2, hald, policykit usw. per rc.conf sind gestartet

Problem:
Nach dem Login über gdm erscheint alles erst normal, klappt vorerst für ein paar Sekunden alles. Nur nach ca. 5 Sekunden verschwinden alle Desktop-Icons und werden durch die typischen "fehlend"-Icons ersetzt.

Wenn ich nun auslogge, per gdm auf "other" klicke, dann direkt wieder auf meinen User klicke und einlogge, habe ich eine kleine Chance, dass alles funktioniert. Wenn ich dieses Spielchen nur oft genug wiederhole, klappt es irgendwann, dann wird alles normal angezeigt. Manchmal sofort, manchmal erst nach zig Logins, manchmal auch gar nicht.

Will betonen - keine Extras, alles direkt aus den Paketen per sysinstall geholt, quasi alles "Default" und nur wenige Minuten alt vor diesem Post.

Kennt jemand diesen (Gnome-)Problem ?

Wäre sehr dankbar für Tips

Grüße
reakktor
 

reakktor

Well-Known Member
Kam jetzt erst dazu, das mal genau anzuschauen:

.xsession-errors:

/usr/local/etc/gdm/Xsession: Beginning session setup...
Need to find the location of a program? Use "locate program_name".
-- Dru <genesis@istar.ca>
/usr/local/etc/gdm/Xsession: Setup done, will execute: dbus-launch --exit-with-session /usr/local/bin/seahorse-agent --execute gnome-session

** (process:1954): WARNING **: Unable to allocate secure memory from gnome-keyring.


** (process:1954): WARNING **: Proceeding using insecure memory for password fields.

gnome-session[1954]: WARNING: Could not parse desktop file /home/testuser/.config/autostart/xfconf-migration-4.6.desktop: Key file does not have key 'Name'
gnome-session[1954]: WARNING: could not read /home/testuser/.config/autostart/xfconf-migration-4.6.desktop
gnome-session[1954]: WARNING: Could not parse desktop file /home/testuser/.config/autostart/xfce4-settings-helper-autostart.desktop: Key file does not have key 'Name'
gnome-session[1954]: WARNING: could not read /home/testuser/.config/autostart/xfce4-settings-helper-autostart.desktop
GNOME_KEYRING_SOCKET=/var/tmp/keyring-NLq8An/socket
SSH_AUTH_SOCK=/var/tmp/keyring-NLq8An/socket.ssh

** (process:1980): WARNING **: Unable to allocate secure memory from gnome-keyring.


** (process:1980): WARNING **: Proceeding using insecure memory for password fields.

Window manager warning: Failed to read saved session file /home/testuser/.config/metacity/sessions/1034ccaa116e076aba127305956367968500000019540021.ms: Failed to open file '/home/testuser/.config/metacity/sessions/1034ccaa116e076aba127305956367968500000019540021.ms': No such file or directory

** (gnome-power-manager:2011): WARNING **: This machine is not identified as a laptop.system.formfactor is desktop.

** (gnome-power-manager:2011): WARNING **: This machine is not identified as a laptop.system.formfactor is desktop.
** (gnome-power-manager:2011): DEBUG: This machine is not identified as a laptop.system.formfactor is desktop.
** (gnome-power-manager:2011): DEBUG: We are not a laptop, so not even trying

MCS->Xfconf settings migration complete


(gnome-settings-daemon:1979): Gdk-WARNING **: gdkproperty-x11.c:325 invalid X atom: 343
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
(Details: serial 644 error_code 8 request_code 20 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

** (soffice:2081): WARNING **: unable to get gail version number
 

juedan

FreeBSDler
Hallo reakktor,

Window manager warning: Failed to read saved session file /home/testuser/.config/metacity/sessions/1034ccaa116e076aba127305956367968500000019540021.m s: Failed to open file '/home/testuser/.config/metacity/sessions/1034ccaa116e076aba127305956367968500000019540021.m s': No such file or directory

Mit diesem Problem bist Du anscheinend nicht alleine. Bei Redhat gibt es dazu einen Bugreport und die Gnome-Leute sind gerade dran, den Fehler zu finden und zu beheben.
Möglicherweise wirkt sich das auch auf den Nautilus aus.
Als Workaround wird genannt, dass Du einmal die Gnome-Session speicherst. In den Systemeinstellungen gibt es dazu die Möglichkeit. Dann meldest Du dich ab und wieder an. Danach schaltest Du bitte das Speichern wieder ab.

(gnome-settings-daemon:1979): Gdk-WARNING **: gdkproperty-x11.c:325 invalid X atom: 343
[...]
Das dürfte sehr wahrscheinlich eine Folge obigen Bugs sein.

Viele Grüße

JueDan
 

reakktor

Well-Known Member
...
Als Workaround wird genannt, dass Du einmal die Gnome-Session speicherst. In den Systemeinstellungen gibt es dazu die Möglichkeit. Dann meldest Du dich ab und wieder an. Danach schaltest Du bitte das Speichern wieder ab.
...

Yeah, scheint nun wieder alles reibungslos zu laufen. Hat genau wie beschrieben funktioniert.

Vielen Dank für den Tip! :)
 

reakktor

Well-Known Member
Da hab ich mich leider zu früh gefreut - Problem existiert leider nach wie vor.

Das session-save war - fürchte ich - nur der statistische Ausnahmefall, wo es nach 2x rebooten zufällig geklappt hat.
Wenn ich direkt nach dem booten beim gdm Login gleich auf "other" klicke, dann "abbrechen", und dann meinen User auswähle und einlogge, klappt es zu 90%.

Leider alles beim alten - .xsession-errors hat sich nix geändert. Somit steh ich wieder am Anfang, Tips willkommen....
 
Oben