Gnome Update auf Version 2.14.1

Styx

Universaldilettant
Es gibt ja - wie die meisten sicherlich bereits bemerkt haben - mal wieder eine neue Version von GNOME und damit auch von einigen Libs, die schon in der Vergangenheit einige Probleme machten.

Die gute Nachricht: Das Gnome-update-script wird nicht benötigt.
Die schlechte Nachricht: Wenn man den mDNSResponder installiert hat, den viele KDE-Anwedungen brauchen, gibts Probleme.

Das Thema wurde hier schon mal angesprochen:
http://www.bsdforen.de/showthread.php?t=14559

Sinnigerweise ist der Thread im "Müll und Testforum", das nicht auf der Portalseite angezeigt wird, deshalb hier nun dieses Thema.

Der Tipp vom Fusselbär scheint also nicht immer zu funktionieren. Hat jemand eine andere Idee bzw. Lösung parat?

Edit:
Soeben kamen auf den entsprechenden Maillinglisten folgende Nachricht:

ahze 2006-05-01 15:39:54 UTC

FreeBSD ports repository

Modified files:
net/avahi Makefile pkg-plist
Log:
- Disable mDNSResponder in avahi so net/mDNSResponder and avahi don't
conflict

Requested by: kde@

Revision Changes Path
1.23 +3 -4 ports/net/avahi/Makefile
1.8 +0 -7 ports/net/avahi/pkg-plist

Wenn man noch ein paar Stündchen wartet, sollten alle cvs-Server auf dem neusten Stand sein und die Probleme somit (hoffentlich!) gelöst sein.
 
Zuletzt bearbeitet:

Fusselbär

Makefile Voyeur
Hallo Styx,

den Post hatte ich in das Müll und Testforum gesetzt,
weil ich dachte, das es vielleicht für den Newsbereich
interessant wäre.
Habe dann moonlook per PM benachrichtigt ,
ob das was für den Newsbereich wäre.
War aber wohl schlechtes Timing,
moonlook ist dann offline gegangen.
Auch Moderatoren brauchen mal eine Pause. ;)
Seitdem habe ich moonlook noch nicht wieder online gesehen.

Wollte dann nicht für Chaos sorgen,
indem ich kreuz und quer weiter PMs verschicke



Nun aber zu Deiner Frage:
bei mir hing es vor allem an devel/gnomevfs2
Also hatte ich mir das Makefile in
Code:
/usr/ports/devel/gnomevfs2
angeguckt.
Da fand ich dann zwischen Zeile 66 und 70:
Code:
.if !defined(WITHOUT_MDNS)
LIB_DEPENDS+=	avahi-client:${PORTSDIR}/net/avahi
.else
CONFIGURE_ARGS+=--disable-avahi
.endif
Das lies sich dann bequem mittels
Code:
make config
per ncurses Menü abschalten
Code:
[ ] MDNS   Enable Bonjour/Rendezvous support
Dann hat devel/gnomevfs2 bei mir gebaut.

Installiert ist jetzt bei mir:
Code:
mDNSResponder-107.1_2 "Apple's mDNSResponder"
howl-1.0.0_1        Zeroconf/Bonjour(tm) implementation


Gruß, Fusselbär
 

Styx

Universaldilettant
Problem gelöst!

Danke für diese Ausführungen, Fusselbär, aber das Problem ist im Portstree wohl bereits gefixt worden. Unter ports/UPDATING steht mittlerweile folgendes:

20060429:
AFFECTS: All GNOME users
AUTHOR: gnome@FreeBSD.org

GNOME has been updated to 2.14. This new release does NOT require the
use of the gnome_upgrade.sh script. That script should not be used.
Instead, use the following simple recipe:

pkgdb -Ff
portupgrade -o net/avahi -f howl
portupgrade -o x11/gnome-screensaver -f xscreensaver-gnome
portupgrade -a

Bei mir lief es nun einwandfrei durch. Der Fehler kam übrigens dadurch zu Stande, dass man bei den GNOME-Entwicklern das wohl zwar getestet hat, aber keiner von den 10 Testern neben GNOME auch noch KDE auf dem Rechner hatte. Sonst wäre der Fehler durchaus aufgefallen. Das ist dann wirklich sehr usernah getestet worden...
 
Oben