gnu tar, NT-Filesystem und Umlaute in den Dateinamen - wie auspacken?

cheasy

SysAdm*n from Hell
Hallo allerseits,

nachdem die DOSe meines Vaters (vermutlich durch Virenbefall) endgültig geschrottet wurde, muss ich den umfangreichen Datenbestand auf den neuen Rechner transferieren. Also: Knoppix-CD in die kaputte Kiste (C:\ ist da größtenteils gelöscht und voller Virenmüll), externe Festplatte an die DOSe und einschalten. D:\ (NTFS) mounten und mit (gnu) tar auf die exteren Platte sichern.

Dummerweise enthalten die Dateinamen Umlaute, und BSD-tar verschluckt sich beim Auspacken der Dateien, die Umlaute enthalten ("File \0xnnnderung not found", die Datei hieß "Änderung"). Die Datei wird dann auch nicht geschrieben.

Gibt's einen besseren Weg, die Dateien (>10.000) aus dem NTFS des alten Rechners auf den neuen Rechner (FreeBSD) zu transferieren?
 

zuglufttier

Well-Known Member
Oder vielleicht mittels eines FTP-Programms die Dateien übertragen? Könnte auch klappen, denke ich... Knoppix hat ja bestimmt einen FTP-Client und ein Server ist auch schnell aufgesetzt. Ansonsten würde ich auch zip oder sowas in die Richtung probieren.
 

-Daemon-

Well-Known Member
Wie zuglufttier schon schrieb: ftp-Server aufsetzen (wobei, sftp sollte es auch tun ;)) und dann die Daten auf die FreeBSD-Maschine rueberschieben :) Das ist meiner Meinung nach am einfachsten ;)
 

cheasy

SysAdm*n from Hell
scp aufgesetzt, Daten rübergeschoben -- die Dateien mit Umlauten fehlen. Ebenso mit ftp -- kein Wunder, beide benutzen dieselben [LinSucks]-Library-Calls.

Noch eine Idee, irgendjemand?
 

-Daemon-

Well-Known Member
Huch? Ich hatte bisher noch nie Probleme mit Umlauten und ftp (Weder mit "Windows", Solaris, Debian, FreeBSD).
Das einzige Problem das ich bisher hatte, war, dass ich nicht immer den binary mode verwendet habe und deswegen aus den Daten Datenmuell wurde -- aber das ist ein Fehler meinerseits gewesen... :ugly:
 

Yamagi

Possessed With Psi Powers
Teammitglied
Boote die DOSe unter Frenzy und mounte das Dateisystem mittel mount_ntfs. Dort kannst du mit der Option -C ein Charset angeben, in welches die UTF-8 Dateinamen übersetzt werden. Dann hast du Zugriff auf alle Dateien und kannst sie über NFS oder SFTP/SCP kopieren.
 

cheasy

SysAdm*n from Hell
Es ging nicht um die Umlaute im Dateiinhalt, sondern um Umlaute im Dateinamen. Bei > 50.000 Dateien ist das Problem leider nicht mal eben händisch zu lösen ;)
 

cheasy

SysAdm*n from Hell
Da schau her, ein brauchbarer Tip!
Danke, ich werd die Ergebnisse hier veröffentlichen, sobald ich wieder bei meinem alten Herrn war.
 
Oben