GPD Micro PC

SierraX

Well-Known Member
Bei der Neuinstallation (das offizielle ubuntu runtergeschmissen) war kein xenodem ausgewählt. Singleuser hab ich noch nicht probiert… wollte ich noch machen weil mir nicht klar ist, ob /etc/firmware überhaupt befüllt wurde.
 

SierraX

Well-Known Member
@midnight: boot -s bleibt an der gleichen Stelle hängen. Muss es wohl doch nochmal über den installations usb stick probieren… da komm ich aber erst heut Abend zu.
 

midnight

OpenBSD & FreeBSD
Hm schade. Das war ja meine Hoffnung, dass Du bei der Installation beim Anlegen eines Users "xenodm" ausgewaehlt hast.

Das Problem scheint ja inteldrm zu sein. Im Prinzip muesstest du verhindern, dass die inteldrm-firmware installiert und geladen wird. Ich weiss allerdings aus dem Kopf nicht, wie das jetzt nachtraeglich zu bewerkstelligen ist, wenn das System nicht bootet. Evtl. ueber bsd.rd, mount, chroot, usw.

Nach einer Neuinstallation wird die Firmware beim ersten reboot aus dem Netz geladen und installiert. Hier wuerde es reichen, das System ohne Netzwerk zu starten und zu schauen, ob das System ohne Fehler bootet.
 

CommanderZed

OpenBSD User
Teammitglied
Shit, hab erst jetzt gesehen das es um OpenBSD geht.

Da hab ich mit meinen HomeServer schon ewig ein ähnliches Problem, könnte sogar das exakt gleiche sein.

Dort deaktiviere ich inteldrm einfach komplett - manchmal bootet er durch und hängt sich nach 0,5 bis 10 Tagen auf, manchmal bootet er auch garnicht, ist auch von release zu release unterschiedlich. Mache das inzwischen so automatisch das ich das inzwischen verdrängt habe ;)

Code:
boot -c
disable inteldrm
quit

oder vorm reboot im kernel hinterlegen:

Code:
config -ef /bsd
disable inteldrm
quit

sha256 -h /var/db/kernel.256 /bsd

Ist aber nicht kernel-upgrade sicher
 

CommanderZed

OpenBSD User
Teammitglied
Achso, noch eine kleine Ergänzung: Der Fehler ist (zumindest bei mir) unabhängig davon ob man X startet da er das intel drm ja schon beim boot-prozess für die höher aufgelöste Konsole lädt.
 

SierraX

Well-Known Member
Mit
boot bsd.rd landet man offenbar im install kernel … dort braucht man bei dem Teil eine externe Tastatur, um in den shell-modus zu gelangen und auch um sich dort zu bewegen.
Bash:
cd /dev
sh ./MAKEDEV sd0
mount /dev/sd0a /mnt
cd /mnt/etc/
cd firmware
ls

IMG_2513.jpg

Und wie se sehen… sehen se nix… mit intel… reicht es die teile da rein zu kopieren?
 

CommanderZed

OpenBSD User
Teammitglied
Schön wäre es gewesen… leider funktioniert im UKC weder die interne noch externe Tastaturen.

Ja, bei mir geht nur ne PS2 Tastatur da, alternativ könntest du glaub ich noch seriell versuchen

Also das mit der Firmware hatte ich glaub ich auch verschiedenes probiert ohne ein ergebniss, da er inteldrm auch ohne firmware irgendwie lädt, zb beim ersten boot.

Du könntest bsd.rd, dein fs mounten, chrooten und dann ggf. dem /bsd modifiezieren
 
Oben