groff in 9.2

Mendenlama

New Member
Hallo an alle,

ich habe gerade NetBSD 9.2 installiert. Dabei habe ich festgestellt, daß groff mit Version "GNU groff version 1.19.2" vorinstalliert ist. Im Repository gibt es aber bereits Version 1.22.4. Wenn man diese neue Version installiert, wird die alte nicht entfernt (läßt sich auch mit pkgin remove nicht entfernen), die ausführbaren Dateien der neuen Version landen in /usr/pkg/bin.

Die neue Version hat gegenüber der alten den Vorteil, daß der PDF-Postprozessor (gropdf) enthalten ist (sowie einige weitere PDF-Erweiterungen). Aus dem Grund möchte ich sie benutzen. Gibt es einen sauberen Weg, die alte Version zu entfernen?

Mein Workaround bislang: ich habe im Suchpfad /usr/pkg/bin vor /usr/bin gesetzt. Dadurch werden die neuen Programme zuerst gefunden. Gibt es da nichts besseres?

Alles Gute
Peter
 

darktrym

Fahnenträger
Meines Wissens nicht da groff warum auch immer in Base ist. Ist ja generell der Weg, ich überlade bspw. ls mit colorls
 
Oben