• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Grub erkennt FS von 5.1 net ?

Ginku

Well-Known Member
Themenstarter #1
Hallo,

schon lange nicht mehr gepostet .... peinlich, peinlich.....

Habe meine 4.8er Installation zu Gunsten einer 5.1er (beta) gelöscht. Leider bekomme ich sie mittels Grub nicht mehr gebootet -> Fehlermeldung:

Booting FreeBSD
root (hd0,3a)
Filesystem type unknown, partition type 0xa5
kernel /boot/loader
Error 17: Cannot mount selected partition

Das Slice und die root-Partition liegen exakt genau so wie vorher bei der 4.8er Installation. Auch die Grub Konfiguration ist unverändert (Grub wird über eine benachbarte Linux Partition ausgeführt). Hat sich das filesystem von 4.x nach 5.x tatsächlich so geändert, dass Grub nichts mehr damit anfangen kann ? Oder stimmt die Vorgaber "/boot/loader" nicht mehr ?

Danke schonmal .....

Grüße

Ginku
 
#3
Original geschrieben von Ginku
Hallo,

schon lange nicht mehr gepostet .... peinlich, peinlich.....

Habe meine 4.8er Installation zu Gunsten einer 5.1er (beta) gelöscht. Leider bekomme ich sie mittels Grub nicht mehr gebootet -> Fehlermeldung:

Booting FreeBSD
root (hd0,3a)
Filesystem type unknown, partition type 0xa5
kernel /boot/loader
Error 17: Cannot mount selected partition

Das Slice und die root-Partition liegen exakt genau so wie vorher bei der 4.8er Installation. Auch die Grub Konfiguration ist unverändert (Grub wird über eine benachbarte Linux Partition ausgeführt). Hat sich das filesystem von 4.x nach 5.x tatsächlich so geändert, dass Grub nichts mehr damit anfangen kann ? Oder stimmt die Vorgaber "/boot/loader" nicht mehr ?

Danke schonmal .....

Grüße

Ginku
Anscheinend handelt es sich um ein bekanntes Problem.
Grub erkennt zwar UFS2 Dateisysteme - kann aber nicht von ihnen lesen. Und da bei FreeBSD 5.1-BETA der Default UFS2 ist, sieht es hier erstmal schlecht aus.

AFAIK gibt es derzeit auch keinen Patch o.ä. für grub - vielleicht solltest du erstmal noch auf UFS1 setzen?

Gruß
 

Ginku

Well-Known Member
Themenstarter #4
Re: Re: Grub erkennt FS von 5.1 net ?

AFAIK gibt es derzeit auch keinen Patch o.ä. für grub - vielleicht solltest du erstmal noch auf UFS1 setzen?
Danke saintjoe,

was müsste ich da konkret vorgeben ? Ich habe die Voreinstellung "165" übernommen (war das nicht bei 4.8 auch vorgegeben) ?

Ginku
 

Kaeptn

Well-Known Member
#6
Also die ID im MBR hat mit dem Filesystem welches dann auf die Platte kommt nix zu tun.
Typ 165 ist nach wie vor OK.

Das Filesystem wird mit newfs angelegt, nach dem labeln der slices.

Um ufs1 zu definieren: -O1
Und in sysinstall glaube ich einfach "1" drücken (nicht F1)

Grüsse
 

Ginku

Well-Known Member
Themenstarter #7
Das Filesystem wird mit newfs angelegt, nach dem labeln der slices. Um ufs1 zu definieren: -O1
Und in sysinstall glaube ich einfach "1" drücken (nicht F1)
Woll, das wer'd ich dann morgen mal checken.......müüüde...

Danke :-)

n8

Ginku
 
#8
Hallo
Ich schon wieder...
Veruch es mal mit diesem Eintrag

title FreeBSD 5.1
root (hd0,3)
makeactive
chainloader +1

Gruss roebel
 
Zuletzt bearbeitet:

Ginku

Well-Known Member
Themenstarter #9
Hallo
Ich schon wieder...
Veruch es mal mit diesem Eintrag

title FreeBSD 5.1
root (hd0,3)
makeactive
chainloader +1
:-)) danke roebel und gruezi,

ich kann's jetzt leider net ausprobieren, weil ich 5.1 neu installiert habe und dabei auf UFS 1 zurückgegangen bin.
Parallel habe ich auf der Grub-Bug-Mailingliste in Erfahrung bringen können, dass UFS 2 derzeit von Grub nicht unterstützt wird - wie saintjoe schon vermutete. Ich wurde aufgefordert, einen patch zu schreiben................prust..........lach.........bin leider Banker und kein Programmierer ;-)

Was soll das bewirken: "makeactive" und "chainloader +1" ?

Schönes Wochenende für alle.......naja.................fast

Ginku
 

Ginku

Well-Known Member
Themenstarter #11
Alles beschrieben unter
Funktioniert auch mit UFS 1 und.....
Hallo roebel,

danke für den Link, den kannte ich noch nicht. Zieh' ich mir baldmöglichst mal rein. Übrigens, mit UFS1 funzt grub...die Nagel-
probe mit UFS2 stünde dann noch aus :-)

Dann schau'n mer mal, dann seh'n wir's schon :-))

SchöWO

Ginku