handbrake startet nicht

Lance

Well-Known Member
Fehlermeldung im Terminal:

Code:
Abort trap (core dumped)

Betrifft ghostbsd 20.11.28, aber das basiert ja auf
Code:
12.2-STABLE FreeBSD 12.2-STABLE GENERIC  amd64
 

Andy_m4

Well-Known Member
Also ich hab hier sozusagen ein Original
FreeBSD 12.2-RELEASE-p2 r368463 GENERIC amd64
und dort lässt es sich problemlos starten.

aber das basiert ja auf
Das ist nicht ganz korrekt. Soweit mir bekannt ist, basiert GhostBSD auf TrueOS was dann wiederum selbst auf den benannten Entwicklungszweig von FreeBSD beruht (daran aber auch noch Modifikationen vornimmt).

Generell bin ich ja immer etwas skeptisch was FreeBSD-Derivate angeht. Die Nutzer und Entwicklerbasis ist da ohnehin nicht sonderlich groß. Wenns also irgendwelche Bugs oder sonstige Probleme gibt, hat man bei nem originalen FreeBSD immer noch die besten Chancen das sie gefunden und zeitnah gefixt werden. Zumal es jetzt auch nicht so kompliziert ist FreeBSD als Desktop-System einzusetzen.
Aber das nur so als generelle Anmerkung.
 

mr44er

moderater Moderator
Teammitglied
Zusammengesponnen, wegen deiner Info aus dem anderen Thread wegen Intel+nvidia: wenn handbrake wegen vorhandenem nvidia-Treiber, aber nicht laufender nvidia-gpu nvenc (...oder quick sync) aktivieren will, könnte es deswegen knirschen.
 

Lance

Well-Known Member
t. Soweit mir bekannt ist, basiert GhostBSD auf TrueOS was dann wiederum selbst auf den benannten Entwicklungszweig von FreeBSD beruht (daran aber auch noch Modifikationen vornimmt).
Dieser Irrglaube sollte endlich mal passe sein. Seit TrueOS eingestellt ist oder auch kurz davor basiert GhostBSD eben nicht mehr darauf. Ein
Code:
uname -a
brachte den von mir oben geposteten Code hervor. Wie "original" das jetzt ist, weiss ich natürlich nicht aber laut offizieller Info basiert GhostBSD auf FreeBSD und OpenRC.

Zusammengesponnen, wegen deiner Info aus dem anderen Thread wegen Intel+nvidia: wenn handbrake wegen vorhandenem nvidia-Treiber, aber nicht laufender nvidia-gpu nvenc (...oder quick sync) aktivieren will, könnte es deswegen knirschen.
danke für den Hinweis. Nun ich habs nur mal so getestet aber brauchen tu ich es zum Glück normalerweise nicht.
 

pit234a

Well-Known Member
aber, handbrake ist doch eine Drittanbieter SW. Wir reden doch über multimedia/handbrake ?

Da kommt ja bei mir zuerst mal die Frage auf, wer das denn installiert hat?
Wenn du es aus dem Live-System ghostbsd-irgendwas direkt startest, sollte es funktionieren. Wenn nicht, sollte man dort nachfragen und ich wette, dass die immer noch ein sehr kleiner Zirkel sind und nicht genug Man-Power haben, alles und jede Einzelheit zu testen. Da können schon mal Pakete hineingeraten, die nicht getestet sind und zur Erstellung der Live-Version eben kaputt waren.
Wenn du ghostbsd-irgendwas nicht live benutzt, sondern installiert hast (wie auch immer), dann solltest du vielleicht diese Installation auch erst mal updaten, wie man das ja mit allen Installationen tun würde. Also sowohl das FreeBSD, als auch alle Pakete.

Die Paket-Versionen, die einem Live-System zu Grunde liegen, können ja dramatisch veraltet sein und wenn da tatsächlich mal eine kaputt war, würde die durch einen entsprechenden Update ja auch erneuert.
Kaputte Pakete gibt es natürlich auch unter FreeBSD gelegentlich mal. Die wenigen Maintainer können das nicht alles immer so im Griff haben, wie das bei professionellen Systemen womöglich der Fall ist. Im Grunde genommen muss man sich wohl eher wundern, dass es durchschnittlich dermaßen gut funktioniert, obwohl es kaum Leute gibt, die tatkräftig helfen.
Hier gibt es aber die Rückmeldung, dass dieses Paket in einem aktuellen FreeBSD funktioniert.

Einen ersten Überblick kann einem der Start der SW aus einer shell heraus geben. Da werden dann oft unerfüllte Abhängigkeiten sichtbar, meiner Erfahrung nach die Nummer Eins der Fehlerquellen: eine passende Lib wird nicht gefunden, weil eine neuere (ältere) Version verlangt wird.
 

Lance

Well-Known Member
Wir reden doch über multimedia/handbrake ?
Richtig


Wenn du es aus dem Live-System ghostbsd-irgendwas direkt startest, sollte es funktionieren.
Klar, aber ich hatte tatsächlich GhostBSD installiert und musste nur lediglich - mal wieder - die dt Sprache einstellen. Den „EFI“ Bug haben sie endlich gefixt. (Hatte ich sonst manuell mittels fstab Eintrag fixen müssen).
so dass es Out Of The Box echt gut und sauber und sehr flott läuft. - Mal sehen wie lange diesesmal.
Einen ersten Überblick kann einem der Start der SW aus einer shell heraus geben.
Ja, siehe oben, erster Post.
 
Oben