• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

HD Auflösung einfach weg

Themenstarter #1
Hi Leute,
monatelang hat mein OpenBSD 6.3 jetzt einwandfrei gelaufen: Keine Abstürze, kein Gezicke - eben einwandfrei.
Die letzten 14 Tage hab ich das System dann nicht genutzt. Heute beim Start dann folgendes Verhalten:
-System läuft hoch wie immer
- Einloggen als user auch wie gewohnt
- manuelles Aufrufen von Xorg via startx funktioniert, aber nur in 1024x768. Egal, welchen Windowmanager ich benutze.
- Aufrufen von startx als root oder mittel su bringt dann die korrekte HD-Auflösung.

Ich hab garantiert zwischendrin nicht irgend etwas installiert oder konfiguriert - ich schwör's.

Wenn ich als normaler user einen wm aufrufe, der die Möglichkeit zum Einstellen der Auflösung bietet (wie xfce), dann wird die Einstellung akzeptiert und ist auch beim nächsten Start wieder genau so. Aber per default startet jetzt alles mit 1024x768.

Wo muss ich hinschauen, um das wieder zu ändern?

Berni
 
#2
Hast Du zwischenzeitlich irgendwas an den BIOS-Einstellungen geaendert? Nutzt Du eine xorg.conf? Wenn ja, kannst Du diese mal hier posten? Evtl. gibt die ``/var/log/Xorg.0.log'' noch irgendwelche Hinweise auf Probleme. Was sagt denn ``xrandr''?
 
Themenstarter #3
Nein, am BIOS wurde nichts geändert und eine xorg.conf wird nicht genutzt.

Aber halt: Was ich geändert habe, ist, dass der Monitor jetzt mit VGA angesteuert wird und nicht mehr über HDMI.
Sekunde, ich stöpsel kurz um .......
............................................................
............................................................

Kurzer Neustart - und mit HDMI ist die Welt wieder in Ordnung.

Aber warum klappt das nicht über VGA? Auch damit ist doch full HD möglich.
 
R

ralli

Guest
#4
Hallo @berni51,

um die Auflösung bei einem WM zu ändern, brauchst Du kein spezielles Programm eines Desktop. Trage einfach die gewünschte Auflösung in die .xinitrc ein wie folgt ein:

Code:
xrandr -s 1920x1080
Und VGA ist nicht mehr für höhere Auflösungen geeignet, zumindest nicht bei den neueren Monitoren, da ist bei 1024x768 Schluß! Schön, das es wieder funktioniert.:)

Grüße Ralph
 
Themenstarter #5
Danke Ralli. Mit dem xrandr - AUfruf hab ich jetzt wieder meine 1920x1080, obwohl der Monitor über VGA angeschlossen ist.
Es klappt also wieder - aber warum zwischendrin nicht? Naja, eigentlich egal. :-)

Grüße
Berni
 

Rakor

Administrator
Mitarbeiter
#6
Weil der Rechner mit dem Monitor über VGA nicht so sprechen kann wie er es über HDMI kann. Daher geht er sicherheitshalber in eine geringe Auflösung, die (fast) jeder Monitor können sollte. Für dein Rechner ist das nicht der selbe Monitor am anderen Anschluss sondern ein unbekanntes Anzeigeobjekt an VGA, dafür ist ein bekannter Monitor am HDMI verschwunden.