Hilfe, kann mich nicht mehr einloggen

klimaschreck

Well-Known Member
Hallo zusammen,

ich habe mein FreeBSD System amd 11.3 auf 12.1 aktualisiert. Was bisher nicht geklappt hat, ist das Einloggen über den sddm von plasma. Es erscheint wie gewohnt der Startbildschirm zum Anmelden. Wenn ich auf der Tastatur ein Zeichen meines Passwort eintippen will, wird nicht unbedingt ein Zeichen (gefüllter Kreis) im Passwortfeld angezeigt. Mal erscheint kein Zeichen, mal sind es direkt drei Zeichen. Zeichen löschen über die Backspace-Taste funktioniert auch nicht.

Ich habe die Logfiles von Xorg und sddm durchgeschaut. Es sind dort keine Fehlermeldungen (EE) enthalten. Mir ist jedoch die folgende Zeile in messages aufgefallen:

Code:
Feb 23 19:59:20 stagioni console-kit-daemon[1025]: WARNING: Error waiting for native console 1 activation: Inappropriate ioctl for device

Könnte dies etwas bedeuten? Habt ihr sonst noch Ideen?
 

Kamikaze

Warrior of Sunlight
Es gab da ein Xorg Update, installiere mal xorg-server und die xf86-input Pakete neu. Ich hatte mich da auch letztens mit ausgesperrt (kein 2. Rechner für SSH, Xorg nahm keine Eingaben und damit konnte ich dann auch nicht zurück auf die Konsole).
 

klimaschreck

Well-Known Member
Ja, ich habe mal startx ausprobiert. Es gab da auch Probleme mit den Tastatureingaben. Also liegt es nicht an sddm, sondern am Xorg. Bei mir waren die neuesten Xorg-Pakete (xorg-server 1.20.7.1 und xorg-driver 7.7.6) installiert. Ich habe sie und die xf86-input-* Pakte durch ältere Pakete ersetzt. Jetzt geht wieder alles.
 

lme

FreeBSD Committer
Ich habe das Problem jetzt auch. Weder ein Neubau der xf86-input-* Ports noch von xorg-server, libevdev und evdev-proto hat etwas geändert. Was nun?
 

lme

FreeBSD Committer
Jetzt geht es: Ich musste /usr/local/etc/X11/xorg.conf.d/input.conf löschen / leeren.
 

pit234a

Well-Known Member
bei mir lief es, nachdem ich meine /usr/local/etc/X11/xorg.conf.d/keyboard.conf angepasst habe und die Zeile für den keyboard driver auskommentierte:
Code:
pit@Celsius ~:- > cat /usr/local/etc/X11/xorg.conf.d/keyboard.conf
Section "InputClass"
    Identifier    "KeyboardDefaults"
#    Driver        "keyboard"
    MatchIsKeyboard    "on"
        Option          "XkbModel" "pc105"
    Option        "XkbLayout" "de"
    Option        "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
 

Yamagi

Possessed With Psi Powers
Teammitglied
Ich habe mir zusammengereimt, dass es darauf ankommt, wie man Xorg konfiguriert:
  • Alte Säcke wie ich, die den Autoconfig-Kram abschalten und eine vollständige Config nutzen, haben im Moment keine Probleme. Aber das Risiko, dass es ihnen in der Zukunft auf die Füße fallen wird. xf86-input-keyboard und xf86-input-mouse werden sicher nicht mehr ewig weiterentwickelt werden.
  • Wer sich auf Autoconfig verlässt, muss seine eventuell vorhandenen teilweisen Configs so anpassen, dass sie keinen Treiber angeben. Sonst kommt man mit der Magie, die seit dem Update libinput bevorzugt, in Konflikt und endet ohne Maus, Tastatur oder sogar beidem.
Das ist aber gefährliches, aus Beobachtung abgeleitetes Halbwissen.
 

bluescreen

verstört
Hallo !

Habe hier ein komplett frisch aus den Ports aufgesetzes System !
Also keine "Leichen" im Keller !

Test :

1. Wie unter Linux ohne config ein startx ausgeführt --> negativ !
2. Mit Xorg -configure --> alles gut

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/sysmouse"
Option "ZAxisMapping" "4 5 6 7"
EndSection

In rc.conf ist "moused" disabled !

Vielleicht hilfts ja !

Gruss
 

klimaschreck

Well-Known Member
Vielen Dank für eure Hinweise. Ich habe den Driver auskommentiert und nun funktioniert Xorg auch in der neuesten Version. Es gibt allerdings noch ein kleines Problem: Wenn ich von den vier Pfeiltasten die Taste Pfeil runter drücke, öffnet sich links unten das Hauptmenü, also als ob ich die Windows-Taste gedrückt hätte. Kann man das irgendwie verhindern?
 

pit234a

Well-Known Member
Wenn ich von den vier Pfeiltasten die Taste Pfeil runter drücke, öffnet sich links unten das Hauptmenü, also als ob ich die Windows-Taste gedrückt hätte. Kann man das irgendwie verhindern?

das ist natürlich nicht FreeBSD-typisch, nicht mal X-Server-zentrisch, sondern eine Eigenschaft deines Fenstermanagers oder Desktop-Environments (was ja auch nur eine Schnittstelle zu irgendeinem Fenstermanager darstellt).

Da niemand weiß, was du da nutzt, kann dir das auch niemand wirklich beantworten.
Von sehr lange zurück liegenden Zeiten erinnere ich ein KDE-Menü, in dem diese Tastatur-Kürzel gesetzt werden konnten (also eine GUI).

In meinem System ist OpenBox der Fenstermanager und ich habe in dessen Konfigurations-Datei meine Tastatur-Kürzel gesetzt.
Die Tasten erkenne ich mit xev(1) und benutze sie nach meinen Wünschen.

Windows-Taste gibt es auch auf meiner Tastatur, aber ich habe sie mit einem kleinen Teufelchen überklebt und weil ich kein voreingestelltes DE nutze, habe ich mir dann wohlüberlegt dort Funktionen hingelegt, wie es mir gefällt.
Wobei ich in den letzten Tagen gerade an der Stelle merkte, dass es gar nicht ganz so wohlüberlegt war, weil ich mir versehentlich durch eine falsche Tastenkombination innerhalb einer Woche zwei Mal den PC ausgeschaltet habe. Dicke Finger auf der falschen Taste!

Wie gesagt, das kann man einstellen. Aber wie du was mit deinem DE einstellen kannst, ist eine andere Frage.
Viele FreeBSD-Nutzer sind auch KDE-Nutzer.
Aber vielleicht hast du trotzdem mehr Erfolg, wenn du im Netz entsprechend suchst.
Eine Änderung der Tastenkombination eines DE ist ja vermutlich nicht auf FreeBSD beschränkt. Das Phänomen dürfte es auch bei GNU/Linux geben und die haben sehr viel mehr Anwender und deshalb findet sich da auch oft schneller eine Lösung, die dann auch für FreeBSD genutzt werden kann.
 

serie300

Well-Known Member
Meine Erfahrung ist auch, daß man sein einiger Zeit den xorg selber machen lassen soll. Habe (auf meinem radeon) System nach X Problemen vor einiger Zeit die /etc/X11/xorg.conf ganz raus. Nur noch in /usr/local/etc/X11/xorg.conf.d zwei kleine Dateien für Tastatur und Mausanpassung
 

klimaschreck

Well-Known Member
Ich nutze KDE plasma. Die Ausgabe von xev bei Pfeiltaste runter ist:

Code:
KeyPress event, serial 37, synthetic NO, window 0x600001,
    root 0x292, subw 0x600002, time 507138, (45,30), root:(1473,59),
    state 0x0, keycode 116 (keysym 0xff54, Down), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 40, synthetic NO, window 0x600001,
    root 0x292, subw 0x600002, time 507185, (45,30), root:(1473,59),
    state 0x0, keycode 116 (keysym 0xff54, Down), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

FocusOut event, serial 40, synthetic NO, window 0x600001,
    mode NotifyNormal, detail NotifyNonlinear

PropertyNotify event, serial 40, synthetic NO, window 0x600001,
    atom 0x161 (_NET_WM_STATE), time 507208, state PropertyNewValue

Kann man diese Abfloge irgendwie unterbinden?

Bei mir ist das Xorg -configure mit einer Fehlermeldung abgebrochen. Fehler war, dass ein zweiter Screen nicht gefunden wurde. Bei einer früheren (Raedon-)Grafikkarte waren mehrere Ausgaben möglich. Die Karte wurde defekt und ich habe sie gegen eine nvidia-Karte ausgetauscht. Daher habe ich diesen Weg nicht weiter verfolgt.
 
Oben