• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

HP nx6325 ACPI

Themenstarter #1
Hallo,
ich habe das nx6325 (AMD Turion X2 @ 1,6GHz) Notebook von HP unter Ubuntu Linux läuft ACPI auf anhieb tadelos. Unter FreeBSD 6.2 (beta) ist selbst der Installer so stark am ruckeln das man meinen könnte das Notebook hat sich aufgehangen. Nur will ich auf die ACPI Funktionen nicht verzichten müssen. d.h. ich möchte es nicht ohne ACPI starten.
Was könnte ich machen um es unter BSD zum laufen zu bringen?
 

zuglufttier

Well-Known Member
#2
ACPI wird normalerweise immer geladen... Ich hab ein Toshiba-Notebook eingerichtet und da genügte es, ein Kernelmodul zu laden, um die Tasten und weitere ACPI-Funktionen zu nutzen. Also einfach:

kldload acpi_toshiba.ko

Scheinbar gibt's aber kein spezielles Modul für HP-Notebooks... Keine Ahnung, was man da benutzen muss. Und das Ruckeln hört sich auch ziemlich komisch an. Klingt nicht so als ob das was mit ACPI zu tun hätte.
 

Cédric

aka decemplex
#3
Bei AMD64 kannst du probieren atpic in den Kernel zu compilieren / zu entfernen, da gabs auch noch in den sysctl's was mit atpic... ansonten kannst du auch noch die DSDT reparieren (das waren sehr im groben die Probleme, die ich mit meinem Asus hatte) - das sind jetzt so ein paar Stichwörter, ich weiss nicht ob du was damit anfangen kannst, für mehr hab ich gerade keine Zeit, zumal ich auch gerade kein BSD unter die Finger habe...
 
Themenstarter #4
Auszug aus der FreeBSD Doku:
Code:
[B][COLOR="Red"]11.16.3.3 System Hangs (temporary or permanent)[/COLOR][/B]

Most system hangs are a result of [COLOR="Red"]lost interrupts[/COLOR] or an interrupt storm. Chipsets have a lot of problems based on how the BIOS configures interrupts before boot, correctness of the APIC (MADT) table, and routing of the System Control Interrupt (SCI).

Interrupt storms can be distinguished from lost interrupts by checking the output of vmstat -i and looking at the line that has acpi0. If the counter is increasing at more than a couple per second, you have an interrupt storm. If the system appears hung, try breaking to DDB (CTRL+ALT+ESC on console) and type show interrupts.

Your best hope when dealing with interrupt problems is to try [COLOR="Blue"]disabling APIC [/COLOR]support with hint.apic.0.disabled="1" in loader.conf.
Wie gesagt, ich möchte nicht auf ACPI verzichten und unter Linux funktioniert ACPI wunderbar!
 

Cédric

aka decemplex
#5
hint.apic.0.disabled="1"

Das hatte ich auch bei mir gesetzt, hat die Interrupts beruhigt, und ist eigentlich auch das, was ich eben mit sysctl's meinte...