• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

i386-wine funktioniert bei mir nicht mehr

cabriofahrer

Well-Known Member
Themenstarter #1
Beim Ausprobierenwollen von Homura habe ich festgestellt, dass wine bei mir gar nicht mehr funktioniert. Da das mit homura nichts zu tun hat, eröffne ich einen neuen Thread. Ich weiß auch nicht, seit wann sich der Fehler eingeschlichen hat und wie, ob seit einem pkg upgrade vor einiger Zeit oder auch durch mehrere hitzebedingte Abstürze in jüngerer Vergangenheit. Jedefalls bekomme ich beim Starten egal welchen Spiels immer folgende Fehlermeldung:

Code:
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  151 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  715
  Current serial number in output stream:  719
$
Das bedeutet m.E., dass wine gar keine 3D-Beschleunigung vorfindet, was bedeuten kann, dass die Treiberversionen von nvidia nicht übereinstimmen.

Das sollte aber nicht sein denn ich habe das Package gerade frisch installiert und es erscheint die entsprechende Meldung bezüglich nvidia:

Code:
Proceed with this action? [y/N]: y
[1/3] Installing i386-wine-5.0_1,1...
[1/3] Extracting i386-wine-5.0_1,1: 100%
i386-wine-5.0_1,1 has been patched for use with nvidia graphics driver.  If
the version of the installed nvidia graphics driver changes execute (as root):
    sh /usr/local/share/wine/patch-nvidia.sh
to get 2D/3D acceleration to work with the nvidia driver.  Without this wine
will crash when a program requires 2D/3D graphics acceleration.
Sicherheitshalber habe ich das Skript ausgeführt, womit in der Vergangenheit das Problem bei einer Veränderung des nvidia-driver immer gelöst wurde.
Diesmal jedoch kein Erfolg:

Code:
# sh /usr/local/share/wine/patch-nvidia.sh
===> Patching i386-wine to work with x11/nvidia-driver:
=> Detected i386-wine: 5.0_1,1
=> Detected nvidia-driver: 440.100
!!! nvidia-driver 440.59+ already includes 32-bit drivers: nothing to do !!!
Terminating...
# pkg info | grep nvidia
linux-nvidia-libs-440.100      NVidia graphics libraries and programs (Linux version)
nvidia-driver-440.100          NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-settings-440.100        Display Control Panel for X NVidia driver
nvidia-xconfig-440.100         Tool to manipulate X configuration files for the NVidia driver
#
Es spielt keine Rolle, ob ich es mit i386-wine oder mit i386-wine-devel versuche, es ist immer das Gleiche. Irgendeine Idee?
 

cabriofahrer

Well-Known Member
Themenstarter #3