• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

inappropriate file type or format

Themenstarter #1
Hallo.

Ich hab folgendes Problem: OpenBSD 3.3 soll auf meinem
Laptop Installiert werden. Momentan befinded sich darauf
eine Linux und ein FAT32-Windows Partition. Die Linux
Partition soll dran glauben, dort soll die OBSD-Partition hin. Die Win-Partition enthällt einige Installationsdateien wie etc.tar.gz und base.tar.gz. Gebootet wird von der Bootfloppy, CD-Laufwerk gibts nicht. Die Restliche Install möchte ich über eine Serielle Verbindung durchführen. Das Problem sieht folgendermassen aus. Da die Dateien für die Install auf der FAT32-Partition liegen muss ich die Partition mounten.
Jedoch:

# mount_msdos /dev/wd0a /mnt
mount_msdos: /dev/wd0a on /mnt: Inappropriate file type or format

Hat jemand eine Idee was ich falsch mach?

(dmesg zeigt die gefundene wd0 an)

kunibert.
 

CW

Netswimmer
#2
Original geschrieben von kunibert
Hallo.

Ich hab folgendes Problem: OpenBSD 3.3 soll auf meinem
Laptop Installiert werden. Momentan befinded sich darauf
eine Linux und ein FAT32-Windows Partition. Die Linux
Partition soll dran glauben, dort soll die OBSD-Partition hin. Die Win-Partition enthällt einige Installationsdateien wie etc.tar.gz und base.tar.gz. Gebootet wird von der Bootfloppy, CD-Laufwerk gibts nicht. Die Restliche Install möchte ich über eine Serielle Verbindung durchführen. Das Problem sieht folgendermassen aus. Da die Dateien für die Install auf der FAT32-Partition liegen muss ich die Partition mounten.
Jedoch:

# mount_msdos /dev/wd0a /mnt
mount_msdos: /dev/wd0a on /mnt: Inappropriate file type or format

Hat jemand eine Idee was ich falsch mach?

(dmesg zeigt die gefundene wd0 an)

kunibert.

Hi

Probiere mal dies aus: mount -t msdos /dev/wd0a /mnt

Nebenbei kann ich dir diese Website mit einem OpenBSD-Erfahrungsbericht empfehlen ... sie covert zwar nicht die neueste Version 3.3, ist aber sonst ganz O.K., da sich im Install selbst nicht viel verändert hat: http://openbsddiary.org/

Gruß und gutes Installieren noch

CW
 
Zuletzt bearbeitet:

CW

Netswimmer
#4
FAT32

Original geschrieben von kunibert
hatte ich bereits probiert, bewirkt das gleiche
wie bei mount_msdos.
Dann musst du mit disklabel überprüfen, ob /dev/wd0a wirklich die Filesystem-Bezeichnung MSDOS trägt.

Schicke bitte eine disklabel-Anzeige.

Gruß

CW
 
#5
1. sollte das nicht /dev/wd0s1a sein? (Hab jetzt kein OpenBSD da...)
2. wenn du file hast, dann mit file -s /dev/wd0a ueberpruefen ob das ueberhaupt eine FAT Partition ist. (oder mit dd|hd auslesen, etc.)
 

CW

Netswimmer
#6
Original geschrieben von MrFixit
1. sollte das nicht /dev/wd0s1a sein? (Hab jetzt kein OpenBSD da...)
OpenBSD kennzeichnet seine Slices nicht mit s0 oder s1. Das macht FreeBSD. Unter OpenBSD werden die Slices überhaupt nicht kenntlich gemacht. Die kann man sich nur per fdisk anschauen.

Hier ein Ausschnitt darüber, was für eine Aufgabe fdisk unter OpenBSD hat:

"...Fdisk is a program to help with the maintenance of your partitions. This program is used at install time to set up your OpenBSD partition (this partition can contain several labels, each with filesystems/swap/etc.). It can divide space on your drives and set one active. ..."


Unter OpenBSD ist z.B. die erste IDE-Platte immer wd0, die zweite wd1 usw, wobei die Bezeichnung für das Slice entfällt. Es wird nur noch der Buchstabe für die jeweilige Partition innerhalb des Slices angezeigt. Und falls sich jetzt jemand fragen sollte, woher dieses wd kommt, so ist die Erklärung in dem Namen einer bekannten Plattenfirma zu suchen: Western Digital. Heute aber hat die Bezeichnung nicht viel mit ihr zu tun. Ist halt so geblieben ;)

Alles weitere steht in der sehr guten FAQ: http://www.openbsd.org/faq


2. wenn du file hast, dann mit file -s /dev/wd0a ueberpruefen ob das ueberhaupt eine FAT Partition ist. (oder mit dd|hd auslesen, etc.)



Und das mit file würde bei OpenBSD überhaupt nicht funktionieren, weil OpenBSD keine Option s für file hat. Und ohnehin ist file hier nicht notwendig, da man alles schön mit disklabel rauskriegen kann.

Einfach disklabel wd0 eingeben und schon wird die Plattenaufteilung mit den jeweiligen Filesystemen geliefert.


CW
 
Zuletzt bearbeitet: