• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Installation Sablotron auf FreeBSD 4.7

Dany

Well-Known Member
Themenstarter #1
Hallo,

ich versuche seit einiger Zeit die Software Sablotron auf unseren System (FreeBSD 4.7) zu Installieren. Leider ohne Erfolg.

Wenn ich den Befehl ./configure --with-expat-prefix=/usr/local/expat-1.95.6 ausführe erhalte ich folgende Fehlermeldung:
creating libtool
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc
checking how to run the C++ preprocessor... g++ -E
configure: error: prefix for Expat not valid (include dir)

Wenn ich nur ./configure ausführe erhalte ich folgende Ausgabe:
checking whether to build under GPL... no
checking whether to build the debugger... no
checking where to find xml parser... 0: not found
not found (panic)
configure: error: Couldn't find the expat libraries

Ich hoffe Ihr könnt mir weiterhelfen.

Danke Dany
 

oenone

Well-Known Member
#2
hm... es erwartet ein include-dir von expat...
gibt es im verzeichnis /usr/local/expat-1.95.6 ein unterverzeichnis include ?
ach ja, als expat-prefix solltest du /usr/local angeben... das nötige unterverzeichnis müsste es sich selbst suchen.

wenn nicht, probier mit parameter --with-expat-include-prefix und danach dann das include-verzeichnis von expat.

auf bald
oenone
 

Dany

Well-Known Member
Themenstarter #3
Weitere Fehlermeldung

Hallo,

danke für die schnelle Antwort.

Ich habe es nun mal mit folgenden Befehl versucht zu installieren:
./configure --with-expat-prefix=/usr/local --with-expat-include-prefix=/usr/local

Ich erhalte folgende Antwort:
checking expat.h usability... no
checking expat.h presence... yes
configure: WARNING: expat.h: present but cannot be compiled
configure: WARNING: expat.h: check for missing prerequisite headers?
configure: WARNING: expat.h: proceeding with the preprocessor's result
configure: WARNING: ## ------------------------------------ ##
configure: WARNING: ## Report this to bug-autoconf@gnu.org. ##
configure: WARNING: ## ------------------------------------ ##
checking for expat.h... yes
checking whether expat.h is broken... yes
configure: error: You probably have expat version 1.95.6. Please refer to:
http://sourceforge.net/tracker/index.php?func=detail&aid=676844&group_id=10127&atid=110127
for a description of the problem.

Hat jemand einen Tip?

Danke Dany