• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Installation von OpenBSD 3.4 auf Sun Ultra 10

Themenstarter #1
Hallo zusammen,

ich würde gerne auf meiner Ultra 10 OpenBSD 3.4 installieren, leider gibt es einige Probleme damit - vielleicht kann mir jemand von Euch weiterhelfen. Vielen Dank schonmal dafür!

Ich habe hier ein original OpenBSD 3.3 CD-Set, davon lässt sich der Rechner normal starten und die Installation würde sicher auch leicht gelingen, nun möchte ich jedoch direkt ein frisches OpenBSD 3.4 auf dem Rechner installieren.
Für die i386-Version habe ich mir schon erfolgreich ein ISO-Image erstellt, mit dem ich OpenBSD 3.4 auf einem PC installieren kann, bei der Sparc64-Version will mir das nicht gelingen, die Ultra 10 kann von der CD nicht booten ("Bad magic number in disc label. Can't open disc label package. Can't open boot device."). Das liegt sicher daran, daß ich bei `mkisofs' (unter Linux) falsche Parameter verwendet habe, leider finde ich auch nirgends die richtige Syntax für ein Sparc64-ISO (die Parameter für ein i386-Image funktionieren nicht und beim Herumprobieren hab' ich schon einige CDs "verbrannt"). Hat jemand von Euch einen Tipp für mich?

Als nächstes habe ich dann mal versucht, die 3.4er über Umwege zu installieren: Ich boote von der 3.3er CD, führe die ersten Schritte der Installation aus und wollte dann als Installationsquelle einen FTP-Server mit den 3.4er Installationsdateien auswählen - leider funktioniert das so nicht, da das Installationsprogramm die 3.3er Dateien erwartet. Gibt es eine Möglichkeit aus einer laufenden 3.3er Shell heraus das OpenBSD 3.4 Installationsprogramm aufzurufen?


Viele Grüße,
Thomas
 
Themenstarter #5
Hallo,

Original geschrieben von [moR-pH-euS]
erstell dir doch einfach die 3.4 boot-floppys, dann davon booten, per ftp installieren und gut is ;-)
Die Ultra 10 kann grundsätzlich nicht per Floppy gebootet werden, das funktioniert nur mit den SBus-Modellen (Ultra 1/2).


Trotzdem Danke,
Thomas
 
Themenstarter #7
Hallo,

Original geschrieben von madCode
evtl. hilft Dir der Link ja weiter:

http://dbforums.com/arch/181/2003/1/642945

...da werden mehrere Wege beschrieben unter anderem auch mkisofs
die Seite kenne ich schon und hab' auch versucht, mich an die Anweisungen zu halten.
Mit folgendem Kommando habe ich eine ISO erstellt, von der ich dann aber nicht booten konnte:
Code:
# mkhybrid -o OpenBSD34.iso -b OpenBSD/3.4/sparc64/floppy34.fs -J -l -R -r -V "OpenBSD 3.4" -A "OpenBSD3.4" .
Im Verzeichnis "OpenBSD/3.4/sparc64" liegen die Dateien aus ftp://ftp.openbsd.org/pub/OpenBSD/3.4/sparc64/.
"mkhybrid" ist auf meinem Debian-System, auf dem ich versuche die ISOs zu erstellen, übrigens nur ein Symlink auf "mkisofs".
Die weiteren im Forum erwähnten Tools "vnconfig" und "mksuncd" sind unter Debian leider nicht verfügbar.

Gruß,
Thomas
 
Zuletzt bearbeitet:
Themenstarter #8
Hi,

Original geschrieben von Kathse
hast du beim Erstellen der CD auf 512Kb Blocksize geachtet?
nein, zumindest nicht bewusst, ich hatte die Installationsanleitung so verstanden, daß dies nur für Floppies gilt.

Bevor ich wieder einige CDs umsonst "verbrenne": wie hast Du die Blocksize in `mkisofs' eingestellt? Ich konnte in der manpage dazu nichts eindeutiges finden.


Gruß,
Thomas
 
Themenstarter #9
Original geschrieben von madCode
...wenn´s nur um das booten von CD geht solltest du auf den OpenBSD Servern in dem Sparc Verzeichniss der 3.4er fuendig werden, da gibt es eine Boot CD.
Vielen Dank für den Tipp, damit hat es funktioniert. Ich habe mit folgendem Kommando das ISO-Image `cd34.iso' auf CD-R gebrannt, davon gebootet und die Installation gestartet:
Code:
/usr/bin/cdrecord -v gracetime=2 dev=0,0,0 speed=8 -dao driveropts=burnfree -eject -data /tmp/OpenBSD/3.4/sparc64/cd34.iso
Als Installationsquelle habe ich dann die CD ausgewählt, die ich vorher erstellt hatte und von der ich nicht booten konnte. Hat wunderbar funktioniert und die Installation ist auch schon beendet.
Nur den X-Server konnte ich noch nicht starten, weiss jemand, ob es da bei der Ultra10 mit on-board Grafik Probleme gibt? Ich hatte vorgestern auf dem CCCongress mit einem OpenBSD-Entwickler gesprochen und der hatte da irgendwas in der Richtung erwähnt.


Nochmal vielen Dank Euch allen,
Gruß Thomas