• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Installationsversuch 6.1.5

beate

Well-Known Member
Themenstarter #1
Hallo in die Runde,

nach längerer BSD-Abstinenz (zuletzt NeBSD 1.6.1 / Sparc und Openbsd 3.7 /Sparc) komme ich wieder auf BSD zurück - mich nerven die aktuellen Trends der Linux-Ecke zu sehr (systemd..., ständig wird alles größer umgekrempelt).

Leider musste ich einen Versuch abbrechen, NetBSD 6.1.5 - i386 zu installieren:
base.tgz korrupt und mindest ein weiteres Archiv (comp.tgz).
Quelle war NetBSD-6.1.5-i386-install.img.gz vom Hauptserver. Installation vom USB-Stick. Zielsystem ein älteres Desktop mit Pentium M und ATA-Controller.

(ein weiterer Versuch mit 7rc3 blieb beim booten hängen)

Gerade probiere ich es mit 6.1.4 - comp.tgz bricht ab (unexpected EOF), misc.tgz ebenfalls, auch xfonts. Netzwerk-Konfiguration bleibt wegen "Filesystem full" hängen, obwohl "df -k" 83% anzeigt.

Gibt es irgendwo funktionierende Images der aktuellen Releases?
Selbst bauen ist wegen des mangelnden FFS-Supports der Linuxe schwierig.

Schade. Eigentlich erwarte ich ja, dass bei einem ofiziellen Release wenigstens die Installationsmedien tun - bei den mir bekannten Uralt-Versionen war das kein Thema.

Beate
 

cla

IRC: Qyx
#2
Es ist sehr unwahrscheinlich, das die Installationsdateien fehlerhaft sind. Wahrscheinlicher ist in diesen Faellen eigentlich eher Korruption waehrend des herunterladens, oder beim abspeichern auf dem lokalen Computer. Deshalb gibts in den Verzeichnissen wo die Installationsmedien bereitgestellt werden auch immer MD5/SHA Pruefsummen. Damit kannst du erstmal sicherstellen, das dein Download ueberhaupt fehlerfrei bei dir auf dem Rechner angekommen ist.

Ebenso: Ist dein USB-Stick fehlerfrei?

Des weiteren ist oft auch die Hardware des Systems auf dem du installieren willst problematisch...mit USB-Sticks (gerade auf aelteren Systemen) hatte ich auch oft Probleme. Stattdessen dann ueber CD-ROM (manchmal auch wieder einfach als externes USB-Laufwerk), und alles lief ploetzlich.
 

darktrym

Fahnenträger
#6
Nunja, ich hatte schon einige Problem mit dem USB Stack von NetBSD. Die Probleme waren zwar stets etwas anders, aber für Installation greif ich dann doch lieber zum CD-Rohling.
 

beate

Well-Known Member
Themenstarter #7
Nunja, ich hatte schon einige Problem mit dem USB Stack von NetBSD. Die Probleme waren zwar stets etwas anders, aber für Installation greif ich dann doch lieber zum CD-Rohling.
Da wüsste ich gerne mehr, besonders über den aktuellen Zustand des Stacks. Die Maschine, die ich gerade aufsetze, soll in mein Office und da auch Drucken. Außerdem plane ich noch ein Notebook fürs Musikmachen (recording).
Mit USB unter NetBSD habe ich noch keine Erfahrung. Unter Linux hat es mich allerdings schon so einiges an Nerven gekostet.

Ach so - wenn wir schon bei Wackelsoftware sind ... cups. Habe gesehen, dass es auch noch 1.5.4 gibt. Gerade eben hatte ich mit 2.10. richtig - das Übliche - update, Drucker geht nicht mehr, aber es gibt keinen Fehler in den logs. Cups samt Treibern und Abhängigkeiten neu installiert, nix. Drucker neu installiert wieder nix (es wird nach wie vor erfolgreich ins Nirwana gedruckt). Dann den neu installierten Drucker remote angesprochen (cups 1.6.2, OSX) - und siehe da, die Testseite wird gedruckt. Seitdem druckt er auch wieder lokal. Die Linux-Installation war ursprünglich mal ein 1.7.x.

Warum ich das schreibe: welche Version läuft stabiler - das "gute alte" 1.5.4 oder das aktuelle cups?

Und noch eine Frage: gibt es noch aktuelle Spiegel für die Anwendungspakete oder muss ich auf den zentralen Server in den USA zugreifen?
 

Jeff

Well-Known Member
#10
Geh doch mal bei der Installation mit CTRL-C auf die Kommandozeile und schick mal die Ausgabe von dmesg|grep configured .
Damit kommen wir an die nicht konfigurierten Hardwareteile.
 

beate

Well-Known Member
Themenstarter #11
Geh doch mal bei der Installation mit CTRL-C auf die Kommandozeile und schick mal die Ausgabe von dmesg|grep configured .
Damit kommen wir an die nicht konfigurierten Hardwareteile.
So, das hat sich wohl erledigt. Ich hatte mich entschlossen, NetBSD 7 abzuwarten.
Be der Installation vom USB-Stick trat dann der bekannte Fehler auf, dass sysinit auf die falsche Partition zugreifen wollte. Daher doch eine CD brennen - und damit klappt die Basisinstallation. Zunächst mal auf einem anderen Rechner, einem mobii-Subnotebook von 2009.
 

beate

Well-Known Member
Themenstarter #14
Wieso?
Mit der CD klappts doch, jedenfalls auf dem Notebook.
Jetzt gehts halt an die vielen Details (xkbcomp will nicht), Powermanagement auf dem Notebook, virtuelle Konsolen, Sound...
 

Chu

Well-Known Member
#15
Hallo beate,

warum sollte der Installer nicht auf die richtige Partition zugreifen. Und selbst, wenn der im Zweifel ist, kannst du ihm sagen wo die Dateien liegen.

Virtuelle Konsolen sollten immer gehen. Wenn nicht beschreib dein Problem doch einfach genauer.

Powermanagment ist immer und überall auf Systemen ein Problemfaktor. In NetBSD gibt es genug Möglichkeiten der Konfiguration.

Welche Probleme hast du mit deinem Sound?

Du beschreibst nie wirklich was......

Gruß
Chu