• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

iPhone Wifi Tethering

teisho

Well-Known Member
Themenstarter #1
Hi zusammen,

ich habe ein Problem mit meinem Thinkpad T460 mit FreeBSD 12.0-RELEASE und meinem iPhone.
Würde gerne das LTE des iPhones auf meinem Notebook über WLAN nutzen, doch leider komme ich nicht weiter.

Wenn ich mich mit dem Telefon per WLAN verbinde bekomme ich keine funktionierende IP. Nur die 0.0.0.0.
"Normales WLAN" geht wunderbar am Thinkpad. Auch können sich andere Geräte ohne Probleme mit dem iPhone verbinden.

Hat jemand vielleicht einen Ansatz wie ich das debuggen könnte?
Danke für die Hilfe.

/etc/rc.conf
Code:
wlans_iwm0="wlan0"
ifconfig_wlan0="WPA DHCP"
ifconfig_wlan0_ipv6="inet6 accept_rtadv"
/etc/wpa_supplicant.conf
Code:
network={
        ssid="foo"
        key_mgmt=WPA-PSK
        psk="12345678"
}
ifconfig
Code:
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 44:85:00:aa:bb:cc
        inet6 fe80::4685:ff:fe6e:5cb7%wlan0 prefixlen 64 scopeid 0x3
        inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
        groups: wlan
        ssid foo channel 6 (2437 MHz 11g) bssid 76:b5:aa:aa:aa:aa
        regdomain FCC country US authmode WPA2/802.11i privacy ON
        deftxkey UNDEF AES-CCM 2:128-bit txpower 30 bmiss 10 scanvalid 60
        protmode CTS wme roaming MANUAL
        media: IEEE 802.11 Wireless Ethernet OFDM/48Mbps mode 11g
        status: associated
        nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
 

mr44er

Well-Known Member
#2
Hab keine Ahnung von Apfel.

Evtl. darf nur ein Gerät gleichzeitig das WLAN nutzen?

regdomain FCC country US authmode WPA2/802.11i privacy ON <-> media: IEEE 802.11 Wireless Ethernet OFDM/48Mbps mode 11g
 

teisho

Well-Known Member
Themenstarter #3
Ich auch nicht. Ist das Geschäftstelefon mit echter Datenflat.
Also es gehen sicher mehrere Geräte im Hotspot.
 

Vril

Well-Known Member
#4
Ich auch nicht. Ist das Geschäftstelefon mit echter Datenflat.
Also es gehen sicher mehrere Geräte im Hotspot.
Das ist zwar richtig - aber:

Ich zitiere mal:
The iPhone has a small DHCP address pool that can give out 16 addresses (172.20.10.0-172.20.10.15). Of these 16 addresses are 3 taken by the network, broadcast (172.20.10.0 and 172.20.10.15) and iPhone itself (172.20.10.1). Leaving 13 addresses for other devices.
 

crotchmaster

happy BSD user
#6
Ich bin iPhone User und benutze die Hotspot Funktion relativ regelmäßig. Ich würd einfach die SSID und das WLAN-Password, das Dir in den Einstellungen des Hotspots angezeigt wird, nehmen. Ganz ohne psk und key_mgmt.
Ich benutze die Funktion ab und an auch mit einem Tolino.
 

teisho

Well-Known Member
Themenstarter #8
Das ist zwar richtig - aber:

Ich zitiere mal:
The iPhone has a small DHCP address pool that can give out 16 addresses (172.20.10.0-172.20.10.15). Of these 16 addresses are 3 taken by the network, broadcast (172.20.10.0 and 172.20.10.15) and iPhone itself (172.20.10.1). Leaving 13 addresses for other devices.
Ja, da hast du recht. Doch selbst wenn ich mein Notebook mit FreeBSD als einziges Gerät über WLAN mit dem Telefon verbinden möchte geht es nicht.

Ich bin iPhone User und benutze die Hotspot Funktion relativ regelmäßig. Ich würd einfach die SSID und das WLAN-Password, das Dir in den Einstellungen des Hotspots angezeigt wird, nehmen. Ganz ohne psk und key_mgmt.
Ich benutze die Funktion ab und an auch mit einem Tolino.
Wie meinst du das genau ohne PSK. Den WPA-PSK brauche ich ja, da ich den Hotspot damit gesichert habe. Ich kann keinen offenen Hotspot betreiben. Außerdem kann ich mich zum iPhone verbinden. Nur ich bekomme keine IP.
 

Esjott

Kellerkind
#10
Auf dem chromebook nutze ich tethering gelgentlich - ssid und password reicht, klappt auf anhieb.

Bin gerade im urlaub, alles ausser telefon an Technik ist zu hause, sonst hätte ich genau gucken können.
 

pit234a

Well-Known Member
#11
Wie meinst du das genau ohne PSK. Den WPA-PSK brauche ich ja, da ich den Hotspot damit gesichert habe. Ich kann keinen offenen Hotspot betreiben. Außerdem kann ich mich zum iPhone verbinden. Nur ich bekomme keine IP.
Das ist eben ziemlich schlecht aus der Ferne zu beurteilen. Das Ausschalten der Sicherheit kann als Test helfen, Felher hier auszuschließen. Ein Schreibfehler in der wpa_supplicant.conf zB oder so etwas banales.

Wie sieht denn deine rc.conf bezüglich Wlan aus?
Also, mit einem IPad und FreeBSD habe ich keine Probleme, auch mit WPA. Deshalb denke ich, dass es auch mit IPhone funktionieren müsste. Da sucht man Fehler am gescheitesten Schritt für Schritt.
 

Vril

Well-Known Member
#12
Dann nimm doch mal eine aus dem Pool, den ich Dir genannt hab ... es sind ja eh nur 13 oder so —- und trag die statisch in ein

- und schau dir dann vorallem mal das routing an

Das iPhone selber hat ja die 172.20.10.1
Was dann Deine Gateway adr wäre , die du aber anpingen können solltest
( also kannst doch die 172.20.10.10 mal als statische IP in rc.conf eintragen )
 

teisho

Well-Known Member
Themenstarter #13
Danke für eure Hilfe.

service dhclient restart wlan0
Tut das evtl. sinnvolles, nachdem Verbindung besteht?
Mhm, wenigstens sowas hätte Apple seinen Usern zutrauen können. ;)

/Edit:
key_mgmt=WPA-PSK <-- hau die Zeile mal raus und nur diese
dhclient neu starten tut augenscheinlich gar nichts.
Auch das löschen von "key_mgmt=WPA-PSK" verändert nichts.

Das ist eben ziemlich schlecht aus der Ferne zu beurteilen. Das Ausschalten der Sicherheit kann als Test helfen, Felher hier auszuschließen. Ein Schreibfehler in der wpa_supplicant.conf zB oder so etwas banales.

Wie sieht denn deine rc.conf bezüglich Wlan aus?
Also, mit einem IPad und FreeBSD habe ich keine Probleme, auch mit WPA. Deshalb denke ich, dass es auch mit IPhone funktionieren müsste. Da sucht man Fehler am gescheitesten Schritt für Schritt.


Ich hab' mich vielleicht falsch ausgedrückt. Beim iPhone kann man WPA nicht ausschalten.
Also im Sinne von: iOS bietet diese Möglichkeit nicht, selbst wenn ich wollte.
"In iOS, this is not possible, as this discussion has pointed out several times." [1]

Meine rc.conf steht oben im Eröffnungspost. Bisher sonst keine Probleme mit WLAN gehabt.
Code:
wlans_iwm0="wlan0"
ifconfig_wlan0="WPA DHCP"
ifconfig_wlan0_ipv6="inet6 accept_rtadv"

Dann nimm doch mal eine aus dem Pool, den ich Dir genannt hab ... es sind ja eh nur 13 oder so —- und trag die statisch in ein

- und schau dir dann vorallem mal das routing an

Das iPhone selber hat ja die 172.20.10.1
Was dann Deine Gateway adr wäre , die du aber anpingen können solltest
( also kannst doch die 172.20.10.10 mal als statische IP in rc.conf eintragen )
Hmm, das habe ich probiert. Das scheint gar nicht zu gehen. Bekomme keine IP. Wird mir auch keine mit ifconfig angezeigt.

/etc/rc.conf
Code:
wlans_iwm0="wlan0"
ifconfig_wlan0="WPA inet 172.20.10.10 netmask 255.255.255.240"


[1] https://discussions.apple.com/thread/7317038
 

Vril

Well-Known Member
#15
Tja ... schade, dass ich es nicht nachvollziehen kann, denn ich missbrauche ein iPhone XR auch regelmäßig als Accesspoint weil ich da eine unbegrenzte LTE datenflatrate drauf hab - auch mit FreeBSD. Allerdings ist FreeBSD bei mir virtuell unter Parallels auf n MacBook - und somit nicht vergleichbar, da FreeBSD nicht nativ auf dem MB läuft