iwicontrol nicht im base-system vorhanden?

nintendo

Please don't sue us!!
Hallo,

ich studiere im Moment an der FH Aachen und um ins Internet zu gelangen wird eine WPA Authentifikation benutzt.

Nun, mein Arbeitswerkzeug war bisher der IBM ThinkPad R51 Laptop, ausgestattet bekannterweise mit dem Intel Centrino 802.11BG Chipsatz. Win2k lief auf dem Teil bis naja.. egal :D

Auf jeden Fall wollte ich nun FreeBSD zum laufen bringen und das 1. Problem war diese WPA Authentifikation. Dafür braucht man wpa_supplicant - läuft nur unter FreeBSD 6 (oder später).

Dann bin ich auf die wunderbare Homepage von Damien Bergamini gestossen, der die iwi-Treiber geschrieben hat und diese mittlerweile im base-System fest implementiert wurden.
Ich bin wie in seiner Beschreibung[1] vorgegangen, doch leider konnte ich keine Firmware mittels iwicontrol laden. iwicontrol ist nicht vorhanden - sollte aber unter /sbin/iwicontrol sein. Hmm, ich weiss jetzt leider nicht wie ich die Firmware laden soll - weiss da zufällig jemand von euch weiter?

Danke schonmal für Vorschläge & schönes WE ;)

[1] http://damien.bergamini.free.fr/ipw/iwi-freebsd.html
 

ouTi

BSD sucker
so, wie ich es bereits im irc gesagt hab:

/usr/ports/net/iwi-firmware

die installiert die firmware und iwicontrol

oder eben ipw-firmware mit ipwcontrol
 

nintendo

Please don't sue us!!
ouTi schrieb:
so, wie ich es bereits im irc gesagt hab:

/usr/ports/net/iwi-firmware

die installiert die firmware und iwicontrol

oder eben ipw-firmware mit ipwcontrol

Hi ouTi,

das Problem hat sich anscheinend gelöst:

Ich habe iwi-firmware mittels pkg_add installiert und nun ist iwicontrol vorhanden. Was mich permanent irritiert hat, war die folgende Ausgabe bei der Installation:

Code:
/usr/ports/net/iwi-firmware/> sudo make install clean
===>  iwi-firmware-2.3_1 iwi(4) support is already included in your tree.

Jo, fein fein aber wo ist mein iwicontrol?! ;-) Reinstall hat natürlich auch nichts gebracht, wie gesagt erst mit pkg_add wurde iwicontrol mitinstalliert

Leider bin ich jetzt nicht in der Nähe des WLAN Netzwerkes und kanns nicht testen :gpaul:
Trotzdem Danke für den Tipp :D
 

ouTi

BSD sucker
:) bitte bitte

die ports installieren auch die treiber selbst als modul für äteren fbsd versionen. daher die nachricht, das die dinger in6.0 ja schon existieren :)
 
Oben