• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

KDE 5 + SDDM in deutscher Sprache

kraekers

Well-Known Member
Themenstarter #1
Moin Kollegen,

auch lebend mit der Gefahr das ich jemanden mit meiner Frage nerve, bin ich einfach mal so frei.

Ich bekomme es zum Verrecken nicht hin KDE5 in deutscher Sprache zu nutzen, geschweige denn SDDM.

Ich weiß, dass in BSDForen.de mehrere Lösungsvorschläge herumgeistern, aber so richtig auf den Punkt hat es noch keiner so richtig gebracht.

Gibt es irgendwo eine Lösung für das Problem oder wäre jemand so nett mich an die Hand zu nehmen.

Vielen Dank im Voraus.

Beste Grüße

kraekers
 

Zirias

Well-Known Member
#2
Eine von sddm gestartete X-Session liest /etc/profile, also z.B. folgendes da reinschreiben:
Code:
LANG=de_DE.UTF-8; export LANG
CHARSET=UTF-8; export CHARSET
Für sddm selbst gibt es die Variable sddm_lang in /etc/rc.conf.
 

kraekers

Well-Known Member
Themenstarter #3
Danke Zirias,

funktioniert soweit, nur bei der Anmeldung haperts, d.h. das bei der Eingabe des Paßwortes nur das englische Zeichenlayout übernommen wird. Hat da jemand eine Idee?

Vielen Dank im Voraus.

Beste Grüße
kraekers
 

Zirias

Well-Known Member
#4
Das Standard Tastaturlayout kannst du im X-server konfigurieren.

Datei: /usr/local/etc/X11/xorg.conf.d/keyboard-de-nodeadkeys.conf

Inhalt:
Code:
Section "InputClass"
        Identifier         "KeyboardDefaults"
        Driver             "keyboard"
        MatchIsKeyboard    "on"
        Option             "XkbLayout" "de"
        Option             "XkbVariant" "nodeadkeys"
EndSection
 

kraekers

Well-Known Member
Themenstarter #5
Daaaaaaaaaaaaaaaaaanke,

dass ist es. Ich habe ein wenig mit

Code:
/usr/local/share/sddm/scripts/Xsetup
herumgespielt, hat soweit funktioniert. Sprachen wie Englisch, Spanisch, Französisch wurden in einem Auswahlfenster
im SDDM angezeigt, nur Deutsch lässt sich nicht hinterlegen.

Dein Lösungsvorschlag ist goldrichtig. Danke Zirias.

Liebe Grüße

kraekers
 

mr44er

Well-Known Member
#6
Ich nutze login-manager absichtlich nicht.

In KDE habe ich unter Regionaleinstellungen auf Deutsch gestellt und das Tastaturlayout (im anderen Menü) entsprechend auch.

Einmal neu einloggen und wir haben ein germanisches KDE :)

Code:
LANG=de_DE.UTF-8; export LANG
in .xinitrc sollte aber auch schon passen für den ersten Start.