• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

KDE-Login geht nicht ...

Windhund

Well-Known Member
Themenstarter #1
Hallo zusammen,
ich bin auch ganz neu hier, Thor kenne ich gut von Mandrake her (grüss dich, Thorsten).

Dummerweise habe ich statt 4.9 schon 5.2.1 geordert und bleibe beim Login in KDE hängen.
Alles andere habe ich schon mit dem Handbuch erledigt.

Wenn ich startkde eingebe, kommt die Fehlermeldung, dass kein Connect zum XServer möglich ist.
Wenn ich aber "XFree86 -xf86config XF86Config.new eingebe, sehe ich genau das, was im Handbuch steht: graues Raster und der X-Mauszeiger.

Wenn ich dann mal ins $Home-Verzeichnis gehe, finde ich da DCOPserver__NODISPLAY.

Unter root finde ich keinen DCOPserver, der - wenn ich das richtig verstehe - doch zum Einloggen nötig ist.

Wenn ich als normaler user "startkde" eingebe, kommen eben die besagten Fehlermeldungen.

Vor mir liegen die Seiten über XFree86 4.X konfigurieren.
Nach denen bin ich vorgegangen.

Wie bekomme ich es nun hin, dass ich mich in KDE einloggen kann?

Eine .xinitrc hab ich auch im $HOME - Verzeichnis angelegt, in die ich "exec kde" eingetragen habe, was aber auch nichts genutzt hat, solange der DCOPserver nicht will.

Sollte ich vielleicht doch erst mal mit der Version 4.9 anfangen?

Hab sie mir eben mal bestellt....

Gruss
Windhund alias Manfred

Infos:
ATI Rage Pro 128
AMD Duron 1300 Mhz
VIDEOSEVEN N98SD
OnboardSound via
RAM 512
Wheelmouse

XFree86 -configure hat alles richtig erkannt, sogar den Monitor mit der genauen Bezeichnung, auch die Maus funktioniert. Grafikkarte auch korrekt erkannt.
 
Zuletzt bearbeitet:

qfat

Well-Known Member
#2
weiß nicht ob ich das problem richtig verstehe aber probier mal anstatt startkde einfach ein startx dann müsste x starten und sich aus ~/.xinitrc auslesen das er kde startsen soll
 

Windhund

Well-Known Member
Themenstarter #3
Erster Schritt weiter:

Habs nun geschafft, dass wenigstens kdm aufgerufen wird, aber erst war neben root noch der user drin, doch nun nur noch root.

Beim Einloggen seh ich zwar die kleine Uhr, aber es bewegt sich nichts weiter.

Wenn ich mich mit dem user anmelden will, kommt: login failed.

Aber ich gebe nicht auf, denn ich möchte weiterkommen und lernen.

Nur steht darüber natürlich nichts im Handbuch. drum frage ich die erfahrenen User hier und hoffe auf Hilfe,

Danke schon einmal im voraus
und freundliche Grüsse
von
Windhund
 

qfat

Well-Known Member
#4
das problem hatte ich mit dem gdm!
damals hatte ich den gdm über /etc/ttys gestartet was aber falsch ist.
beim gdm gibt es ein script zum starten weiß aber nicht ob das beim kdm genauso ist.
 

Ice

Well-Known Member
#5
Wenn ich startkde eingebe, kommt die Fehlermeldung, dass kein Connect zum XServer möglich ist.
Wenn ich aber "XFree86 -xf86config XF86Config.new eingebe, sehe ich genau das, was im Handbuch steht: graues Raster und der X-Mauszeiger.
Das sind ja auch zwei völlig unterschiedliche Vorgänge!
- Im ersten Fall versuchst Du den Window-Manager zu starten, der dann nach einem laufenden X-Server sucht! Der aber ja noch nicht läuft!!!!!
- Im 2.ten Fall startest Du manuell den X-Server mit einer temporären Konfiguration

In Deiner .xinitrc im HOME sollte folgendes stehen:
exec startkde

Dann startest Du Dein X durch Aufruf von "startx"

Wenn Du X beim Booten starten willst, dann kopiere zuerst Dein XF86Config.new nach /etc/XF86Config
.xinitrc sollte wie beschrieben aussehen
Editiere /etc/ttys und ändere die Zeile für ttyv8 folgendermaßen:
#ttyv8 "/usr/X11R6/bin/xdm -nodaemon" xterm off secure
ttyv8 "/usr/local/bin/kdm -nodaemon" xterm on secure

Beim nächsten Boot sollte Dich der KDM mit seinem Login-Screen begrüßen!

Gruß,

Ice
 

Windhund

Well-Known Member
Themenstarter #6
Hallo Ice.

vielen Dank, nun ist das auch geregelt.

So langsam komme ich voran.

Wechsel von FreeBSD auf eine mit Internet-Zugang versehene Distri und ins Forum.

Dann zurück zu FreeBSD, um die Einstellungen vorzunehmen usw. usw.

Wenn ich erst mal einen Internet-Zugang von FreeBSD aus habe, dann wirds leichter.

Aber vor den Erfolg haben die Götter den Schweiss gesetzt :-)

Auch die deutsche kde-version muss ich noch installieren, die bekomme ich aber erst, wenn ich ISDN eingerichtet habe.

Ansonsten hab ich per Handbuch schon mal die Einträge für LANG vorgenommen, was aber noch keinen Erfolg gebracht hat.

Danke jedenfalls für jede Hilfe, die ich hier bekomme und schon bekommen habe.

Gruss
Windhund
 
#7
An die Frage würde ich mich gerne anhängen.

Ich habe soweit alles installiert. FreeBSD läuft, XServer funktioniert, XFCE4 ist drauf und funktioniert, kdm habe ich über "# pkg_add -r kdebase" installiert, das startet auch und zeigt mir die verfügbaren User an.

Das Problem ist nur, dass ich die ganze Zeit einen "login failed" bekomme wenn ich versuche mich einzuloggen und ich weiß nicht wieso. Der User und das Passwort stimmen garantiert, auf der Konsole funktioniert beides 1A und ich hab auch schon deppensichere Passwörter ausprobiert, die auch nicht an einem Vertipper oder so hängen können...

Kann mir da jemand einen Tipp geben wo ich da suchen muss?
 

0815Chaot

FreeBSD/sparc64-Tüftler
#8
Hast du auch das korrekte Tastaturlayout eingestellt? Gib das Paßwort in das Feld für den Benutzernamen ein und prüfe, ob da wirklich das steht, was du haben wolltest. Du wärst nicht der erste, der statt einem Z ein Y eingetippt hat, weil die Tastatur auf US-Layout eingestellt ist. :)

Ansonsten solltest du mal in /var/log/messages gucken. Der KDM schreibt dort z.B. rein, wenn mit deiner Konfiguration etwas nicht in Ordnung ist.

Ach ja: Du versuchst doch nicht etwa, dich als root einzuloggen?
 
#10
*push*

Edit: Zusätzlich wäre es nett, wenn mir jemand sagen könnte, wo ich in der kdm-config festlegen kann, dass er IMMER xfce4 startet und nicht kde.
 
Zuletzt bearbeitet:

pit234a

Well-Known Member
#11
/usr/X11R6/lib/X11/xinit
enthält xinitrc und darin kann zB startkde stehen, wenn dieses mit Aufruf des X-Servers starten soll. Diese möglichkeit ist nicht sehr schön für mich, denn es gibt keinen Anmeldeschirm mit grafischer Auswahl des Benutzers und des Ortes, sprich des PCs, auf dem sich wer einloggen will. Gerade dies macht kdm ja so komfortabel.
kdm starte ich mit einer Datei X.sh, die ich nach /usr/local/etc/rc.d/X.sh stelle, die ausführbar sein muß und die so einfach aussieht:

#/usr/local/etc/rc.d/X.sh
/usr/local/bin/kdm -nodaemon #xterm on secure

kdm startet dann die Sitzung, X wird beim booten automatisch gestartet.

/usr/local/share/config/kdm
enthält die kdmrc, die Konfiruationsdatei für den kdm.
Diese kann editiert werden und bestimmt das Asusehen und auch das Default-Anmeldesystem und so weiter.
In einer KDE-Sitzung kann das Verhalten des KDM von root weitgehend grafisch angepasst und bestimmt werden, inklusive des Rechtes und passenden Befehls zum Ausschalten des PCs. Was ich nur durch direktes Editieren machen konnte, war die Freigabe des Zugriffs von entfernten Rechnern aus. Das sieht dann so aus:
[Xdmcp]
# Whether KDM should listen to incoming XDMCP requests.
# Default is true
Enable=true

Damit kann ganz bequem von einem aktuellen PC aus dem Anmeldefenster auf einem entfernten angemeldet und grafisch gearbeitet werden. Für mich ist dies eine ganz schön praktische Sache. Hier ist wieder wichtig, das passende Tastaturlayout zu setzen. Ich lernte, am einfachsten alle richtig einzustellen. Also, im xorg.conf, in der .cshrc und besonders dann in der aktuellen KDE-Sitzung wieder. Ich nutze stets KDE.