• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

KDE startet von einem Tag auf den anderen nicht mehr ...

PatTheMav

BSD-Frischling
Themenstarter #1
Irgendwann dreh ich noch ab bei dem System hier :)

Monatelang läuft alles gut und plötzlich will KDE nicht mehr so, wie es soll. Selbst nach Deinstallation fast aller Ports und komplettem Neubau von KDE, X.org und Co hab ich diese Probleme ...

Wenn ich KDE starte bleibt das Ding erstma minutenlang beim "Initialisieren der Systemdienste" hängen, bis dann nach 5-10 Minuten irgendwann der Desktop auftaucht. Alle anderen Programme funktionieren dann auch, doch alles was mit dem Konqueror zu tun hat, hängt ebenfalls ..

Woran kann das liegen, zumal an der Konfiguration des System nichts geändert wurde und das Verhalten von einen Tag auf den anderen auftrat ...
 

/dev/urandom

Well-Known Member
#2
Nur ne Vermutung...hast du schon mal deinen .kde Ordner im Homeverzeichnis gelöscht?
Kann sein dass KDE da irgendeinen Mist reingeschrieben hat und deswegen hängt.

/dev/urandom
 

PatTheMav

BSD-Frischling
Themenstarter #5
AndreasMeyer hat gesagt.:
Mit deinen Namensauflösung- und locale-Problemen wundert mich das nicht..
Ja Andreas das Problem ist vielmehr, daß beides gemäß Wiki 100%ig funktionieren sollte !

Namensauflösung funktioniert einwandfrei (hab ich im anderen Thread schon mal geschrieben...), der Hostname wird korrekt angezeigt und wird auch revers per IP korrekt aufgelöst, also DNS und DHCP rennen hier einwandfrei.

Locales sind alle gemäß Wiki eingestellt, Stress machen Perl und andere Ports auch, einige meinen sie finden nicht mal die "C"-Locale ...

Aber vielleicht übersehe ich auch was - hab mal hier paar Outputs reingepostet:
[root@router ~]# hostname
router.local

[root@router ~]# host router
router.local has address 192.168.0.10

[root@router ~]# host router.local
router.local has address 192.168.0.10

[root@router ~]# host 192.168.0.10
10.0.168.192.in-addr.arpa domain name pointer router.local.

[root@router ~]# host localhost
localhost has address 127.0.0.1

[root@router ~]# host 127.0.0.1
1.0.0.127.in-addr.arpa domain name pointer localhost.local.

[root@router ~]# locale
LANG=de_DE.ISO8859-1
LC_CTYPE="de_DE.ISO8859-1"
LC_COLLATE="de_DE.ISO8859-1"
LC_TIME="de_DE.ISO8859-1"
LC_NUMERIC="de_DE.ISO8859-1"
LC_MONETARY="de_DE.ISO8859-1"
LC_MESSAGES="de_DE.ISO8859-1"
LC_ALL=de_DE.ISO8859-1

[root@router ~]# ls /usr/share/locale/ | grep de_DE
de_DE.ISO8859-1
de_DE.ISO8859-15
de_DE.UTF-8
 
Zuletzt bearbeitet:

PatTheMav

BSD-Frischling
Themenstarter #6
Also ich habe den schweren Verdacht, daß irgendwas mit dem Loopback-Interface nicht stimmt, aber ifconfig listet lo0 ganz normal auf und wie oben zu sehen ist, ist "localhost" auch richtig eingetragen...
 

sir_eidrien

Nuklearer Mailhamster...
#8
Hastu Du die Probleme seit deiner Umstellung des Namens (wie in einem anderen Thread von Dir beschrieben)?

Greets, s_e
 

PatTheMav

BSD-Frischling
Themenstarter #9
OOZE hat gesagt.:
Du läst nucht zufällig /tmp beim Boot löschen, oder?
Öööhm ne, das hab ich aus der rc.conf entfernt, seit ich KDE installiert hab, weil sonst dieses eine .ICE-Verzeichnis fehlt usw..

Hab statt dessen nur einen crontab-Eintrag der jede Woche einmal alle Dateien löscht, die älter als zwei Wochen sind.

Die Umstellung meines Hostnamen liegt schon weiter zurück, KDE funktionierte damit ohne Probleme, die sind erst seit Freitag nachmittag aufgetreten, fragt mich nicht, das einzig tiefgreifende, was ich davor gemacht hab, war ein lost+found-Dir aufzuräumen.

Ich hab hier mal meine .xsession-errors angehängt, vielleicht lässt sich daraus was brauchbares erlesen :
startkde: Starting up...
kbuildsycoca running...
kbuildsycoca: WARNING: 'katepart.desktop' specifies undefined mimetype/servicetype 'text/x-fortran'
kbuildsycoca: WARNING: 'kcertpart.desktop' specifies undefined mimetype/servicetype 'application/binary-certificate'
kbuildsycoca: WARNING: 'knotify.desktop' specifies undefined mimetype/servicetype 'KNotify'
kdecore (KLibLoader): WARNING: KLibrary: Undefined symbol "init_kdnssd"
rm: /root/.kde/share/config/session/kwin_1022721619a22b000112138487400000250520000_1131056532_656749: No such file or directory
kicker: crashHandler called
KCrash: Application 'kicker' crashing...
startkde: Shutting down...
kicker: sighandler called
klauncher: Exiting on signal 1
KWrited Überwacht Gerät /dev/ttyp2
startkde: Running shutdown scripts...
startkde: Done.
 
Zuletzt bearbeitet:

PatTheMav

BSD-Frischling
Themenstarter #10
Verflixt und zugenäht, ich hab nun alles von meinem System runtergehauen, was irgendwas mit KDE zu tun hatte und auch X.org gekillt.

Danach X.org aus den Ports gebaut und getestet - funktioniert einwandfrei, kann Firefox und Co auch starten usw.

Dann hab ich KDE gebaut auf "nüchternem" System, aber beim ersten Start wieder das übliche : Beim Initialisieren der Systemdienste hängt es. Aufgefallen ist mir dieses Mal nur, daß "saslpasswd2" während der Installation ausgeführt wird und 2x zwar meldet, daß das Passwort erfolgreich gesetzt werden konnte aber auch 2x danach meldet, daß die db nicht geschrieben werden könne.

Und was Namensauflösung und Co betrifft, ich hab alles gemacht, was im Wiki steht und es brachte keine Fehler zu Tage. Was kann denn von einen Tag auf den anderen passieren, daß KDE selbst nach ner Neucompilierung so ein Stress macht ?
 

PatTheMav

BSD-Frischling
Themenstarter #11
Tut mir ja leid, daß ich den Thread bumpen muss, aber ich doktore seit Wochen dran rum und ich bekomm das Problem nicht behoben und ich habe keine Ahnung woher das Problem kommt - die Namensauflösung funktioniert einwandfrei und Localhost ist vollkommen erreichbar und selbst Recherche in KDE-Foren oder per Google haben mich kein Stück weitergebracht, selbst recompile von Xorg und KDE mit allen Dependencies hat keine Besserung gebracht, bin kurz davor aufzugebenden und diese Startverzögerung zu akzeptieren, obwohl sie auf identischem System vorher nicht da war :(
 

d4mi4n

volksoperator on duty
#12
dies ist jetzt kein konstruktiver beitrag, aber in so einem fall hätte ich das komplette system neu installiert
gut wenn man einen fehler ausbügelt ist man hinterher klüger, aber in dem fall hätt ich nach paar tagen aufgehört, es sei denn natürlich du stehst drauf dir weiterhin den hintern aufzureissen :D
 

dettus

Bicycle User
#13
DESWEGEN mag ich kde nicht...

DESWEGEN mag ich kde nicht. das proggie ist einfach zu unuebersichtlich!

folgendes: du schreibst hier immer wieder, dass der beim initialisieren haengt. und hast auch schonmal die .xsessionlog gepostet (sehr loeblich)

mach aber doch bitte auch mal das hier:
einmal im failsafe-modus einloggen.

und dann:
Code:
% bash
% startkde &>kdelog.txt
sobald der haengt, guckst du nach, in welcher zeile das ist. und dann, wenn der wieder laeuft, guckst du nach, was da noch so alles dahinter kommt.
 

PatTheMav

BSD-Frischling
Themenstarter #14
dettus hat gesagt.:
DESWEGEN mag ich kde nicht. das proggie ist einfach zu unuebersichtlich!

folgendes: du schreibst hier immer wieder, dass der beim initialisieren haengt. und hast auch schonmal die .xsessionlog gepostet (sehr loeblich)

mach aber doch bitte auch mal das hier:
einmal im failsafe-modus einloggen.

und dann:
Code:
% bash
% startkde &>kdelog.txt
sobald der haengt, guckst du nach, in welcher zeile das ist. und dann, wenn der wieder laeuft, guckst du nach, was da noch so alles dahinter kommt.
Ok, wird gemacht sobald ich @Home bin, sitz grad in der Uni ;)

Muss es der Failsafe-Mode sein ? Weil dann hat das Haus kein Inet mehr und dann is das Geschrei wieder gross :)

Und ja ich hab KDE aufm Router/Firewall-Server am laufen - wo sonst kann man eine Computerunerfahrene Mutter sicherer surfen lassen als auf einem BSD/Unix mit Firefox/Konqueror und extrem eingeschränktem Gastkonto :D
 

PatTheMav

BSD-Frischling
Themenstarter #15
So - habe mal getan, was mir aufgetragen wurde, bin mir aber nicht sicher, ob's das wirklich gebracht hat :)

Hier das Log mit startkde :
xsetroot: unable to open display ''
xset: unable to open display ""
xsetroot: unable to open display ''
startkde: Starting up...
ksplash: cannot connect to X server
kdeinit: Aborting. $DISPLAY is not set.
Warning: connect() failed: : No such file or directory
ksmserver: cannot connect to X server
ERROR: Couldn't attach to DCOP server!
startkde: Shutting down...
Warning: connect() failed: : No such file or directory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts...
startkde: Done.
Danach hab ich vermutet, daß das ein Tippfehler von dir war und hab das ganze mal mit startx gemacht :
X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: FreeBSD 6.0 i386 [ELF]
Current Operating System: FreeBSD router.local 6.0-STABLE FreeBSD 6.0-STABLE #4: Sat Nov 5 04:09:13 CET 2005 root@:/usr/obj/usr/src/sys/PTMv3KERNEL i386
Build Date: 08 November 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Nov 21 17:29:57 2005
(==) Using config file: "/etc/X11/xorg.conf"
Warning: font renderer for ".pcf" already registered at priority 0
Warning: font renderer for ".pcf.Z" already registered at priority 0
Warning: font renderer for ".pcf.gz" already registered at priority 0
Warning: font renderer for ".snf" already registered at priority 0
Warning: font renderer for ".snf.Z" already registered at priority 0
Warning: font renderer for ".snf.gz" already registered at priority 0
Warning: font renderer for ".bdf" already registered at priority 0
Warning: font renderer for ".bdf.Z" already registered at priority 0
Warning: font renderer for ".bdf.gz" already registered at priority 0
Warning: font renderer for ".pmf" already registered at priority 0
startkde: Starting up...
kbuildsycoca running...
SetClientVersion: 0 8
sysctl: unknown oid 'hw.dri.0.name'
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x1600007
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 6
Minor opcode: 0
Resource id: 0x1600007
kicker: crashHandler called
KCrash: Application 'kicker' crashing...
startkde: Shutting down...
kicker: sighandler called
klauncher: Exiting on signal 1
KWrited überwacht Gerät /dev/ttyp0
startkde: Running shutdown scripts...
startkde: Done.

waiting for X server to shut down
 
#16
Warning: font renderer for ".pcf" already registered at priority 0
Warning: font renderer for ".pcf.Z" already registered at priority 0
Warning: font renderer for ".pcf.gz" already registered at priority 0
Warning: font renderer for ".snf" already registered at priority 0
Warning: font renderer for ".snf.Z" already registered at priority 0
Warning: font renderer for ".snf.gz" already registered at priority 0
Warning: font renderer for ".bdf" already registered at priority 0
Warning: font renderer for ".bdf.Z" already registered at priority 0
Warning: font renderer for ".bdf.gz" already registered at priority 0
Warning: font renderer for ".pmf" already registered at priority 0
Fehler in /etc/X11/xorg.conf, oder Probleme mit freetype oder Probleme mit Kompileroptionen in /etc/make.conf?!

sysctl: unknown oid 'hw.dri.0.name'
DRI und DRM korrekt installiert?!
=> http://wiki.bsdforen.de/index.php/FreeBSD_-_3D-Grafik-Beschleunigung
 

PatTheMav

BSD-Frischling
Themenstarter #17
AndreasMeyer hat gesagt.:
Fehler in /etc/X11/xorg.conf, oder Probleme mit freetype oder Probleme mit Kompileroptionen in /etc/make.conf?!
Nicht, daß ich wüsste. Der Make-Lauf verursacht keine Probleme und ob was in der xorg.conf falsch steht, kann ich nicht beurteilen - ich hab die hier mal mit reingeschmissen :
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/webfonts"
FontPath "/usr/X11R6/lib/X11/fonts/TTF"
FontPath "/usr/X11R6/lib/X11/fonts/bitstream-vera"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/local/share/fonts"
EndSection

Section "Module"
Load "bitmap"
Load "freetype"
Load "extmod"
Load "glx"
Load "dbe"
Load "record"
Load "xtrap"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/sysmouse"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
# Driver "keyboard"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
EndSection

Section "Monitor"

### Uncomment if you don't want to default to DDC:
# HorizSync 31.5 - 57.0
# VertRefresh 50.0 - 90.0
Identifier "Monitor0"
Option "DPMS"
EndSection

Section "Device"
Identifier "Card0"
Option "NvAgp" "1"
# Option "RenderAccel" "true"
# Option "AGPMode" "4"
Option "AllowGLXWithComposite" "true"
# Driver "nv"
Driver "nvidia"
VendorName "NVIDIA"
# ChipSet "GeForce2 MX/MX 400"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "enable"
Option "RENDER" "enable"
Option "BIG-REQUESTS" "enable"
Option "GLX" "enable"
EndSection
Um evtllen Fragen vorzubeugen : Ja ich verwende den nVidia-Binärtreiber und habe deshalb auch mal den Fallback auf den Standard-nv-Treiber versucht, aber hat am Problem nichts geändert :(

AndreasMeyer hat gesagt.:
Also DRI und DRM benutze ich garnicht direkt, weil ich ja den nVidia-Treiber benutze, der das ganze ja mit eigenem Kernelmodul und eigenen GLX-Bibliotheken betreibt und daher kann ich nichts aus dem Wiki-Einträg wirklich benutzen, glxinfo meldet z.B. immer, daß er keine Verbindung zum Display :0 aufbauen kann ("connection refused"), selbst wenn ich es in einem Terminal unter laufendem KDE starte.