KDE unter NetBSD als User ausführen

fatman

Assemblerfan
Guten Tag zusammen!

Also ich kann KDE nur als root starten. Versuche ich als normaler User, bricht er mit einer Fehlermeldung ab.
(kstartupconfig not configured...). Ich habe den Pfad auf kstartupconfig gesetzt, die .xinitrc angepaßt, per $PATH die Pfade kontrolliert, user und root gehören einer Gruppe (wheel) an, mit which kstartupconfig geprüft, ob diese überhaupt existent ist und jetzt bin ich etwas ratlos.

Hat jemand noch'n Tip für mich?

Danke!

fatman
 

fatman

Assemblerfan
soul_rebel:
Inhalt der .xinitrc:
Pfad auf kstartupconfig: /usr/pkg/bin/kstartupconfig
exec startkde

KDE-Start durch Eingabe von startx auf der Konsole. (Ich mag keinen xdm, kdm oder gdm, ich starte lieber manuell).

Fatman
 

franco98

NetBSDler aus Leidenschaft
Eigentlich dürfte da nichts schief gehen! :confused:

In die ~/.xinitrc am Ende "exec /usr/pkg/bin/startkde" eintragen und den Rest macht ein startx an der Konsole! Das klappt bei richtigem $PATH auf jedem Unix normalerweise, die internen Settings nimmt KDE ja selbst vor!

Da ist was anderes verstellt!

Hat der user seine eigene .xinitrc?
Was gibt ein env beim $PATH raus?
Selbstgebautes KDE mit veränderten Pfaden???

Gruß Frank
 

fatman

Assemblerfan
@franco98:

Hat auch nix gebracht.
Hier mal alle Fehlermeldungen, die er ausgibt:
- mkdir: /home/stefan/.kde/share: Permission denied (3x untereinander)
- /usr/pkg/bin/startkde: cannot create /home/stefan/.kde/share/kde/config/startupconfigkeys: permission denied
- trying to create local folder /home/stefan/.kde/share: permission denied
- Can't open /home/stefan/.kde/share/kde/config/startupconfig
- xauth: error in locking authority file /home/stefan/.Xauthority

(Installiert habe ich mit make install clean, also keine Änderungen an den Pfaden vorgenommen)

Fatman
 

fatman

Assemblerfan
@zmieff:

Jupp, das wars!:D
Ich mußte noch eine Datei zusätzlich "entsperren", aber jetzt gehts.
Vielen Dank für Eure Hilfe!

Fatman
 
Oben