• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

KDE4 + HAL hat sich was ab 4.7.4 geändert ?

kraekers

Well-Known Member
Themenstarter #1
Moinsen,

bei mir liefen die Jahre KDE4 und Xorg immer rundum gut. Ich habe entweder aus Packages installiert oder aus Ports, es lief jeweils immer gut.

Ab Version KDE 4.7.4 habe ich nur noch Probleme.

Ob ich aus Packages oder Ports installiere macht da keinen Unterschied.

Das größte Problem ist, daß HAL nicht mehr mit KDE läuft. KDE erkennt keine Devices mehr und Xorg kann mit meiner Maus und Tastatur nichts mehr anfangen. K3b erkennt natürlich auch keine Devices mehr.

Ich nutze nun 9.0 anstatt 8.2, habe aber auch zwischenzeitlich KDE 4.7.4 aus Ports auf der 8.2er Version von FreeBSD installiert und lief auch nicht besser.

Hat sich etwas grundlegend in KDE 4.7.4, bzw. HAL geändert was ich nicht mitbekommen habe ?

Meine Configs (die immer perfekt liefen):

rc.conf:

Code:
keymap="german.iso"
font8x14="NO“
font8x16="NO“
font8x8="NO“
dumpdev="NO"
linux_enable="YES"
abi_load="YES"
sysctl_load="YES"
sendmail_enable=“NONE“
sshd_enable="YES"
usbd_enable="YES"
webcamd_enable=“YES“
devd_enable="YES"
devfs_enable="YES"
devfs_ruleset="/etc/devfs.rules"
devfs_system_ruleset="localrules"
lpd_enable="NO"
cupsd_enable="YES"
hpiod_enable="YES"
hpssd_enable="YES"
fsck_y_enable="YES"
background_fsck="NO"
clear_tmp="YES"
dbus_enable="YES"
hald_enable="YES"
vboxnet_enable=“YES“
avahi_daemon_enable=“YES“
powerd_enable=“YES“
powerd_flags=“-a hiadaptive -b adaptive“
kdm4_enable="YES“
sysctl.conf:

Code:
kern.coredump=0
kern.sched.preempt_thresh=224
kern.maxfiles=49312
vfs.usermount=1
hw.syscons.bell=0 
hw.usb.ukbd.no_leds=1
hw.snd.default_unit=1
loader.conf:

Code:
kern.ipc.shmseg=1024
kern.ipc.shmmni=1024
kern.maxproc=10000
hw.ata.ata_dma=1
hw.ata.atapi_dma=1
autoboot_delay="3"
sbp_load=“YES“
cuse4bsd_load="YES"
pwc_load="YES"
mmc_load="YES"
mmcsd_load="YES"
sdhci_load="YES"
scd_load="YES"
sound_load="YES"
snd_hda_load="YES"
snd_ich_load=“YES“
aio_load=“YES“
ucom_load=“YES“
u3g_load=“YES“
libiconv_load="YES"
libmchain_load="YES"
cd9660_iconv_load="YES"
msdosfs_iconv_load="YES"
tmpfs_load="YES"
lindev_load=“YES“
vboxdrv_load=“YES“
devfs.rules:

Code:
[localrules=10] 
add path 'ad[0-9]*' mode 0666 group mount
add path 'da[0-9]*' mode 0666 group mount
add path 'acd[0-9]*' mode 0666 group mount
add path 'cd[0-9]*' mode 0666 group mount
add path 'pass[0-9]*' mode 0666 group mount
add path 'xpt[0-9]*' mode 0666 group mount
add path 'ugen[0-9]*' mode 0666 group mount
add path 'usbctl' mode 0666 group mount
add path 'usb/*' mode 0666 group mount
add path 'lpt[0-9]*' mode 0666 group mount
add path 'ulpt[0-9]*' mode 0666 group mount
add path 'unlpt[0-9]*' mode 0666 group mount
add path 'fd[0-9]*' mode 0666 group mount
add path 'uscan[0-9]*' mode 0666 group mount
add path 'video[0-9]*' mode 0666 group mount
add path 'dvb/adapter*/demux*' mode 0660 group mount
add path 'dvb/adapter*/frontend*' mode 0660 group mount
add path 'dvb/adapter*/dvr*' mode 0660 group mount
10-x11-input.fdi:

Code:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
<device>
<match key="info.capabilities" contains="input.keyboard">
<!-- If we're using FreeBSD, we use kbd by default -->
<merge key="input.x11_driver" type="string">kbd</merge>
<match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
string="FreeBSD">
<merge key="input.xkb.layout" type="string">de</merge>
<merge key="input.xkb.variant" type="string">nodeadkeys</merge>
</match>
</match>
</device>
</deviceinfo>
Es lief alles mit meinen Configs out-of-the-Box.

Hat vielleicht jemand einen Tipp?

Vielen Dank im Voraus.

Beste Grüße
kraekers
 

Fusselbär

Makefile Voyeur
#2
Bei mir läufts wie gehabt mit KDE 4.7.4, MP3 Player eingestöpselt und es tut:

(Klicken zum vergrößern)
Das ist auf einem FreeBSD 8.2-STABLE amd64, die Kiste mit dem 9er ist gerade aus, da war mir bislang nichts aufgefallen, müsste mal den MP3 Player einstöpseln wenn die 9er läuft.

In der /etc/rc.conf habe ich DBUS und HAL eingeschaltet:
Code:
egrep 'dbus|hal' /etc/rc.conf

dbus_enable="YES"
hald_enable="YES"
Beim pgrep nach HAL sieht es so aus:
Code:
pgrep -l hal

3253 hald-addon-storage
3252 hald-addon-storage
3248 hald-addon-storage
3247 hald-addon-storage
1910 hald-addon-storage
1909 hald-addon-storage
1906 hald-addon-storage
1905 hald-addon-storage
1902 hald-addon-storage
1901 hald-addon-storage
1898 hald-addon-storage
1897 hald-addon-storage
1894 hald-addon-storage
1893 hald-addon-storage
1881 hald-addon-mouse-sy
1872 hald-addon-mouse-sy
1838 hald-addon-storage
1837 hald-addon-storage
1832 hald-runner
1825 hald
In der /etc/X11/xorg.conf habe ich in der Section "ServerFlags" HAL für die Eingabegeräte abgeschaltet:
Code:
grep AutoAddDevices /etc/X11/xorg.conf

    Option         "AutoAddDevices" "False"
und die Eingabegeräte über die /etc/X11/xorg.conf konfiguriert.

x11-servers/xorg-server ist mit den default Optionen gebaut. HAL ist da bei den Compile Optionen auch eingschaltet.

An fdi Dateien habe ich:
Code:
ls -1 /usr/local/etc/hal/fdi/policy/

10-mouse-sysmouse.fdi
10-power-mgmt-policy.fdi
20-storage-methods.fdi
preferences.fdi
x11-input.fdi
Die 20-storage-methods.fdi sind dort unverändert aus sysutils/hal.
 

kraekers

Well-Known Member
Themenstarter #3
Hallo Fusselbär,

danke für Deine Infos.

Könntest Du mir deine *.fdis einmal zukommen lassen?

Das wäre klasse.

Viele Grüße

kraekers
 

Fusselbär

Makefile Voyeur
#4
So, gerade mal neue world & kernel gebaut und installiert und dann mal in der /etc/xorg.conf
die Option:
Code:
###    Option         "AutoAddDevices" "False"
auskommentiert, um HAL die Eingebegeräte verwalten zu lassen, damit wirklich sicher ist, dass die fdi für die Eingabegeräte auch bei mir funktionieren, bevor ich die hier poste. :ugly:

Die fdi Dateien:
Code:
10-power-mgmt-policy.fdi
20-storage-methods.fdi
... in /usr/local/etc/hal/fdi/policy/ sind perfekte Kopien vom sysutils/hal Port.
Die sind per default unter:
Code:
/usr/local/share/hal/fdi/policy/10osvendor/
zu finden.

Hier ist der Inhalt meiner /usr/local/etc/hal/fdi/policy/preferences.fdi:
Code:
cat /usr/local/etc/hal/fdi/policy/preferences.fdi

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
 
<device>
 <match key="volume.fstype" string="vfat">
  <match key="volume.size" compare_ge="128000000000">
    <merge key="volume.policy.mount_option.large" type="bool">true</merge>
  </match>
 </match>
</device>

</deviceinfo>
Hier ist der Inhalt meiner Tastatur-HAL-Konfiguration /usr/local/etc/hal/fdi/policy/x11-input.fdi:
Code:
cat /usr/local/etc/hal/fdi/policy/x11-input.fdi

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">                                                                                                                                                                                                                                                     
  <device>                                                                                                                                                                                                                                                                     
    <match key="info.capabilities" contains="input.keyboard">                                                                                                                                                                                                                  
      <merge key="input.x11_options.XkbModel" type="string">pc105</merge>                                                                                                                                                                                                      
      <merge key="input.x11_options.XkbLayout" type="string">de</merge>                                                                                                                                                                                                        
      <merge key="input.x11_options.XkbVariant" type="string">nodeadkeys</merge>                                                                                                                                                                                               
    </match>                                                                                                                                                                                                                                                                   
  </device>                                                                                                                                                                                                                                                                    
</deviceinfo>
... der mit meiner Tastatur Konfiguration in der /etc/X11/xorg.conf übereinstimmt:
Code:
Section "InputDevice"                                                                                                                                                                                                                                                          
    Identifier     "Keyboard0"                                                                                                                                                                                                                                                 
    Driver         "keyboard"                                                                                                                                                                                                                                                  
    Option         "XkbModel" "pc105"                                                                                                                                                                                                                                          
    Option         "XkbLayout" "de"                                                                                                                                                                                                                                            
    Option         "XkbVariant" "nodeadkeys"                                                                                                                                                                                                                                   
EndSection
Mein Eintrag für die Maus in der /etc/X11/xorg.conf:
Code:
Section "InputDevice"                                                                                                                                                                                                                                                          
    Identifier     "Mouse0"                                                                                                                                                                                                                                                    
    Driver         "mouse"                                                                                                                                                                                                                                                     
    Option         "Protocol" "auto"                                                                                                                                                                                                                                           
    Option         "Device" "/dev/sysmouse"                                                                                                                                                                                                                                    
    Option         "Buttons" "6"                                                                                                                                                                                                                                               
    Option         "ZAxisMapping" "4 5"                                                                                                                                                                                                                                        
    Option         "Emulate3Buttons"                                                                                                                                                                                                                                           
EndSection
Meine Maus hat Daumentasten, die ich für vor und zurück benutze.
http://www.bsdforen.de/showthread.php?t=25999

Edit:
Oh halt, warte, die fdi Datei für die Maus /usr/local/etc/hal/fdi/policy/10-mouse-sysmouse.fdi ist ja doch angepasst:
Code:
cat /usr/local/etc/hal/fdi/policy/10-mouse-sysmouse.fdi

<?xml version="1.0" encoding="UTF-8"?>

<deviceinfo version="0.2">
  <device>
    <match key="freebsd.driver" string="ums">
      <match key="freebsd.unit" int="0">
        <merge key="info.ignore" type="bool">true</merge>
      </match>
    </match>
  </device>
</deviceinfo>
 
Zuletzt bearbeitet:

kraekers

Well-Known Member
Themenstarter #6
Wunderbar, ich kann jetzt endlich wieder auf KDE zugreifen ohne das ich eine xorg.conf anlegen muss.

K3b zickt aber immer noch. Meckert das kein HAL aktiviert sei, was definitiv nicht stimmt.

So kann K3b kein Optical Drive finden.

Kann es sein, daß das mit atapicam zusammanhängt?

Mein KDE findet überhaupt kein CD/DVD-Laufwerk, egal welches Programm gestartet wird.
 
Zuletzt bearbeitet:

Fusselbär

Makefile Voyeur
#7
Bei mir tut es auch K3b:

(Klicken zum vergrößern)
Hast Du links auf /dev/cd0?
So etwa von /dev/cdrom, /dev/dvd und von /dev/acd0 auf /dev/cd0 gelinkt.
Was sagt:
Code:
ls -la /dev/*cd*
... und:
Code:
ls -la /dev/dvd
Bei mir sind da links, die kommen von /etc/devfs.conf:
Code:
# Commonly used by many ports 
link    cd0     cdrom 
link    cd0     dvd 
link    cd0     acd0
 

kraekers

Well-Known Member
Themenstarter #8
Habe Deine Daten in die /etc/devfs.conf eingetragen, hatte ich vorher nie benötigt, aber man lernt ja nie aus. Jedoch geht es immer noch nicht.

ls -la /dev/*cd* zeigt folgendes an:

Code:
lrw-rw-rw-  1 root  mount         3 Feb 14 15:40 /dev/acd0 -> cd0
crw-rw-rw-  1 root  mount    0,  92 Feb 14 15:40 /dev/cd0
lrwxr-xr-x  1 root  wheel         3 Feb 14 15:40 /dev/cdrom -> cd0
und ls -la /dev/dvd zeigt folgendes an:

Code:
lrwxr-xr-x  1 root  wheel  3 Feb 14 15:40 /dev/dvd -> cd0
 

kraekers

Well-Known Member
Themenstarter #10
Moin,

camcontrol devlist zeigt folgendes (mit eingestecktem USB-Stick)

Code:
<ST9250827AS 3.AAA>                at scbus0 target 0 lun 0 (pass0,ada0)
<Optiarc DVD RW AD-7590S 1.44>     at scbus1 target 0 lun 0 (pass1,cd0)
<SanDisk Cruzer 1.26>              at scbus6 target 0 lun 0 (da0,pass2)
Den Stick kann ich übrigens auch nicht mounten, es erscheint folgende Meldung:

Code:
An error occurred while accessing 'Systeme', the system responded: org.freedesktop.Hal.Device.PermissionDeniedByPolicy: org.freedesktop.hal.storage.mount-fixed auth_admin_keep_always <-- (action, result)
 

Gulp

Well-Known Member
#11
Hy,
kannst Du mit root-Rechten mounten ?
wenn ja, dann steht die Antwort in der 'Meldung'.
Die Dateien in "/usr/local/share/PolicyKit/policy/ " und "/usr/local/etc/PolicyKit/ " müssten
angepasst werden.
Ich benutze zwar xfce, aber Hal ist das doch egal (oder?).
 

kraekers

Well-Known Member
Themenstarter #12
Moin,

das Mounten von USB-Sticks habe ich mittlerweile hinbekommen, das Einzige was nocht nicht funkioniert ist, daß k3b keinen Brennen findet.
 

kraekers

Well-Known Member
Themenstarter #13
Moin,

das Mounten von USB-Sticks habe ich mittlerweile hinbekommen, das Einzige was noch nicht funkioniert ist, daß k3b keinen Brennen findet.

Im übrigen benutze ich auch primär XFCE mit ausgeschaltetem HAL und Automounter, funktioniert prächtig, wollte halt mal KDE wieder antesten.
 

kraekers

Well-Known Member
Themenstarter #16
Moin,

jetzt geht es. Zumindest auf einem Rechner, der zweite Rechner der identisch konfiguriert ist findet komischerweise den DVD-Brenner nicht.

Egal, habe von HAL die Sch..... voll.

Xfce ohne HAL + automounter = perfekt !

Vor allem weiß man nie was die Zukunft bringt. Nachher unterstützt KDE kein HAL mehr und dann ist zappenduster.

Vielen Dank nochmal an Alle.

Beste Grüße
kraekers