• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Kein IPv6 über QLogic NetXtreme II BCM57810 10Gb

teisho

Well-Known Member
Themenstarter #1
Hallo Leute,
zum Rumspielen und Testen konnte ich einen Coloplatz mit 10G ergattern.
Da habe ich mich natürlich nicht lange bitten lassen und einen Server mit FreeBSD 11.2 reingeschraubt.
An das Netzwerk angebunden ist die Kiste über eine QLogic NetXtreme II BCM57810 10Gb.
IPv4 alles super. Geht.

Jetzt bekomme ich aber keine IPv6-Adress, obwohl in dem Netz alle Adressen dynamisch vergeben werden.
Schließe ich den Server mit Kupfer von den Mainboardports aus an ein Switch mit dem selben Netz an, geht alles.

Der Admin meint es läge an mir.
Hat jemand eine Idee?

Code:
$ ifconfig
bxe0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=527bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,WOL_MAGIC,VLAN_HWFILTER,VLAN_HWTSO>
    ether 00:10:aa:aa:aa
    hwaddr 00:10:aa:aa:aa
    inet6 fe80::110:19dd:abcd:2342%bxe0 prefixlen 64 scopeid 0x1
    inet 111.11.60.211 netmask 0xffffff00 broadcast 111.11.60.255
    nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
    media: Ethernet autoselect (10Gbase-SR <full-duplex>)
    status: active
bxe1: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=527bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,WOL_MAGIC,VLAN_HWFILTER,VLAN_HWTSO>
    ether 00:10:18:bb:bb:bb
    hwaddr 00:10:18:bb:bb:bb
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: Ethernet autoselect (none)
igb0: flags=8c02<BROADCAST,OACTIVE,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=6403bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
    ether 00:25:90:cc:cc:cc
    hwaddr 00:25:90:cc:cc:cc
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: Ethernet autoselect
    status: no carrier
igb1: flags=8c02<BROADCAST,OACTIVE,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=6403bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
    ether 00:25:90:dd:dd:dd
    hwaddr 00:25:90:dd:dd:dd
    nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
    media: Ethernet autoselect
    status: no carrier
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
    inet 127.0.0.1 netmask 0xff000000
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    groups: lo
Code:
$ cat /etc/rc.conf
clear_tmp_enable="YES"
syslogd_flags="-ss"
sendmail_enable="NONE"
hostname="nazgul"

ifconfig_bxe0="DHCP"
ifconfig_bxe0_ipv6="inet6 accept_rtadv"

sshd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
zfs_enable="YES"
Code:
$ netstat -nr
Routing tables

Internet:
Destination        Gateway            Flags     Netif Expire
default            111.11.60.254      UGS        bxe0
127.0.0.1          link#5             UH          lo0
111.11.60.0/24     link#1             U          bxe0
111.11.60.211      link#1             UHS         lo0

Internet6:
Destination                       Gateway                       Flags     Netif Expire
::/96                             ::1                           UGRS        lo0
::1                               link#5                        UH          lo0
::ffff:0.0.0.0/96                 ::1                           UGRS        lo0
fe80::/10                         ::1                           UGRS        lo0
fe80::%bxe0/64                    link#1                        U          bxe0
fe80::110:19dd:abcd:2342%bxe0     link#1                        UHS         lo0
fe80::%lo0/64                     link#5                        U           lo0
fe80::1%lo0                       link#5                        UHS         lo0
ff02::/16                         ::1                           UGRS        lo0
[/co
 

teisho

Well-Known Member
Themenstarter #3
Hi,
ich verstehe nicht ganz.
Unterscheidet sich die Konfiguration der QLogic in der rc.conf?
Habe mich eigentlich an das Handbuch gehalten und über die Anschlüsse am Board über Kupfer geht's .

Auch wenn ich die /etc/rc.conf ändere, kein Erfolg.
Code:
ifconfig_bxe0="DHCP"
ifconfig_bxe0_ipv6="inet6 autoconf accept_rtadv"
 

teisho

Well-Known Member
Themenstarter #5
Hi, hier die Ausgabe.
Code:
bxe0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=527bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,WOL_MAGIC,VLAN_HWFILTER,VLAN_HWTSO>
    ether 00:10:aa:aa:aa
    hwaddr 00:10:aa:aa:aa
    inet6 fe80::110:19dd:abcd:2342%bxe0 prefixlen 64 scopeid 0x1
    inet 111.11.60.211 netmask 0xffffff00 broadcast 111.11.60.255
    nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
    media: Ethernet autoselect (10Gbase-SR <full-duplex>)
    status: active