• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Kein WiFi nach boot

crotchmaster

happy BSD user
Themenstarter #1
Moin,

ich kämpfe aktuell mit dem WiFi-Setup unter FreeBSD 12.0 und benötige Hilfe oder Tipps dazu.

Ich habe meine Raspberry Pis auf FreeBSD 12.0 aktualisiert. Als WiFi Dongles nutze ich EDIMAX EW-7811UN Sticks, die mit dem rtwn-Treiber laufen.
In der vor FreeBSD 12.0 Zeit liefen die fast out of the box. Jetzt beim Upgrade musste ich einiges in der Konfiguration ändern, u.a. das richtige Firmwaremodul laden, aber nun bekomme ich zumindest eine Verbindung zu meinem Netzwerk. Das Problem ist nur, dass die Verbindung nicht beim Systemstart aufgebaut wird. Logge ich mich ein und starte wpa_supplicant auf der Konsole, verbindet sich der RasPi mit dem Netzwerk.

Hier die relevanten Konfigs:

/etc/rc.conf
Code:
keymap="de"
hostname="raspberry1Bp"
wlans_rtwn0="wlan0"
ifconfig_wlan0="WPA DHCP"
create_args_wlan0="country DE regdomain ETSI"
ifconfig_ue0="DHCP"
sshd_enable="YES"
ntpd_enable="YES"
ntpdate_enable="YES"
ntpd_sync_on_start="YES"
sendmail_enable="NONE"
sendmail_submit_enable="NO"
sendmail_outbound_enable="NO"
sendmail_msp_queue_enable="NO"
netwait_enable="YES"
/boot/loader.conf
Code:
accf_data_load="YES"
if_urtwn_load="YES"
if_lagg_load="YES"
wlan_load="YES"
wlan_amrr_load="YES"
wlan_ccmp_load="YES"
legal.realtek.license_ack=1
rtwn-rtl8188eufw_load="YES"
/etc/wpa_supplicant.conf
Code:
network={
    priority=0
    ssid="K***n"
    psk="40 ASCII-Zeichen lange Passphrase"
}
ifconfig wlan0 nach dem Boot:
Code:
wlan0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 80:1f:02:ef:df:da
        groups: wlan
        ssid "" channel 1 (2412 MHz 11b)
        regdomain ETSI country DE authmode OPEN privacy OFF txpower 30
        bmiss 7 scanvalid 60 wme bintval 0
        media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
        status: no carrier
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
wpa_supplicant starte ich nach dem Boot mit mit:
wpa_supplicant -B -i wlan0 -c /etc/wpa_suplicant.conf

ifconfig wlan0 nach manuellem wpa_supplicant:
Code:
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 80:1f:02:ef:df:da
        inet 10.10.1.166 netmask 0xffffff00 broadcast 10.10.1.255
        groups: wlan
        ssid K***n channel 11 (2462 MHz 11g ht/20) bssid 64:66:b3:c2:3c:61
        regdomain ETSI country DE authmode WPA2/802.11i privacy ON
        deftxkey UNDEF AES-CCM 2:128-bit txpower 30 bmiss 7 scanvalid 60
        protmode CTS ht20 ampdulimit 64k ampdudensity 8 shortgi -stbc -ldpc
        wme roaming MANUAL
        media: IEEE 802.11 Wireless Ethernet MCS mode 11ng
        status: associated
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
Danke schon mal fürs Lesen.

Gruß c.
 
Themenstarter #6
Nur zur Info und damit der Thread auch einen Abschluss findet. Ich habe die Ursache gefunden. Das Problem war eins dieser OSI-Layer 8 Probleme. ;'(

Wenn Mann die Datei /etc/wpa_supplicant.conf als /etc/wpa_suplicant.conf speichert, kann es auch nicht funktionieren.
Es ist ein schwacher Trost, dass ich nicht der Einzige bin, der das übersehen hat. ;)