• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Keine Maus in X

Sir_Blizzardz

Well-Known Member
Themenstarter #1
Guten Abend,

ich verwende zwar Xmonad aber ich glaube nicht, dass mein Maus-Problem ein Xmonad-Problem ist, viel mehr ein generellex X-Problem.

Ich sehe zwar den Mauszeiger, kann ihn aber nicht bewegen. An meinem Desktop-PC habe ich eine PS2-Maus und habe mir auch schon dieses Kapitel[1] zu Gemüte geführt - leider erfolglos.

Hier [2] kann man die Ausgabe von dmesg sehen, hier [3] die Ausgabe von /var/log/Xorg.0.log, aus der ich zumindest lesen kann, dass das Modul "mouse" geladen wird.

Woran kann es denn liegen, dass ich die Maus nicht bewegen kann?

Rahmendaten:
Code:
FreeBSD punica 11.1-RELEASE FreeBSD 11.1-RELEASE #0 r321309: Fri Jul 21 02:08:28 UTC 2017  root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64
Code:
$ pkg info |grep driv
libva-1.8.3                    VAAPI wrapper and dummy driver
mesa-dri-17.1.10               OpenGL hardware acceleration drivers for DRI2+
xdriinfo-1.0.5_1               Query configuration information of DRI drivers
xf86-input-keyboard-1.9.0_1    X.Org keyboard input driver
xf86-input-mouse-1.9.2_1       X.Org mouse input driver
xf86-video-scfb-0.0.4_5        X.Org syscons display driver
xf86-video-vesa-2.3.4_1        X.Org vesa display driver
xorg-drivers-7.7_5             X.org drivers meta-port
[1] https://www.freebsd.org/doc/en/books/faq/x.html#x-and-moused
[2] https://paste.hihn.org/gU7d
[3] https://paste.hihn.org/imtr
 

pit234a

Well-Known Member
#5
Nein, die Maus geht auch ohne X nicht.
kannst du anders verifizieren, dass die Maus an diesem PC überhaupt geht?

Die Maus kann in X gehen, ohne dass der moused laufen muss und normalerweise wird sie automatisch erkannt und läuft sofort, wenn man gar nichts anstellt. Ich habe mir das Xorg.0.log nicht angesehen, weil das scheinbar ein Link auf eine externe Seite ist und das wollte ich nicht machen.
Manchmal gab es Probleme, dass das automatische Erkennen von Geräten mit anderen Methoden in Karambolage geriet. Dazu wird auch im von dir verlinkten Handbuch etwas erklärt. Etwas in der Art in der xorg.conf würde da vielleicht helfen, bei mir tat es das:
Code:
Section "ServerFlags"
  Option  "AutoAddDevices" "False"
  Option  "AllowEmptyInput" "Off"
EndSection
Aber ich halte es für wichtig, erst die Maus an diesem Rechner mal so zu testen, dass man weiß, dass sie überhaupt geht. Kannst du vielleicht probeweise ein anderes System booten? Ein Live-System (irgendein GNU/Linux mit Live-Funktion oder speziell das gute Knoppix) könnte hier hilfreich sein.

Achso, wenn das automatische Einbinden wie oben abgeschaltet ist, sollte die Maus auch noch in der xorg.conf konfiguriert werden.
Aber, normalerweise (sagen alle) braucht man heute gar keine xorg.conf und alles sollte direkt automatisch funktionieren.
 

marcel

Well-Known Member
#6
Hi @Sir_Blizzardz ,

in Deiner Ausgabe von dmesg sehe ich kein psmX und auch kein atkbdX. Da Du den GENERIC-Kernel benutzt, der die notwendigen EInträge
Code:
# atkbdc0 controls both the keyboard and the PS/2 mouse
device  atkbdc   # AT keyboard controller
device  atkbd    # AT keyboard
device  psm      # PS/2 mouse
enthält, liegt es nahe, dass Deine Maus, bzw. die Schnitstelle nicht erkannt wird.
 
#7
Ich würde mal eine USB-Maus anschließen.
Heutzutage gibt es doch nur noch einen (zweifarbigen) PS2-Anschluss - entweder für Maus oder eben für Tastatur. Vielleicht liegt darin das Problem.

Rob