• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

keine Maus mehr auf ttyv

H

holgerw

Guest
Themenstarter #1
Hallo,

mir ist aufgefallen, dass ich am Terminal keine Maus mehr habe (unter X mit plasma5 läuft die Maus hervorragend).

In meiner /etc/rc.conf
Code:
moused_enable="YES"
moused_device="/dev/ums0"
Beim Ab- und wieder Anstöpseln:
Code:
ums0: <PixArt USB Optical Mouse, class 0/0, rev 2.00/1.00, addr 6> on usbus0
ums0: 3 buttons and [XYZ] coordinates ID=0
ums0: at uhub0, port 2, addr 6 (disconnected)
Warum zeigt die letzte Zeile - obgleich die Maus angestöpselt bleibt - ein disconnected?

Eine andere USB-Maus zeigt das gleiche Verhalten.

Ich hätte schon gernre die Maus wieder auch am Terminal ohne Xserver.

In /dev gibt es übrigens auch bei angestöpselter Maus kein ums0.

Viele Grüße,
Holger
 

Vril

Well-Known Member
#2
Wofuer brauchst Du eine Maus im Terminal, wenn sie doch hervorragend und reproduzierbar
unter dem ach so genialen Plasma5 laeuft?

duck & weg... :-)

Holger! das ist jetzt einfach nur witzig und humor voll gemeint... Du kennst mich ja inzwischen etwas ;-)
Gruss walter
 

pit234a

Well-Known Member
#3
das ist eine merkwürdige Sache und scheint von mancherlei abhängig, denn bei mir funktioniert das bei gleichen Einstellungen einmal hervorragend und auf einem weiteren Rechner leider gar nicht. Merkwürdig ist deshalb für mich eher, wenn es bei dir plötzlich nicht mehr geht.
Bei dem PC, bei dem es funktioniert, starte ich nicht extra den moused in der rc.conf, ich verhindere ihn aber auch nicht explizit.
In ps sehe ich, dass er so gestartet wurde:
/usr/sbin/moused -p /dev/ums0 -t auto -I /var/run/moused.ums0.pid

Vielleicht kannst du das mal überprüfen und zunächst auch ohne X starten und testen.
ich kann mir nämlich vorstellen, dass anschließend X und weitere Dienste die Maus auf der Konsole erst beenden. Insbesondere bei Verwendung von HAL habe ich solche Sachen schon erlebt und deshalb auch eine Option "AutoAddDevices" "False" in meiner xorg.conf
 
H

holgerw

Guest
Themenstarter #4
Wofuer brauchst Du eine Maus im Terminal, wenn sie doch hervorragend und reproduzierbar
unter dem ach so genialen Plasma5 laeuft?

duck & weg... :-)

Holger! das ist jetzt einfach nur witzig und humor voll gemeint... Du kennst mich ja inzwischen etwas ;-)
Gruss walter
:D na komm, so humorlos bin ich doch auch nicht.

Bei dem PC, bei dem es funktioniert, starte ich nicht extra den moused in der rc.conf, ich verhindere ihn aber auch nicht explizit.
In ps sehe ich, dass er so gestartet wurde:
/usr/sbin/moused -p /dev/ums0 -t auto -I /var/run/moused.ums0.pid

Vielleicht kannst du das mal überprüfen und zunächst auch ohne X starten und testen.
Okay, danke, werde ich mal machen, wenn mein neuer Repo-Build fertig ist.

Viele Grüße,
Holger
 

steinex

Well-Known Member
#5
Lass mich raten, Du hast letztens mein "Tutorial" bzgl. Multimediatasten befolgt und nutzt seitdem den uhidd? Der schaltet das Kernel-Device aus.

Ich würde moused_device einfach mal aus der rc.conf werfen, moused sollte das richtig device (welches jetzt dann halt von uhidd zur Verfügung gestellt wird) alleine finden.
 
H

holgerw

Guest
Themenstarter #8
Hallo @steinex

stimmt, ich habe Dein Tutorium für die Multimedia-Tastatur abgearbeitet.

Ich werde heute Abend mal den Device-Eintrag auskommentieren und weiter berichten.

Danke für den Hinweis.