• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Keine Passwortänderung möglich

Olodin

Reading User
Themenstarter #1
Hallo,

wenn ich für einen beliebigen User das Passwort wechseln möchte, bekomme ich eine Fehlermeldung:

Code:
[user@host ~]$ passwd
Changing local password for user
Old Password:
New Password:
Retype New Password:
passwd: entry inconsistent
passwd: pam_chauthtok(): error in service module
[user@host ~]$
Im Log find ich folgendes:
Code:
passwd: in pam_sm_chauthtok(): pw_copy() failed
Das passiert als User, als Root, egal wie. Schliesse damit ein Rechteproblem aus. /etc/pam.d hab ich schon gegen /usr/src/etc/pam.d gecheckt: die Verzeichnisse sind identisch.

Hat jemand ne Idee?
 

Olodin

Reading User
Themenstarter #3
Illuminatus hat gesagt.:
probier mal man pwd_mkdb aus, ist nur eine Vermutung... (Parameter -C)
Hmmm:

Code:
[root@host freebsd]# pwd_mkdb -C /etc/passwd
pwd_mkdb: corrupted entry
pwd_mkdb: at line #3
pwd_mkdb: /etc/passwd: Inappropriate file type or format
[root@host freebsd]#
In Zeile 3 ist der Root User eingetragen und sieht so aus:

Code:
root:*:0:0:Charlie &:/root:/usr/local/bin/bash
Das & ist mir schon aufgefallen, das hab ich bisher nur bei Maschinen-Accounts gesehen. Was tun?
 
Zuletzt bearbeitet:

.align64

66 46 83 46 68 46
#6
pwd_mkdb(8) ist ja auch für die /etc/master.passwd vorgesehen.

Das '&' ist ein gültiges Zeichen und nicht für das Problem verantwortlich.

__Solid_Snake
 

Olodin

Reading User
Themenstarter #7
.align64 hat gesagt.:
pwd_mkdb(8) ist ja auch für die /etc/master.passwd vorgesehen.

Das '&' ist ein gültiges Zeichen und nicht für das Problem verantwortlich.

__Solid_Snake
Code:
# pwd_mkdb -C /etc/master.passwd
Gibt schlicht nix zurück. Deswegen geh ich davon aus, das mit dem File alles ok ist.


Edit:

Aber das hats getan:

Code:
# pwd_mkdb /etc/master.passwd
Jetzt kann ich fröhlich Passwörter ändern. Danke für die Anregungen. :)
 
Zuletzt bearbeitet: