• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Kernel- bzw. Modulparameter setzen, wie?

Rosendoktor

Well-Known Member
Themenstarter #1
Hallo zusammen,

hab' mich schon länger gewundert wieso meine X220 Notebooks bei Verbindung zu meinem selbstgebauten Router im WLAN nur auf max. 50MBit Nettodurchsatz kommen. Brutto wird je nach Ort in der Wohnung bis zu 150MBit angezeigt.

Jetzt habe ich dem Router zwei weitere Antennen verpasst (also zwei Antennen pro Band statt bisher einer), als Bruttodatenrate wird jetzt bis zu 300MBit angezeigt. Netto blieb es aber bei max. 50MBit, gemessen mit iperf unter Debian 10.

Das hat mich dann schon geärgert. :grumble:

Und so hab' ich herausgefunden, dass ich unter Linux dem Treiber einen Parameter mitgeben muss:

/etc/modprobe.d/iwlwifi.conf
Code:
options iwlwifi 11n_disable=8
Ein modinfo iwlwifi sagt dazu das hier:
Code:
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
Dann sind die Nettoraten deutlich höher, bei Sichtverbindung im Flur bis zu 180MBit. Damit bin ich zufrieden.

Nun hab' ich das unter FreeBSD bisher nie gemessen, da war ich schon froh wenn mit den Intel Karten überhaupt eine Verbindung zustande kam...

Aber siehe, gleiches Problem wie unter Linux, max. 50MBit.

Jetzt will ich's natürlich wissen... :cool: Nur, ich habe keinen Plan wie ich dem FreeBSD Kernel bzw. dem Modul diesen Parameter mitgeben kann, geschweige denn, wie das Modul für die Intel Karten überhaupt heisst.

In der rc.conf steht dies:
Code:
wlans_iwn0="wlan0"
ifconfig_wlan0="WPA DHCP country DE"
ifconfig_wlan0_ipv6="inet6 accept_rtadv"
kldstat gibt das hier aus:
Code:
Id Refs Address                Size Name
1  104 0xffffffff80200000  2136000 kernel
2    2 0xffffffff8263e000     9aa0 opensolaris.ko
3    1 0xffffffff82648000   388707 zfs.ko
4    1 0xffffffff829d1000    1d4a3 geom_eli.ko
5    1 0xffffffff82c21000     81f0 tmpfs.ko
6    1 0xffffffff82c2a000     1a20 fdescfs.ko
7    1 0xffffffff82c2c000     490c linprocfs.ko
8    3 0xffffffff82c31000     2e28 linux_common.ko
9    1 0xffffffff82c34000   12ce50 i915kms.ko
10    1 0xffffffff82d61000    76990 drm.ko
11    4 0xffffffff82dd8000    104f0 linuxkpi.ko
12    3 0xffffffff82de9000    12f30 linuxkpi_gplv2.ko
13    2 0xffffffff82dfc000      6c0 debugfs.ko
14    1 0xffffffff82dfd000     2e80 acpi_ibm.ko
15    1 0xffffffff82e00000    151a8 pefs.ko
16    1 0xffffffff82e16000      b98 coretemp.ko
17    1 0xffffffff82e17000     9c08 fuse.ko
18    1 0xffffffff82e21000     2780 if_urndis.ko
19    3 0xffffffff82e24000     1550 uether.ko
20    1 0xffffffff82e26000     34a0 if_cdce.ko
21    1 0xffffffff82e2a000     1140 if_ipheth.ko
22    1 0xffffffff82e2c000     5794 cuse.ko
23    1 0xffffffff82e32000     3aa0 ng_ubt.ko
24    5 0xffffffff82e36000     a020 netgraph.ko
25    1 0xffffffff82e41000     9608 ng_hci.ko
26    3 0xffffffff82e4b000      9c0 ng_bluetooth.ko
27    1 0xffffffff82e4c000     cd40 ng_l2cap.ko
28    1 0xffffffff82e59000    1b9c0 ng_btsocket.ko
29    1 0xffffffff82e75000     2190 ng_socket.ko
30    1 0xffffffff82e78000      fe0 cpuctl.ko
31    1 0xffffffff82e79000    39970 linux.ko
32    1 0xffffffff82eb3000    33c60 linux64.ko
33    1 0xffffffff82ee7000     5590 vkbd.ko
34    1 0xffffffff82eed000      acf mac_ntpd.ko
Da sehe ich kein Modul welches ich mit iwn0 in Verbindung bringen könnte...

Kann mir jemand helfen? :confused: Danke!

Ach ja, selbstgebauter Kernel. Eine loader.conf gibt's nicht, da ich aus GRUB heraus direkt den Kernel starte.
 

Rosendoktor

Well-Known Member
Themenstarter #4
Um das Problem vielleicht an der Wurzel zu packen, auf was für'n modi ist denn deine wifi karte? da freebsd gerne mal auf 802.11a setzt. :)
ifconfig sagt
Code:
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    ether 10:0b:a9:4b:12:c4
    inet6 fe80::120b:a9ff:fe4b:12c4%wlan0 prefixlen 64 scopeid 0x3 
    inet6 2001:470:abcd:202:120b:a9ff:fe4b:12c4 prefixlen 64 autoconf 
    inet6 2001:470:abcd:202:e92a:9736:cfc7:6f86 prefixlen 64 autoconf temporary 
    inet6 fd10:2842:f0d1:202:5d32:abf3:7de2:5ec prefixlen 128 
    inet 192.168.1.19 netmask 0xffffff80 broadcast 192.168.1.127 
    groups: wlan 
    ssid Sagittarius channel 36 (5180 MHz 11a ht/40+) bssid 02:a5:04:3d:96:10
    regdomain ETSI country DE authmode WPA2/802.11i privacy ON
    deftxkey UNDEF AES-CCM 2:128-bit txpower 17 bmiss 10 mcastrate 6
    mgmtrate 6 scanvalid 60 ampdulimit 64k ampdudensity 8 -amsdutx amsdurx
    shortgi -stbc -ldpc wme roaming MANUAL bintval 1000
    media: IEEE 802.11 Wireless Ethernet MCS mode 11na
    status: associated
    nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
Also 11na, ht40+

kldstat sagt nur, welche Module gerade geladen sind und nicht, welche zum Laden verfügbar sind...
Ja, das WLAN läuft aber, also muss der Treiber ja auch geladen sein.
 

Rosendoktor

Well-Known Member
Themenstarter #8
Danke Euch.

Nachdem auf der man Page des iwn Treibers nichts zu finden ist, und auch eine Suche im Quellcode nach "agg(regate)" und "TX" in verschiedenen Varianten ausser Kommentaren wie "TODO: ..." oder "This is not enough..." nichts offenbarte was ins Auge springt, geh' ich mal davon aus dass der Treiber mit dieser Karte das einfach nicht kann...

Na gut, kann damit leben. Muss ich ja auch. ;'(

Grüße!