• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

kppp / kinternet für ISDN4BSD?

Themenstarter #1
Hallo Leute!

Ich bin neu in diesem Forum und bin auch Neuling in Sachen
FreeBSD.
Jetzt habe ich mich von meinem Suse Linux getrennt und FreeBSD installiert und ich bin wirklich sehr begeistert.

Nur habe ich ein Problem mit dem ISDN. Die ganze Zeit suche ich nach einem ähnlichen programm für FreeBSD , wo ich meine Internetverbindung unter KDE aufbauen kann. Kppp ist scheinbar nutzlos für ISDN oder ?
Gibt es wirklich nur die Möglichkeit mit Scripten meine Verbindung aufzubauen?

Vielen Dank

Fletscher
 
Themenstarter #3
sorry..

Sorry , sicherlich hast du mich falsch verstanden.

Ich suche einen GRAFISCHEN Dialer für KDE.
Mit Scripten läuft alles prima!

...und gegoogelt hab ich natürlich auch schon. :-)
 
#4
ooops... hab ich.

dazu kann ich dir dann nichts konkretes mehr sagen, aber...
ich glaube mich dunkel zu erinnern, daß für kppp der pppd nötig ist und das es bei der kompilierung auf anderen plattformen (als linux, für die kppp geschrieben ist) manchmal probleme mit den includes und defines gab (in irgendeiner .cpp datei)

tschö mit ö
e.
 
Themenstarter #5
Schaaaade

Jetzt bin ich schon ein bisschen entäuscht.
Die ganz script-einwählerei nervt irgendwie...
Irgendwie steht da FreeBSD noch auf dem Niveau von Linux vor 3 Jahren.
Ist dann wohl doch nicht so mein Geschmack.

Nichts für Ungut.


fletscher
 

buebo

Well-Known Member
#6
Ich würde dir empfehlen einfach ppp über die Flag mitzuteilen sich automatisch einzuwählen, das finde ich zumindest am praktischsten wenn ich mit Notebook und ISDN unterwegs bin.
AFAIK läuft das über ppp -auto aber da sollte dir die manpage weiterhelfen

buebo
 
Themenstarter #7
Wie schon gesagt.: Bei dieser automatischen Scripteinwahl kriege ich Bauchschmerzen. Ich möchte gern von Hand die Verbindung aufbauen und von Hand wieder beenden ohne irgendwelche Scripte die nach TimeOuts die Verbindung schließen.

Scheinbar gibt es wirklich kaum Möglichkeiten das zu bewerkstelligen.
Ist doch eigentlich ein ganz simple Sache oder?
Sorry für den Satz jetzt aber Linux und Windows beherrschen
diese banalen Dinge.
 

void

New Member
#8
wieso sagst du ppp nicht, dass es sich einwählen soll per hand.

also:

saturn# ppp
Working in interactive mode
Using interface: tun0
ppp ON saturn> dial msn

und beim schliessen:

PPP ON saturn> close

is das "von hand" genug? :)
 
Themenstarter #9
Hallo Leute!

Nun habe ich erstmal alles so konfiguriert wie es in der Doku von
ISDN4BSD steht.

Der Tipp von Void hat mir ganz gut gefallen. Ich habe ppp von
hand gestartet.
Nun kam folgende Fehlermeldung beim einwählen:
------
tun0: Phase: deflink: /dev/i4brbch0: No carrier (increase ``set cd'' from 6 ?)
------

Scheinbar funktioniert da die ISDN karte nicht richtig oder?
Beim Starten des Kernels kommt jedenfalls keine Fehlermeldung.
 
#10
Re: sorry..

Original geschrieben von fletscher1507
Sorry , sicherlich hast du mich falsch verstanden.

Ich suche einen GRAFISCHEN Dialer für KDE.
Mit Scripten läuft alles prima!

...und gegoogelt hab ich natürlich auch schon. :-)

hab ich das richtig verstanden, bei der automatischen einwahl "klappt alles prima" und bei verbindung von hand kriegst du nen error???
 

lme

FreeBSD Committer
#11
Original geschrieben von fletscher1507
Hallo Leute!

Nun habe ich erstmal alles so konfiguriert wie es in der Doku von
ISDN4BSD steht.

Der Tipp von Void hat mir ganz gut gefallen. Ich habe ppp von
hand gestartet.
Nun kam folgende Fehlermeldung beim einwählen:
------
tun0: Phase: deflink: /dev/i4brbch0: No carrier (increase ``set cd'' from 6 ?)
------

Scheinbar funktioniert da die ISDN karte nicht richtig oder?
Beim Starten des Kernels kommt jedenfalls keine Fehlermeldung.
Hi Fletscher,

ich hab mich gestern auch mit der Konfiguration von ISDN rumgeschlagen und kenne den Fehler. Es liegt nicht an der ISDN Karte, sondern an einem fehlenden Eintrag in der ppp.conf.
Wäre schön, wenn du die mal hier bekannt geben würdest, dann werde ich den Fehler hoffentlich finden.


Wenn ich mich nicht irre, lag der Fehler bei mir an den folgenden Einträgen. Nachdem ich die alle drin hatte / auskommentiert habe, ging es:

##ppp.conf

# set mrru 1500 # Multilink mode please
# set mru 1504 # Room for the MP header

clone 1,2 # Two new links
link deflink rm # And get rid of the original one

link * set mode auto # Automatically manage the second link
# set autoload 10 80 30 # Down @10% usage, up at 80%, 30s sample

# set server /var/run/ppp/ppp-isdn "" 0177 # The diagnostic port (-rw-------)


Gruß
laemodost
 
Zuletzt bearbeitet:
#12
Einwahl auf die bequeme art

Ein Bisschen Shell und die Einwahl klappt ohne Probleme auf Knopfdruck.
Bei mir bringt mich der Aufruf
$ ppp -background PROVIDER
ins Internet und der Aufruf von
$ kill `ifconfig tun0 | grep Opened | cut -f 4 -d " "`
beendet die Verbindung.

Klappt bisher 1 A, und ein Symbol dafür sollte sich auch auf den KDE (oder wohin auch immer) legen lassen.

Gruss
 
Themenstarter #13
meine ppp.conf

Hallo Jungs!

Meine ppp.conf sieht wie folgt aus:

default:
set log Phase Chat LCP IPCP CCP tun command
ident user-ppp VERSION (built COMPILATIONDATE)

set timeout 180 # 3 minute idle timer (the default)
enable dns # request DNS info (for resolv.conf)

T-Offline:

# die neu eingefügten Zeilen von <laemodost>
clone 1,2
link deflink rm
link * set mode auto

set log local phase chat ipcp ccp tun command
set redial 10 4
set timeout 1800 300
set ifaddr 10.0.0.1/0 10.0.0.2/0
add default HISADDR
set phone 0191011
set authname XXXXXXXX
set authkey YYYYYYYY
set dial
set login
set hangup
set device /dev/i4brbch0 /dev/i4brbch1
set speed sync
nat enable yes

enable lqr
set lqrperiod 45
disable pred1 deflate mppe

papchap:
#
# edit the next three lines and replace the items in caps with
# the values which have been assigned by your ISP.
#


vielleicht könnt ihr was damit anfangen.
 
#14
$ cat /etc/ppp/ppp.conf
default:
set device /dev/i4brbch0
set dial
set hangup
set login
set proctitle ppp-isdn
set speed sync
allow users rauswahl


arcor:
set phone "0192072"
set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.0 0.0.0.0
add default HISADDR
set authname sagichnicht
set authkey sagichnicht
Also das ist meine ppp.conf und ich komm wunderbar mit ISDN und Arcor ins Internet.
Tut mir leid wenn ich keine Ahnung habe was bei dir falsch sein könnte, aber meine funktioniert so. (und ist etwas kürzer)

Gruss
 

Ripley8

Softwareentwickler
#15
Original geschrieben von fletscher1507
Wie schon gesagt.: Bei dieser automatischen Scripteinwahl kriege ich Bauchschmerzen. Ich möchte gern von Hand die Verbindung aufbauen und von Hand wieder beenden ohne irgendwelche Scripte die nach TimeOuts die Verbindung schließen.

Scheinbar gibt es wirklich kaum Möglichkeiten das zu bewerkstelligen.
Ist doch eigentlich ein ganz simple Sache oder?
Sorry für den Satz jetzt aber Linux und Windows beherrschen
diese banalen Dinge.
Sagt er so :D

Also ich finde das schon ganz gut, dass mein ISDN von alleine
wieder auflegt, wenn die Verbindung idle ist. Nun habe ich
über ISDN aber auch eine richtige Verbindung, d.h. eine feste
IP-Adresse, so dass mir von einem zwischenzeitlichen Abbau
der Verbindung nicht gleich die TCP-Verbindungen sterben...

Ich habe mir dazu zwei kleine Scripte angelegt, die heissen
praktischerweise "isdn+" und "isdn-". Wenn ich mit isdn+
die Verbindung scharfschalte, dann gilt anschliessend, dass
ein Paket nach draussen die Verbindung triggert und wenn
ich mal nix tue, dann wird aufgelegt. Sobald ich wieder was
auf die Leitung schicke, schlägt wieder der Autodial zu.
Wenn ich dann keine Verbindung mehr haben will, dann
tippe ich einfach "isdn-" und schluss ist.

Das habe ich dann auch in Cronjob-Einträgen gehabt, um
so kurz vor dem Mailabruf die Leitung aufzumachen und
nach einer gewissen Zeit wird sie auf jeden Fall wieder
geschlossen. Das war doch sehr von Vorteil, als die erste
Welle Code Red oder Nimda oder wie das Geraffel jetzt
schon wieder heisst auf meinem Apache aufschlug - so war
für mich der Spuk nach 2 Stunden erstmal zu Ende; da
prasselten die Abfragen aus dem Netz nämlich so heftig
rein, dass die Leitung nie lange genug Ruhe hatte.
Anschliessend habe ich mir dann überlegt, wie ich die
Konfiguration ändern muss, dass externe Requests da
nicht stören ;)

Zurück zum Thema: Du willst sicher wissen, wie die Scripte
aussehen.

Code:
#!/bin/sh
PATH=/usr/bin:/bin
interface=`netstat -rn | grep default| awk '{print $NF;}'`
#echo "/sbin/ifconfig $interface up" | /usr/bin/su
/usr/local/bin/sudo /sbin/ifconfig $interface up
Also, mit dem netstat greife ich die Defaultroute ab und
stelle dementsprechend fest, welcher Eintrag aus meiner
isdnd-Liste genommen werden soll. Sehr praktisch, so kann
ich unter zwei verschiedenen isp0 (oder auch ipr0) Devices
verschiedene Provider ansprechen. In der Praxis musste
ich das aber nie so häufig ändern, als dass es sich auch
noch gelohnt hätte, Scripte zu schreiben mit denen ich
automatisiert einen anderen Provider als Route setze.

Und in der Zeile mit dem ifconfig aktiviere ich einfach die
entsprechende Netzverbindung.

isdn- sieht genauso aus, nur halt "ifconfig $interface down".