• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

läuft bei euch natd?

Marco

Well-Known Member
Themenstarter #1
Hallo

Ich habe zwar schon einige Zeit NATd bei mir laufen, habe es aber bisher noch nie wirklich ausprobiert, da ich es nicht brauchte.

Nun möchte mein Bruder aber auf seinem Rechner ein Gamevoice Server öffnen. Dachte ich mir "schön, kann ich wenigstens gleich mal natd ausprobieren". Dachte bisher das es so klappt wie ich es eingerichtet habe. Habs schließlich auch u.a. in einer Guide von mir erwähnt (ohne es ausprobieren -> böse ;) ).

Aufruf von NATd bei Systemstart:
- - - - - - - -
natd_enable="YES"
natd_interface="tun0"
natd_flags="-dynamic -f /etc/firewall/natd.conf"
natd_program="/sbin/natd"


/etc/firewall/natd.conf:
- - - - - - - -
redirect_port tcp 192.168.0.3:9110 9110
redirect_port udp 192.168.0.3:9110 9110


Bei IPFW habe ich natürlich die Port nochmal expliziet für incoming-traffic auf diesem Port freigegeben:

# Gamevoice
ipfw add allow tcp from any 9110 to any 9110 in recv tun0
ipfw add allow udp from any 9110 to any 9110 in recv tun0


Leider funktioniert das ganze nicht. Der Gamevoice Server ist von außen nicht zu erreichen.

Und dann noch eine Frage, die ich schon immer mal geklärt haben wollte. Kann ich natd auch irgendwie neustarten?
 
#2
ich benutze nicht natd, aber den builtin nat von ppp.
ich natd lässt sich mit killall -HUP natd neu starten...

# Gamevoice
ipfw add allow tcp from any 9110 to any 9110 in recv tun0
ipfw add allow udp from any 9110 to any 9110 in recv tun0

als erstes würde ich zum testen mal folgende Regel einbauen:
ipfw add 65000 allow log ip from any to any

dann kannst du in deiner logdatei sehen, was woher kommt.

zu deinen regeln:
wieso sollten die leute, die auf den server zugreifen wollen von port 9110 zugreifen? ist das bei dem prog so?
wenn nicht, einfach mal die ersten 9110 rausschmeißen.

gruß
Male
 

asg

push it, don´t hype
#3
Aufruf von NATd bei Systemstart:
- - - - - - - -
natd_enable="YES"
natd_interface="tun0"
natd_flags="-dynamic -f /etc/firewall/natd.conf"
natd_program="/sbin/natd"
OK.

/etc/firewall/natd.conf:
- - - - - - - -
redirect_port tcp 192.168.0.3:9110 9110
redirect_port udp 192.168.0.3:9110 9110
OK.

Bei IPFW habe ich natürlich die Port nochmal expliziet für incoming-traffic auf diesem Port freigegeben:
# Gamevoice
ipfw add allow tcp from any 9110 to any 9110 in recv tun0
ipfw add allow udp from any 9110 to any 9110 in recv tun0
Hast Du auch diese Zeile in Deinen IPFW Rules (?):

ipfw add 10 divert natd all from any to any via tun0

Wenn nicht, rein damit.

Und Deine Kernel hast Du auch mit:
options IPDIVERT
kompiliert?

Bzw. was hast Du alles in den Kernel eingetragen?
 

Marco

Well-Known Member
Themenstarter #4
Sorry hatte ich vergessen zu erwähnen. Ja habe ich natürlich alles drinne. Mich wundert es eben das es nicht funktioniert.

Vielleicht liegt es aber auch garnicht an NATd, sondern an Gamevoice. Ich habs bisher noch nicht mit was anderem getestet.

Muss ich NATd neustarten nachdem ich in der natd.conf was geändert habe? So wie es aussieht, liest NATd die Conf nur beim starten ein. Wenn ja, wie kann ich NATd neustarten, ohne gleich das ganze System rebooten zu müssen?


wieso sollten die leute, die auf den server zugreifen wollen von port 9110 zugreifen? ist das bei dem prog so?
So leite ich ja nur die Anfragen weiter die an Port 9110 gestellt werden weiter. Oder habe ich da was falsch verstanden? Gamevoice nutzt als Standartport die 9110. Demnach ist das doch okay.
 
Zuletzt bearbeitet: