Lösbares php-Versionsproblem?

bsd69

Gitarrist & Cabriofahrer
Hallo Zusammen,

einer meiner Server hat diverse php-Ports in der Version 5.2.17 installiert. Nun muss ich php auf die neueste Version php5-5.4.7 updaten. Und nun habe ich gesehen, dass es folgende Ports leider nicht für die Version 5.4 gibt:

* php52-oci8-5.2.17 The oci8 shared extension for php
* php52-pcre-5.2.17 The pcre shared extension for php
* php52-simplexml-5.2.17 The simplexml shared extension for php

Hmm... Lässt sich dieses Problem lösen? Die obgenannten 5.2-Ports werden nach wie vor von der php-Applikation benötigt.

Für Lösungsvorschläge danke ich jetzt schon!

Gruss Marcel
 

Bummibaer

Registered Schwarzbär
Hoi,
wenn deine PHP Apps noch 5.2.x gerne haben wollen würde ich erstmal zu php 5.3.x raten, da diese vermutlich unter 5.4.x eh nicht korrekt funktionieren werden. Ich würde also zuerst mal alles auf lang/php53 und lang/php53-extensions ziehen und schauen was deine PHP Applikationen damit tun.
Gruß Bummibär
 

bsd69

Gitarrist & Cabriofahrer
Hoi Bummibär,

die php-Applikation wird auf 5.4 portiert, das funzt schon. Aber ich benötige "zwingend" diese Ports (inkl. deren Abhängigeiten wie zBsp. Oracle8-Client etc.) hier:

* phpxx-oci8 The oci8 shared extension for php
* phpxx-pcre The pcre shared extension for php
* phpxx-simplexml The simplexml shared extension for php

Du siehst, was mir Bauchschmerzen bereitet :zitter:

Gruss Marcel
 

Bummibaer

Registered Schwarzbär
Hoi,
php53 bzw. 54 mit oci8 z.B. seh ich nirgends. Müsste Oracle ned scho bei 11 oder so sei ?
Gruß Bummibär
 

kai_001

Well-Known Member
Hi,

pcre ist im php core drin. Simplexml kannst Du unter lang/php5-extensions mit auswählen.

Wegen oci8, da musst Du wohl händisch nacharbeiten: Pecl Package

Grüße,
Kai
 

bsd69

Gitarrist & Cabriofahrer
Hoi,
php53 bzw. 54 mit oci8 z.B. seh ich nirgends. Müsste Oracle ned scho bei 11 oder so sei ?
Gruß Bummibär

Das ist ja mein Problem ....


Hi,

pcre ist im php core drin. Simplexml kannst Du unter lang/php5-extensions mit auswählen.

Wegen oci8, da musst Du wohl händisch nacharbeiten: Pecl Package

Grüße,
Kai

Oh, das sieht ja gar nicht so schlecht aus :) Dann werde ich mich mal dranmachen.

Danke euch beiden :)

Gruss Marcel
 

crotchmaster

happy BSD user
oci8 ist schon ok, damit kann man auch auf eine Oracle 11 DB zugreifen.
Mir war das pecl-Paket aber unbekannt. Habe deswegen eine Entwicklungs-VM mit Linux aufsetzen müssen, weil FreeBSD kein php-oci mehr hat. ;'(

c.
 

bsd69

Gitarrist & Cabriofahrer
oci8 ist schon ok, damit kann man auch auf eine Oracle 11 DB zugreifen.
Mir war das pecl-Paket aber unbekannt. Habe deswegen eine Entwicklungs-VM mit Linux aufsetzen müssen, weil FreeBSD kein php-oci mehr hat. ;'(

c.

Hi, bedeutet somit "unlösbar" in meiner Konstellation, ausser ich versuche es mit dem "pecl-Paket", richtig?

Gruss Marcel
 

bsd69

Gitarrist & Cabriofahrer
Hello Again,

ich habe nun versucht, das Makefile zu "patchen" und php5 mit OCI8 zu compilieren. Soweit, so gut. Das Problem, welches nun beim bauen vom php5 auftritt (die anderen Abhängigkeiten haben durchgebaut), ist folgendes:

Code:
/compat/linux/usr/lib/oracle/10.2.0.3/client/lib/libclntsh.so: could not read symbols: File in wrong format
*** [libphp5.la] Error code 1
1 error
*** [do-build] Error code 1
 
Stop in /usr/ports/lang/php5.
*** [build] Error code 1
 
Stop in
/usr/ports/lang/php5.

Code:
file /compat/linux/usr/lib/oracle/10.2.0.3/client/lib/libclntsh.so
/compat/linux/usr/lib/oracle/10.2.0.3/client/lib/libclntsh.so: symbolic link to `libclntsh.so.10.1'

 file /compat/linux/usr/lib/oracle/10.2.0.3/client/lib/libclntsh.so.10.1 
/compat/linux/usr/lib/oracle/10.2.0.3/client/lib/libclntsh.so.10.1: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped

root@test# uname -ars 
9.1-RELEASE-p3 FreeBSD 9.1-RELEASE-p3 #0: Mon Apr 29 18:11:52 UTC 2013     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  i386

Hmm... denke nicht, dass ich eine 64-Bit-Version von FBSD installiert habe.. Irgendwelche Ideen???

Danke und Gruss
Marcel
 

bsd69

Gitarrist & Cabriofahrer
Ok, da leider "niemand" trotz 1.409 Hits wirklich helfen kann, wird zwangsweise aus dem FBSD-Server ein Linux-Server :grumble::grumble::grumble:

Sche... OCI!

Greetz Marcel
 
Oben