• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

lapboot1.fs disk bootet nicht

Themenstarter #1
Hallo,

ich habe ein Problem mit der lapboot1.fs bootdisk. Mein uralt Laptop, ein Compaq
Contura 430C, bootet nicht davon. Das heisst, er bleibt gleich bei der ersten Zeile
"netBSD (i386)..." stehen, der Servomotor vom Laufwerk dreht sich aber munter
weiter. Ich habe sichergestellt, das der Download in Ordnung war, d.h. das er
nicht fehlerhaft ist. Zudem ist das Laufwerk auch noch in Ordnung, ich habe
davon schon oft Linux gebootet, in verschiedenen Varianten. Die Diskette ist
auch in Ordnung, ich habe sie mehrfach mit rawrite unter windows beschrieben,
und wenn ich ein anderes image auf die gleiche disk spiele, dann geht das.
Eine andere Disk zu nehmen hats auch nicht gebracht.

--> Also: alles an Hardwareversagen habe ich soweit ausgeschlossen.

Also bleibt an sich nur übrig, das sich netbsd irgendwie nicht mit dem Laptop verträgt...
nur komisch, so exotisch ist das Ding nun auch wieder nicht (höchstens uralt... naja).
Wie gesagt, Linux davon zu booten ist kein Problem. Meist habe ich von Slackware
Disks gebootet. Kein Problem.

Was kann das denn sein, kann ich was machen oder gibts noch andere bootdisks,
die pcmcia treiber + 3com Treiber für eine 3c574 (oder so ähnlich, müsste ich nachschauen) mitbringen?


Hintergrund des ganzen, falls Fragen auftauchen:
das ist mein erster Post hier im den BSDforen, und auch mein erster Versuch,
mit BSD Unixen etwas herumzuarbeiten... vorher habe ich hauptsächlich
Unixmässig eigentlich nur mit Linux zu tun gehabt, und ich muss sagen, das ich
mich allgemein mit Open Source Betriebssystemen ganz gut anfreunden kann...
Da ich einfach auch in der BSD Schiene mir einfach mal ein eigenes Bild machen
will, habe ich mir gedacht, ich setze auf meinen uralten, eingestaubten, aber
dennoch funktionstüchtigen Laptop Compaq Contura 430C mit 16MB RAM (ist noch ein 486er... jaaaa ich weiss, so was benutzt doch kein Mensch mehr...) einmal netBSD auf. Es scheint recht sparsam vom ressourcenverbrauch her zu sein, aber darüber wollte ich eigentlich auch nicht diskutieren. Mein Ziel ist es, einerseits ein bischen auf der Shell zu schnuppern,
und einen kleinen webserver darauf aufzusetzen. Also ohne sql server und all das, was
massig Ressourcen frisst. Einfach nurn paar HTML seiten soll er drauf haben, kein php
oder sonstwas. Also wird er auch nicht gross gefordert, hoffe ich mal.

Danke schonmal im Voraus, ich bin über jede Hilfe dankbar. :)
 
E

ex-user_4198

Guest
#2
ch habe ein Problem mit der lapboot1.fs bootdisk. Mein uralt Laptop, ein Compaq
Contura 430C, bootet nicht davon. Das heisst, er bleibt gleich bei der ersten Zeile
"netBSD (i386)..."
Genau das gleiche Problem hatte ich auch bei einem ähnlichen "asbach-uralt" Notebook. Ist aber schon länger her, darum weiss ich nicht mehr genau, wie ich das gelöst habe, aber bei mir stopte die Bootdisk auch immer beim einlesen. Das Notebook war ein Pentium 1 ohne CD oder Netzwerkkarte. . Vielleicht überläuft auch das bescheidene Ram deines Rechners.
http://groups.google.ch/group/muc.l...t&q=netbsd+karim+old+machine#520b80b7da4dae3f

Da es sich bei deinem Rechner um einen 486er hadelt, denke ich nicht, dass das Gerät ein Netzwerkanschluss hat.

Ich hab mal vor langer Zeit (1998) ein Linux auf einen 486SX Notebook installiert und zwar auf sehr abenteurliche Weise. Das Gerät hatte kein NIC oder Modem oder CDROM. So wie deins.

1. Zuerst hab ich mir ne DOS Boot Floppy gemacht und das alte DOS Program "Laplink" draufgepackt.
2. Auf meinem Hauptrechner hatte ich Linux gedownloadet (der hatte ja ne I-net Verbindung).
3 Hab ich auf dem Zielrechner (486SX) eine kleine Dos Partition eingerichtet.
4. Dann hab ich den Hauptrechner mit der DOS Bootdisk gebootet
5. Dann per Nullmodemkabel und Laplink eine Verbindung zweischen Hauptrechner und Notebook aufgebaut.
6. Daten auf eine Partition übertragen auf dem Notebook.
7. Dann Linux entpackt und die 2. Dosparition später gelöscht.

Hat alles funktioniert, aber war ziemlich aufwending. Was willst du eigentlich mit dem Elektroschrott?
 

darktrym

Fahnenträger
#3
@mczero
Was für ein Betriebssystem ist denn noch drauf? Stehen noch zus. Hardware wie PCMCIA Netzwerkkarten, ext. CD Laufwerk zur Verfügung?

Mit 2 Partitionen und eine ISO Image könnte man wohl auch NetBSD installieren. Ein Partition mit der ISO-Image und die andere für die spätere Installation. Ich hatte das mal mit einen Windows Programm durchgezogen, glaube grub kann auch ISO-Images ausführen.
 
Themenstarter #4
Vielleicht überläuft auch das bescheidene Ram deines Rechners.
Ne, ich denke das die 16 MB RAM, die der hat, nicht überlaufen und auch nicht schon an so einem frühen Punkt (er hat vielleicht ein paar KB von der disk gelesen, da ist noch nix mit Kernel geladen)

Was willst du eigentlich mit dem Elektroschrott?
Hehe, sag ichs mal so: ich habe mich schon in den letzten Jahren von so viel Mist
getrennt, alte Mainboards usw... ich habe quasi fast nur noch meinen Hauptrechner,
und ein paar Ersatzteile, falls der Hauptrechner mal nicht mehr will, ich aber
unbedingt was darauf erledigen muss...aber irgendwie bringe ich es nicht übers Herz, ein
funktionstüchtiges Notebook zu entsorgen. Und da ich eh mal in netBSD reinschnuppern
wollte, dachte ich, na nimm das alte Notebook, kannste nicht viel mit machen; aber zumindest
das Grundkonzept von netBSD auf der Console bissl erforschen, und vielleicht ein paar
rudimentäre Netzwerkfunktionen zum laufen bringen.
offtopic: Was tun wir Männer nicht alles, um uns abzulenken, wenn man Urlaub hat
und die Freundin uns verlassen hat... :)
Na genug des rumheulens :rolleyes: zurück zum Thema:
Da es sich bei deinem Rechner um einen 486er hadelt, denke ich nicht, dass das Gerät ein Netzwerkanschluss hat.
Doch doch, ich habe im pcmcia port eine 3COM 3C574 (auch 3COM Megahertz 10/100 genannt).
Ich hoffe, die wird überhaupt unterstützt... aber da das ein sehr gängiges Modell ist, denke ich mal.
Naja, erst mal muss alles andere funktionieren.

Was für ein Betriebssystem ist denn noch drauf? Stehen noch zus. Hardware wie PCMCIA Netzwerkkarten, ext. CD Laufwerk zur Verfügung?

Mit 2 Partitionen und eine ISO Image könnte man wohl auch NetBSD installieren. Ein Partition mit der ISO-Image und die andere für die spätere Installation. Ich hatte das mal mit einen Windows Programm durchgezogen, glaube grub kann auch ISO-Images ausführen.
Ich habe da noch Windows 95 drauf... damit komme ich per Netzwerkfreigabe auf meinen grossen Rechner. Das mit dem ISO Image ist eine coole Idee. Wusste gar nicht, das GRUB sowas kann...
Ich kann auch von meinem Slackware Diskettensatz booten, damit lässt sich per wget Sachen
downloaden und auch auf NFS zugreifen, wenn mans braucht.

Also wäre die ISO Idee an sich ist das erste, was ich probieren werde...
Kann ich eigentlich auch von meinem Slackware booten, und von dort aus eine Installation anwerfen, oder bzw. bis zu einem gewissen Grad vorbereiten? Klar, mit fdisk und so kann ich schon was machen... aber ich meine, vielleicht ein Grundsystem mit tar in eine neu angelegte Partition entpacken oder sowas? Dann von dort aus booten (wenn ich grub irgendwie zum laufen bringe...) und die Installation weiter ausführen?
 
Zuletzt bearbeitet:
Themenstarter #5
So, ich habe das Installationsproblem selbstständig lösen können, zwar konnte ich noch immer nicht NetBSD 4.0 von Diskette booten, aber ich konnte installieren.

1. Zunächst habe ich vorher schon einmal sichergestellt, das meine Windows 95 FAT-Partition nicht die gesamte Festplatte einnimmt.
2. Ich habe den folgenden Kernel heruntergeladen, und in \ auf meiner FAT Partition entpackt
ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-4.0/i386/binary/sets/kern-GENERIC_LAPTOP.tgz
3. Dann habe ich mir grub4dos heruntergeladen, und zwar habe ich mich für diese Variante entschieden, da ich zunächst einmal den MBR in Ruhe lassen wollte, und Windows 95 auch im Falle das ich NetBSD neu installiere, immer bootfähig haben möchte. Link für grub4dos:
http://download.gna.org/grub4dos/grub4dos-0.4.3-2007-03-10.zip
4. grub4dos entpackt nach \boot auf FAT Partition
5. config.sys und autoexec.bat so modifiziert, das man auswählen kann zwischen grub4dos und windows 95.
config.sys:
Code:
[menu]
menuitem=grub
menuitem=windows95

[COMMON]

[grub]
device=c:\boot\grub.exe

[windows95]
device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)
Country=049,850,C:\WINDOWS\COMMAND\country.sys
autoexec.bat:
Code:
if %CONFIG%==grub goto GRUB
if $CONFIG%==windows95 goto WINDOWS95

:GRUB
ECHO

:WINDOWS95
mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)
mode con codepage select=850
keyb gr,,C:\WINDOWS\COMMAND\keyboard.sys
6. Eine c:\menu.lst für grub erstellt:
Code:
default 0

timeout=7

title NetBSD 4.0 pure load
   root (hd0,2)
   kernel /netbsd

title windows95
   root (hd0,1)
   makeactive
   chainloader +1

title NetBSD 4.0 Laptop Installer
   root (hd0,1)
   kernel --type=netbsd /netbsd
Darin enthalten ist auch schon der Bootmechanismus für das installierte NetBSD, dann nocheinmal windows 95, falls man das dann doch starten möchte, und den gerade installierten netbsd-Installer. Windows 95 ist bei mir nicht die erste Partition, daher (hd0,1). Es existiert noch eine sogenannte "compaq" bios partition (hd0,0).
7. Mit grub4dos den netbsd-Installer starten

Das wars. Das einzigste, was mich irritiert, ist die Tatsache, das das laden des Installationskernels und des Kernels des installierten Systems sehr lange braucht.Klar, ich habe hier ne alte Möhre. Aber grub scheint wohl eine Art Einstiegspunkt zu suchen, da er bevor der Kernel gebootet wird, sowas wie ladeadressen ausspuckt. Der Zeit, die zum booten des eigentlichen Kernels gebraucht wird, stört mich gar nicht. Nur das laden/vorbereiten des bootens durch grub dauert ewig lange und stört mich. Kann man den bootvorgang von grub irgendwie beschleunigen? Linux wird wird im gegensatz zu netbsd von grub sehr fix gebootet (ich möchte aber keine diskussion, was nun besser ist, und will hier auch nicht linux hervorheben, es geht mir nur um diesen einen aspekt... aber ich glaube, diese Vergleiche sind hier im BSD forum auch gar nicht so allgegenwärtig, wie in manchen Linux Foren :) ).
Also, kann man grub noch irgendwie beschleunigen?
 

darktrym

Fahnenträger
#6
Die Möglichkeit über einen Ausbau der Platte und Anschluss an einen Desktoprechner mittels IDE Adapter hätte sicherlich auch geklappt - kostet auch nicht die Welt
Vielleicht bekommst du GAG zum laufen. Musst mal schauen, obs an grub liegt, an der Verrenkung oder an der Hardware.

Der ält. Rechner bei dem ich eine Installation durchgeführt hatte, war ein Thinkpad 770 mit 32MB RAM und 233Mhz. Der hatte auch ein CDROM Laufwerk lief, wie erwartet, sehr rund mit APM Unterstützung.
 
Themenstarter #7
Das wäre auch eine Idee, ich hatte mich erst einmal mit dem delay von grub nicht weiter beschäftigt, und mich gleich mal ans neukompilieren des Kernels gewagt :) Dadurch allein bootet das System schon wesentlich schneller, ich bin absolut zufrieden. Mein Ziel war es einfach, den Speicherverbrauch dessen stark zu reduzieren. Das hat besser geklappt, als ich dachte- es ist doch schon ne menge Information im Netz vorhanden. Und ich war unglaublich erstaunt, das das kompilieren anstandslos klappte, und noch nicht einmal irgendwelche warnings ausgespuckt wurden :)
Das kenne ich von Linux so nicht... ich hatte hier ähnliches erwartet, umso größer die Überraschung.
Der Kernel ist auf 1,8 MB geschrumpft. Alle unnötigen Kernel options sind so weit raus. Kann man dem compiler noch andere flags übergeben, die die Größe des binary verkleinern? Ich benutze "-march=i486 -Os". Und wie ist es mit den Sachen, die nach dem booten im Speicher rumschwirren, nachdem man unnötige Dienste auch schon abgeschaltet hat- ich würde solche dinge wie dclient oder was da sonst noch so ist (fällt mir sonst gerade nichts weiter ein) gerne ebenfalls neu kompilieren. Problem ist, das diese binaries in den Distribution Sets drinne sind, aber anscheinend nicht greifbar zum kompilieren durch pkgsrc- oder ich bin einfach nur blind. Danke auch schonmal für alle vorhergehenden Antworten! Nochwas, das ganze bezieht sich ja schon nicht mehr auf den eigentlichen Topic "lapboot1.fs disk bootet nicht", soll/muss das ganze in einen neuen Thread verschoben werden?
 
Zuletzt bearbeitet:

Cessel

Master of Desaster
#8
Naja, du kannst ja das ganze System neu kompilieren.
Allerdings dürfte das auf der alten Möhre sehr lange brauchen.
Eventuell wäre da ein Crossbuild besser. Müsste auch im Handbuch stehen wie das geht.
Wenn du die Make.conf dementsprechend anpasst, sollte das eigentlich nochmal den Verbauch der Systemprogramme senken.

Gruß, Cessel
 
Themenstarter #9
Ja, den Kernel habe ich auch in einer VM auf meinem Hauptrechner kompiliert. Ich werde da mal im Handbuch nach schauen! Gibts noch Tips in Sachen Compilerflags ausser "-march=i486 -Os", um noch bissl was rauszuholen an binarygröße? Ich habe schon massiv gegoogelt, aber nichts brauchbares gefunden.
 
Zuletzt bearbeitet:

Cessel

Master of Desaster
#10
Du kannst mal in den Manual Pages nachschauen.
In der man-Page zu make steht was von einem Tutorial.
Ausserdem gibt es im FBSD WIki Teil noch einen Artikel zum optimieren der Make.conf.
Inwiefern du das auf NetBSD übertragen kannst, weiß ich aber nicht.

Generell ist das -O Flag für Optimierungen zuständig.

Gruß, Cessel