• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Laptop, US-Tastenlayout, OpenBSD - konkrete Kaufempfehlung?

Themenstarter #1
Nachdem ich seit einiger Zeit mit BSD - insbesondere OpenBSD - geliebäugelt habe, haben meine lieben Freunde xargs, sed, awk und make mich nun gemeinsam überredet, doch mal zu versuchen, Linux aufgrund zunehmender Enttäuschung nach 20 Jahren weitgehend hinter mir zu lassen. Da ich einen neuen Laptop benötige, bietet es sich ja an, den explizit für OpenBSD zu kaufen.

In meiner eigenen kleinen Welt, deren einziger Bewohner ich selbst bin, sind sich alle einig, dass meine Anforderungen nicht besonders speziell sind: Ob groß oder klein, neu oder gebraucht - spielt alles keine Rolle. Ich hätte es halt gerne direkt mit US-Tastatur statt dafür nochmal extra was auszugeben und es sollte im Idealfall ca. im Bereich 400-1000 Euro bleiben. Wär auch schön, wenn es keine Antiquität wäre, bestenfalls sogar ab 2015. Ich steh' logischerweise auch nicht unbedingt drauf, die Microsoft-Steuer zu bezahlen (bei ThinkPads irgendwie fast immer der Fall?).

Nun hab ich jetzt schon länger recherchiert, um was Passendes zu finden. Inzwischen bin ich nicht mehr verzweifelt, sondern mindestens verdreifelt. Die Rechner von Tuxedo klangen ja vielversprechend, aber wenn ich dann lese, dass das eher holprig mit OpenBSD läuft ("Neither suspend nor hibernate work. Reporting of battery status is bogus as well.", Quelle), frage ich mich halt schon, ob es da nicht doch was Passenderes gibt.

Also: Wo kann man einen Laptop kaufen, mit dem so eine spezielle Schneeflocke wie ich was anfangen kann?
 

turrican

Well-Known Member
#2
Willst du neu kaufen oder darfs auch was vom Gebrauchtmarkt (da entfiele quasi die von dir angemerkte MS-Steuer) sein?
Spontan fielen mir nur Lenovo als Hersteller mit deren ThinkPads ein, so a la T420, 430 470, oder das X1 Carbon (im "Luxussegment"), aber die hast du vermutlich schon auf dem Schirm gehabt und ggf wg des einen oder anderen für dich nicht gangbaren Grundes verworfen?

Lenovo sag ich u.a. deshalb, weil: OpenBSD lief bei mir mal ne kurze Zeit schon vor Jahren relativ unkompliziert auf nem X61S - bevor dann wieder aus dem einen oder anderen Grund Linux bzw FreeBSD (10 und hernach 11) draufkamen... bei Lenovo-TP funktioniert halt einfach das meiste mit unseren geliebten BSDs... bei anderen Herstellern meist weniger bis gar nichts (da Hardware auf Win ausgelegt, keine Treiber verfügbar usw).
 

berni51

Well-Known Member
#3
Ich hab OpenBSD auf einem Medion Akoya E7221, einem Asus K53U und einem HP (nach dem Typ müsste ich schauen) laufen - klappt bei allen einwandfrei, alle Onboard-devices werden erkannt und unterstützt.
Einzig bei einem Eee701 wird das onboard-Wlan nicht unterstützt, mit einem dlink-stick geht aber auch das.
 
Themenstarter #4
Gebraucht ist voll okay, aber sollte dann schon refurbished sein, und dann ist leider doch wieder ne MS-Windows-Lizenz dabei. Die T420 und T430 sind mir tendenziell halt etwas zu alt. Das T470 hatte ich nicht auf dem Schirm, weil da neben einem Intel-Grafikchip anscheinend auch Nvidia drin steckt und ich da Zweifel hatte, dass das gut unterstützt wird; wenn dem nicht so ist umso besser! Hab da auch gebrauchte US-Versionen bei eBay gefunden, Juhu.

Die anderen Empfehlungen schau ich mir auch mal an, vielen Dank!
 
#5
Bei top-aktuellsten Modellen kann es tatsächlich mal Probleme mit OpenBSD geben. Du bist ja auch "sehr vage" - theoretisch könnte man tatsächlich alles empfehlen sofern OpenBSD drauf läuft und es nach 2015 produziert wurde - da gibt es sicher einige 100 Geräte die in die Kategorie fallen. Aber villeicht trotzdem hilfreich:

Ich hab mir vor wenigen Monate ein gebrauchtes Thinkpad T450s zugelegt und ca. 600 EUR inkl. zwei neuer Batterien bezahlt.

Es funktioniert alles und ich bin mit der Verarbeitung extrem zufrieden.
/edit Ich würde das so jederzeit wieder kaufen, ich hab das Full-HD Modell ohne Touch genommen, das Display ist recht angenehm)

Du wirst fast kein sinnvolles Gerät finden ohne "Microsoft Steuer" da fast alle Hersteller das nunmal mitliefern.
Bei einem Neugerät ist das aber idr. sehr wenig - villeicht 50 EUR, villeicht sogar dtl. weniger. In meinem Beispiel wären also noch 20 EUR davon anteilig übrig ;)

(edit: Etwas ergänzd)
 

xbit

Well-Known Member
#6
ThinkPads kann ich auch empfehlen. Hatte bei notebooksbilliger.de geguckt und gekauft. Da gibts gebrauchte und aeltere Modelle neu inkl. Garantie. Leider alle mit MS Steuer. Und als Layout haben die wohl ueberwiegend ein deutsches Layout. Hatte da nicht darauf geachtet, weill mir das zu aufwaendig ist. Ich nutz einfach das US Layout auf einer deutschen Tastatur.

Ansonsten funktioniert bei meinem X260 alles einwandfrei mit OpenBSD 6.4: WiFi, externes Display, S2RAM, S2Disk. Die gibts wahlweise mit SSD oder HDD.
 
Themenstarter #7
Du bist ja auch "sehr vage" - theoretisch könnte man tatsächlich alles empfehlen sofern OpenBSD drauf läuft und es nach 2015 produziert wurde - da gibt es sicher einige 100 Geräte die in die Kategorie fallen.
Mag sein, aber da ich mit qwerty und non-MS recht exotische Wünsche habe, bin ich halt bei den übrigen Merkmalen zwangsweise ziemlich flexibel. Ein einziger Link zu einem Händler wo ich sowas bekommen kann würde mir schon reichen; da es den vermutlich nicht gibt, bleiben dann nur vage Anforderungen in der Suche nach dem besten Kompromiss, da hast du wohl Recht...

Auf jeden Fall aber Danke dir (und allen anderen) für die Tipps, das hilft definitiv Orientierung zu bekommen.

Du wirst fast kein sinnvolles Gerät finden ohne "Microsoft Steuer" da fast alle Hersteller das nunmal mitliefern.
Bei einem Neugerät ist das aber idr. sehr wenig - villeicht 50 EUR, villeicht sogar dtl. weniger. In meinem Beispiel wären also noch 20 EUR davon anteilig übrig ;)
Das sind immer noch genau 2 Mio. Millicent zu viel! Zwei Millionen! ;)
 

turrican

Well-Known Member
#8
Das T470 hatte ich nicht auf dem Schirm, weil da neben einem Intel-Grafikchip anscheinend auch Nvidia drin steckt
Naja, die nVidia-Seite an dem 470 wirst halt mit dem Gerät kaufen (wenn du eins kaufen solltest), aber mit OpenBSD (vermutlich auch mit FreeBSD, für welche es sogar nVidia-Treiber gäbe) nie nutzen können; der Intel-Teil _sollte_ zumindest funktionieren...

BSD hieß (für mich persönlich) bislang immer "Intel-Grafik" - was immer auch das für jeden im Einzelnen bedeutet; jeder nutzt seine(n) Rechner ja anders bzw hat ne andere Erwartungshaltung daran; zumindest hatte ich persönlich mit den von mir je eingesetzten TPs ( X60S, X61S, X200T (Tablet-Funktionen unter BSD nicht erkannt, snif) und X220 (schreibe diese Zeilen grad auf dem, mit FreeBSD 12)) wenig bis gar keine Probleme mit Free- und OpenBSDs, zumindest kann ich mich an keine großen Sachen erinnern...
 
#10
Ich nutze OpenBSD mit US-Tastatur auf einem Thinkpad T460p. Fuer meine Zwecke laeuft das Teil sehr gut und performant mit der Intel Grafikkarte.

Code:
OpenBSD 6.4-current (GENERIC.MP) #546: Sun Dec 23 09:16:59 MST 2018
    deraadt@amd64.openbsd.org:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 33724887040 (32162MB)
avail mem = 32693297152 (31178MB)
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.8 @ 0xb6f90000 (65 entries)
bios0: vendor LENOVO version "R07ET84W (2.24 )" date 06/05/2018
bios0: LENOVO 20FW003LGE
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP UEFI SSDT SSDT ECDT HPET APIC MCFG SSDT DBGP DBG2 BOOT BATB SLIC SSDT SSDT SSDT MSDM SSDT SSDT DMAR ASF! FPDT UEFI
acpi0: wakeup devices LID_(S4) SLPB(S3) IGBE(S4) PXSX(S4) PXSX(S4) PXSX(S4) PXSX(S4) PXSX(S4) PXSX(S4) XHCI(S3)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpiec0 at acpi0
acpihpet0 at acpi0: 23999999 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i5-6440HQ CPU @ 2.60GHz, 3094.25 MHz, 06-5e-03
cpu0: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: smt 0, core 0, package 0
mtrr: Pentium Pro MTRR support, 10 var ranges, 88 fixed ranges
cpu0: apic clock running at 24MHz
cpu0: mwait min=64, max=64, C-substates=0.2.1.2.4.1.1.1, IBE
cpu1 at mainbus0: apid 2 (application processor)
cpu1: Intel(R) Core(TM) i5-6440HQ CPU @ 2.60GHz, 3092.81 MHz, 06-5e-03
cpu1: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu1: 256KB 64b/line 8-way L2 cache
cpu1: smt 0, core 1, package 0
cpu2 at mainbus0: apid 4 (application processor)
cpu2: Intel(R) Core(TM) i5-6440HQ CPU @ 2.60GHz, 3092.81 MHz, 06-5e-03
cpu2: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu2: 256KB 64b/line 8-way L2 cache
cpu2: smt 0, core 2, package 0
cpu3 at mainbus0: apid 6 (application processor)
cpu3: Intel(R) Core(TM) i5-6440HQ CPU @ 2.60GHz, 3092.81 MHz, 06-5e-03
cpu3: FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE,SSE3,PCLMUL,DTES64,MWAIT,DS-CPL,VMX,SMX,EST,TM2,SSSE3,SDBG,FMA3,CX16,xTPR,PDCM,PCID,SSE4.1,SSE4.2,x2APIC,MOVBE,POPCNT,DEADLINE,AES,XSAVE,AVX,F16C,RDRAND,NXE,PAGE1GB,RDTSCP,LONG,LAHF,ABM,3DNOWP,PERF,ITSC,FSGSBASE,SGX,BMI1,HLE,AVX2,SMEP,BMI2,ERMS,INVPCID,RTM,MPX,RDSEED,ADX,SMAP,CLFLUSHOPT,PT,IBRS,IBPB,STIBP,L1DF,SSBD,SENSOR,ARAT,XSAVEOPT,XSAVEC,XGETBV1,XSAVES,MELTDOWN
cpu3: 256KB 64b/line 8-way L2 cache
cpu3: smt 0, core 3, package 0
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 120 pins
acpimcfg0 at acpi0
acpimcfg0: addr 0xf8000000, bus 0-63
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 1 (PEG0)
acpiprt2 at acpi0: bus -1 (PEG1)
acpiprt3 at acpi0: bus 2 (PEG2)
acpiprt4 at acpi0: bus 3 (EXP1)
acpiprt5 at acpi0: bus -1 (EXP2)
acpiprt6 at acpi0: bus -1 (EXP3)
acpiprt7 at acpi0: bus -1 (EXP4)
acpiprt8 at acpi0: bus -1 (EXP5)
acpiprt9 at acpi0: bus -1 (EXP6)
acpiprt10 at acpi0: bus -1 (RP09)
acpicpu0 at acpi0: C3(200@1034 mwait.1@0x60), C2(200@151 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu1 at acpi0: C3(200@1034 mwait.1@0x60), C2(200@151 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu2 at acpi0: C3(200@1034 mwait.1@0x60), C2(200@151 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpicpu3 at acpi0: C3(200@1034 mwait.1@0x60), C2(200@151 mwait.1@0x33), C1(1000@1 mwait.1), PSS
acpipwrres0 at acpi0: PUBS, resource for XHCI
acpipwrres1 at acpi0: PG00, resource for PEG0
acpipwrres2 at acpi0: PG01, resource for PEG1
acpipwrres3 at acpi0: PG02
acpitz0 at acpi0: critical temperature is 128 degC
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: SLPB
acpipci0 at acpi0 PCI0: 0x00000000 0x00000011 0x00000001
acpicmos0 at acpi0
acpibat0 at acpi0: BAT0 model "45N1777" serial  2264 type LION oem "SANYO"
acpiac0 at acpi0: AC unit online
acpithinkpad0 at acpi0
"PNP0C14" at acpi0 not configured
"PNP0C14" at acpi0 not configured
"PNP0C14" at acpi0 not configured
acpivideo0 at acpi0: GFX0
acpivout at acpivideo0 not configured
cpu0: Enhanced SpeedStep 3094 MHz: speeds: 2601, 2600, 2500, 2300, 2200, 2100, 2000, 1800, 1700, 1600, 1400, 1300, 1200, 1100, 900, 800 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core 6G Host" rev 0x07
ppb0 at pci0 dev 1 function 0 "Intel Core 6G PCIE" rev 0x07: msi
pci1 at ppb0 bus 1
ppb1 at pci0 dev 1 function 2 "Intel Core 6G PCIE" rev 0x07: msi
pci2 at ppb1 bus 2
2:0:0: mem address conflict 0xfff80000/0x80000
"NVIDIA GeForce 940MX" rev 0xa2 at pci2 dev 0 function 0 not configured
inteldrm0 at pci0 dev 2 function 0 "Intel HD Graphics 530" rev 0x06
drm0 at inteldrm0
inteldrm0: msi
error: [drm:pid0:i915_firmware_load_error_print] *ERROR* failed to load firmware i915/skl_dmc_ver1.bin (-22)
error: [drm:pid0:i915_gem_init_hw] *ERROR* Failed to initialize GuC, error -8 (ignored)
inteldrm0: 1920x1080, 32bpp
wsdisplay0 at inteldrm0 mux 1: console (std, vt100 emulation)
wsdisplay0: screen 1-5 added (std, vt100 emulation)
xhci0 at pci0 dev 20 function 0 "Intel 100 Series xHCI" rev 0x31: msi, xHCI 1.0
usb0 at xhci0: USB revision 3.0
uhub0 at usb0 configuration 1 interface 0 "Intel xHCI root hub" rev 3.00/1.00 addr 1
pchtemp0 at pci0 dev 20 function 2 "Intel 100 Series Thermal" rev 0x31
"Intel 100 Series MEI" rev 0x31 at pci0 dev 22 function 0 not configured
puc0 at pci0 dev 22 function 3 "Intel 100 Series KT" rev 0x31: ports: 16 com
com4 at puc0 port 0 apic 2 int 19: ns16550a, 16 byte fifo
ahci0 at pci0 dev 23 function 0 "Intel 100 Series AHCI" rev 0x31: msi, AHCI 1.3.1
ahci0: port 0: 6.0Gb/s
ahci0: port 2: 6.0Gb/s
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, SAMSUNG MZ7TY256, MAT0> SCSI3 0/direct fixed naa.5002538d00000000
sd0: 244198MB, 512 bytes/sector, 500118192 sectors, thin
sd1 at scsibus1 targ 2 lun 0: <ATA, TS512GMTS400, O122> SCSI3 0/direct fixed t10.ATA_TS512GMTS400_D511770448_
sd1: 488386MB, 512 bytes/sector, 1000215216 sectors, thin
ppb2 at pci0 dev 28 function 0 "Intel 100 Series PCIE" rev 0xf1: msi
pci3 at ppb2 bus 3
iwm0 at pci3 dev 0 function 0 "Intel Dual Band Wireless AC 8260" rev 0x3a, msi
pcib0 at pci0 dev 31 function 0 "Intel CQM170 LPC" rev 0x31
"Intel 100 Series PMC" rev 0x31 at pci0 dev 31 function 2 not configured
azalia0 at pci0 dev 31 function 3 "Intel 100 Series HD Audio" rev 0x31: msi
azalia0: codecs: Realtek/0x0293, Intel/0x2809, using Realtek/0x0293
audio0 at azalia0
ichiic0 at pci0 dev 31 function 4 "Intel 100 Series SMBus" rev 0x31: apic 2 int 16
iic0 at ichiic0
sdtemp0 at iic0 addr 0x18: mcp98244
sdtemp1 at iic0 addr 0x1a: mcp98244
em0 at pci0 dev 31 function 6 "Intel I219-LM" rev 0x31: msi, address 50:7b:9d:ef:43:0b
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5 irq 1 irq 12
pckbd0 at pckbc0 (kbd slot)
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
wsmouse0 at pms0 mux 0
wsmouse1 at pms0 mux 0
pms0: Synaptics clickpad, firmware 8.2, 0x1e2b1 0x943300
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
vmm0 at mainbus0: VMX/EPT
uhidev0 at uhub0 port 4 configuration 1 interface 0 "Logitech USB Receiver" rev 2.00/29.01 addr 2
uhidev0: iclass 3/1
ukbd0 at uhidev0: 8 variable keys, 6 key codes
wskbd1 at ukbd0 mux 1
wskbd1: connecting to wsdisplay0
uhidev1 at uhub0 port 4 configuration 1 interface 1 "Logitech USB Receiver" rev 2.00/29.01 addr 2
uhidev1: iclass 3/1, 17 report ids
ums0 at uhidev1 reportid 2: 16 buttons, Z and W dir
wsmouse2 at ums0 mux 0
uhid0 at uhidev1 reportid 3: input=4, output=0, feature=0
uhid1 at uhidev1 reportid 4: input=1, output=0, feature=0
uhid2 at uhidev1 reportid 16: input=6, output=6, feature=0
uhid3 at uhidev1 reportid 17: input=19, output=19, feature=0
ugen0 at uhub0 port 6 "Validity Sensors product 0x0090" rev 2.00/1.64 addr 3
ugen1 at uhub0 port 7 "Intel Bluetooth" rev 2.00/0.01 addr 4
uvideo0 at uhub0 port 8 configuration 1 interface 0 "SunplusIT Inc Integrated Camera" rev 2.00/48.04 addr 5
video0 at uvideo0
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
sd2 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 006> SCSI2 0/direct fixed
sd2: 244190MB, 512 bytes/sector, 500102858 sectors
root on sd2a (642dc0666a2dc0f8.a) swap on sd2b dump on sd2b
iwm0: hw rev 0x200, fw ver 16.242414.0, address e4:b3:18:48:97:7f
 

pit234a

Well-Known Member
#11
besonders sed habe ich in der GNU-Welt schon mit gelegentlichen Unterschieden zu FreeBSD sed erlebt. Das ist nicht weiter dramatisch, aber es müssen dann unter Umständen Anpassungen an Scripts vorgenommen werden. Vielleicht gibt es auch einen GNU-sed für FreeBSD, respektive dann OpenBSD bei dir oder vielleicht ist in OpenBSD sogar der GNU-sed drin und nicht der FreeBSD sed. Ich weiß das nicht. Vielleicht testest du es einfach mal zuvor in einer VM, bevor du nachher Ärger erlebst.
 

turrican

Well-Known Member
#12
Da sieht man die Bedeutung von GNU - GNU's not UNIX...
BSD ist halt ein "echtes" UNIX im Vgl zu Linux - mit allen Facetten...
Bei Solaris waren die GNU Tools damals mit vorangestelltem "g" gekennzeichnet - gsed, gawk, gmake usw, bzw "steuerte" man die Skriptausführung über die Systempfade ... oder es wurde wild gesymlinkt *schauder*