• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

locale auf UTF-8 setzen

klimaschreck

Well-Known Member
Themenstarter #1
Hallo zusammen,

seit meinem Wechsel auf plasma5 habe ich nicht mehr UTF-8 als Standard. Ich weiß nicht, ob ich es vorher hatte, aber ich würde gerne UTF-8 haben.

Wenn ich locale aufrufe, erscheint Folgendes:

Code:
LANG=
LC_CTYPE="C"
LC_COLLATE="C"
LC_TIME="C"
LC_NUMERIC="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_ALL=
Ich habe im großen plasma5 Thread beschrieben in der .xinitrc folgende Einträge:

Code:
export LANG=de_DE.UTF-8
export ck-launch-session startkde
In /etc/rc.conf habe ich Folgendes gesetzt:

Code:
sddm_enable="YES"
sddm_lang="de_DE.UTF-8"
Meine .login_conf sieht folgendermaßen aus:

Code:
me:\
        :charset=UTF-8:\
        :lang=de_DE.UTF-8:
Ich habe auch cap_mkdb aufgerufen.

Habt ihr noch einen Tipp, wie ich UTF-8 setzen kann?
 

Kamikaze

Warrior of Sunlight
Mitarbeiter
#3
Hallo zusammen,

seit meinem Wechsel auf plasma5 habe ich nicht mehr UTF-8 als Standard. Ich weiß nicht, ob ich es vorher hatte, aber ich würde gerne UTF-8 haben.



Meine .login_conf sieht folgendermaßen aus:

Code:
me:\
        :charset=UTF-8:\
        :lang=de_DE.UTF-8:
Das ist eigentlich alles was notwendig sein sollte. Mach' die Anderen Sachen erst mal weg und schau dann ob dein WM vielleicht eigene locale/keyboard Einstellungen hat.
 

klimaschreck

Well-Known Member
Themenstarter #4
@holgerw: wie wähle ich unter sddm auch user? Ich habe einen Login-Bildschirm. Auf der rechten Hälfte sind die User aufgeführt. Dort wähle ich meinen User aus und gebe mein Paßwort ein.
 

holgerw

Well-Known Member
#5
@holgerw: wie wähle ich unter sddm auch user? Ich habe einen Login-Bildschirm. Auf der rechten Hälfte sind die User aufgeführt. Dort wähle ich meinen User aus und gebe mein Paßwort ein.
sddm.jpg

Links oben bei "Session" wählst Du "User" oder "Custom" o.ä., bin gerade auf Arbeit, sonst könnte ich es Dir ganz genau mitteilen :)

Hierzu auch noch ein anderer Thread samt einigen Erläuterungen von Tobias Berner, einem der Committer von plasma5 / kf5:
https://www.bsdforen.de/threads/sddm-login-englisches-plasma5.33724/

Viele Grüße
Holger
 

klimaschreck

Well-Known Member
Themenstarter #6
@holgerw: Wenn ich User links oben auswähle, klappt das Login nicht. Eine Fehlermeldung erscheint nicht auf dem Bildschrim, ich weiß nicht, wo eine Fehlermeldung in eine Datei geschrieben wird.
 

holgerw

Well-Known Member
#8
Anhang anzeigen 3586
Links oben bei "Session" wählst Du "User" oder "Custom" o.ä., bin gerade auf Arbeit, sonst könnte ich es Dir ganz genau mitteilen :)

Hierzu auch noch ein anderer Thread samt einigen Erläuterungen von Tobias Berner, einem der Committer von plasma5 / kf5:
https://www.bsdforen.de/threads/sddm-login-englisches-plasma5.33724/

Viele Grüße
Holger
@holgerw: Wenn ich User links oben auswähle, klappt das Login nicht. Eine Fehlermeldung erscheint nicht auf dem Bildschrim, ich weiß nicht, wo eine Fehlermeldung in eine Datei geschrieben wird.
Für den von mir geposteten Ansatz brauchst Du eine .xinitrc mit der LANG Variablen und mit
Code:
exec ck-launch-session startkde
Außerdem muss dbus gestartet sein.
Dann sollte es klappen.
 

ralli

BSD Fanboy
#9
Ganz ehrlich gesagt @klimaschreck, ich verstehe Deine Einwände nicht. Das gilt auch für andere, die plasma5 ausprobieren oder installieren wollen. Haltet Euch doch bitte an die weiter oben gepostete Installationsanleitung von @holgerw, die ist sehrgut, erprobt und funktioniert 1a, auch mit deutschen Umlauten. Das erspart Euch doch weitere Probleme ..... :rolleyes:
 

pit234a

Well-Known Member
#10
wir hatten das leidige Thema ja schon häufiger hier und es ist nun mal nicht so einfach. Verschiedene Programme sehen an unterschiedlichen Stellen nach den Settings für die locale. Dein Firefox zB interessiert sich nicht für die Einstellungen deiner Shell-Variablen. So kann es sein (wird es vermutlich auch sein), dass KDE oder Plasma wieder ganz eigene Einstellungen haben und gar nicht darauf achten, was dem System mitgegeben wird.

Generell finde ich, dass die Variablen nicht in der ~/.xinitrc gesetzt werden sollten. Meiner Ansicht nach gehören die in die Grundkonfiguration der zugehörigen Shell, also einmal in die /etc/csh.login oder /etc/csh.cshrc:
Code:
setenv LC_ALL de_DE.UTF-8
setenv LANG de_DE.UTF-8
setenv MM_CHARSET UTF-8
und die /etc/profile:
Code:
LC_ALL=de_DE.UTF-8; export LC_ALL
LANG=de_DE.UTF-8; export LANG
MM_CHARSET=UTF-8; export MM_CHARSET
Natürlich kann man das jeweils auch in die ~/.xyz schreiben und nicht Systemweit bestimmen.

Weiter gibt es einige Programme, die nach einer ~/.login nachsehen (manchmal auch .login.conf und ich habe auch mal .login_conf gesehen):
Code:
me:\
    :charset=UTF-8:\
    :lang=de_DE.UTF-8:
Das cap_mkdb /etc/login.conf legt aus der Konfiguration /etc/login.conf eine neue Datenbank an. In der /etc/login.conf kann man da etwa schreiben:
Code:
german|German Users Accounts:\
        :charset=UTF-8:\
        :lang=de_DE.UTF-8:\
        :tc=default:
Damit legt man eine "Gruppe" german an und wenn man diese nutzen möchte, muss die den zugehörigen Usern in der /etc/master.passwd zugewiesen werden udn zwar mittel vipw, damit anschließend an das Editieren auch das zugehörige Binary neu angelegt wird. Ein Eintrag in der master.passwd sieht etwa so aus:
Code:
user:$1$ZQy8cjlU$otNcIcr1NfPN5i7bnn.sY.:1001:0:german:0:0:name user:/home/user:/bin/csh
Neulich gab es hier eine Diskussion darum, dass diese Datenbank aus der /etc/login.conf eigentlich veraltet ist und keinen Sinn mehr macht. Das solltest du vielleicht nachlesen.

Die oben genannten Settings sind wiederum speziell für die dort genannten Programme, die ich allesamt nicht kenne, also etwa sddm oder was da erwähnt wurde. Und wie gesagt: KDE hat sicher eine eigene "Variable" oder einen Eintrag in einer Konfigurationsdatei. Diese muss dann sicher dem Benutzer gehören, der sie verändern möchte.
 

holgerw

Well-Known Member
#11
wir hatten das leidige Thema ja schon häufiger hier und es ist nun mal nicht so einfach.
Doch, ist es in diesem Fall:
@klimaschreck, in Deiner .xinitrc ist ein Fehler, es darf nicht "export ck-launch ...." heißen, sondern die Datei muss folgenden Inhalt haben:
Code:
export LANG=de_DE.UTF-8
exec ck-launch-session startkde
Dann bitte dafür sorgen, dass dbus gestartet ist. Und dann startet plasma5 auch, wenn Du im sddm bei "Session" den Eintrag "user" auswählst.