• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Lokalisierung

waldbaer59

Well-Known Member
Themenstarter #1
Hallo zusammen,

nach einiger Zeit des Herumspielens bin ich wieder einmal als Fragesteller hier.
Es geht um die Lokalisierung des Systems, genauer: um die Konfiguration für eine deutsche Tastatur und die Darstellung der in Deutschland gebräuchlichen Sonderzeichen und Symbole.

Was habe ich schon gemacht?
- in der Doku über Lokalisierung belesen und nach Erfahrungen / Kochrezepten gefahndet.
- etwas herumprobiert, dabei die /etc/login.conf so zerbröselt, dass nach einem cap_mkdb nix mehr ging. Immerhin habe ich gelernt, wie man sich im Single-User an den Haaren wieder aus dem Sumpf ziehen kann. Das ist ja auch schon was ;) .

Was ist eigentlich mein Problem?
Irgendwie verfangen meine Einstellungen nicht wie sie sollten. Im Eingabefeld des Login-Managers Slim greift die deutsche Belegung nicht. Im Lxqt habe ich die Belegung explizit konfiguriert. Da geht's denn auch. In den virtuellen Konsolen und in einem Terminal innerhalb Lxqt jedoch ist zwar das meiste OK, aber Umlaute und Paragraf etwa werden nicht dargestellt.

Falls gewünscht kann ich natürlich auch die rc.conf, login.conf, ttys usw hier zeigen, damit aus dem ??? ein !!! wird. Vielleicht aber hat jemand zu diesem Thema mal was mitgeschrieben und kann mir damit helfen, den Punkt zu erledigen.

Unicode brauche ich nicht. Es tät mir reichen, wenn ich den normalen ISO-8559-1 resp. 8559-15 zu fassen kriege.

VLG
Stephan
 
#2
Moin !

1. /etc/login.conf (Hat als Überschrift Russian Users Accounts. Setup proper environment variables)

german|German Users Accounts:\
:charset=UTF-8:\
:lang=de_DE.UTF-8:\
:tc=default:

2. Als root "vipw" ausführen :

Die Zeile für root und den/die benutzer wo die vier Nullen sind ( :0:0::0:0:) wie folgt füllen !

:0:0:german:0:0:

3. cap_mkdb /etc/login.conf

4. /etc/rc.conf :

keymap="de.kbd"

Das war es eigentlich schon !

Ob SLIM das übernimmt , weiss ich nicht !
Aber der Desktop und die Umlaute sprechen Deutsch !

Gruss
 

SolarCatcher

Well-Known Member
#3
@bluescreen Änderst Du damit nicht die Locale des (eingeloggten) Root-Users? Ich dachte, davon wurde bisher immer abgeraten, weil man nie weiß, wie z.B. Systemprogramme auf eine andere Locale als "C" reagieren. Zumindest werden auf neuen Systemen die Root-User standardmäßig immer noch mit Locale "C" eingerichtet...
 
#4
Moin zusammen,

@SolarCatcher, @bluescreen : In meinen/unseren Systemen halte ich/halten wir es immer so, dass wir die Locale-Einstellungen für root nicht anfassen. Dafür gibt es einen Admin-User-Account und von dort greift man per sudo auf "root" zu. Man weiß ja nie...

Ohne vipw läßt sich die Locale-Einstellung auch mit
pw user mod <username> -L german
auf deutsch umstellen.

Beste Grüße und gesund bleiben!
 
#5
Hi !

@juedan

pw user mod <username> -L german

Werde ich in Zukunft mal antesten !

So wie ich es mache (seit FBSD5.*) hatte ich
bisher keine Probleme !
Allerdings ist das nur für desktop-pc-use ....

Gruss
 

serie300

Well-Known Member
#6
Hallo

gut ich starte X aus der Konsole. Bei mir reicht ein einfaches 'export LC_ALL=de_DE.ISO8859-15' z.B. in der /etc/profile
 

waldbaer59

Well-Known Member
Themenstarter #7
Hallöchen und schon mal vielen Dank.

Zwar bin ich mit der deutschen Tastatur bei der Anmeldung - was Slim betrifft - noch nicht weiter, aber der Rest funktioniert immerhin schon mal so wie er soll. Mein Problem war, dass man im Netz eine Fülle an (mehr oder weniger) stichhaltigen Informationen findet und wenn man diese dann versuchsweise einbaut (und manches vielleicht sogar versehentlich mischt oder unkoordiniert daran herumdoktert) es immer schlimmer wird. Hinterher hat man dann in allerlei Dateien Konfigurationsansätze drin, die sich teilweise gegenseitig 'in die Suppe spucken'.

Daher habe ich erstmal etwas aufgeräumt und dann die Vorschläge nach und nach eingearbeitet. Jetzt sieht es fast schon genauso aus wie es soll und ich kann mich bald der nächsten Baustelle widmen. Erst einmal werde ich aber die Aufzeichnungen über den seitherigen Verlauf meiner Installation auf den Stand bringen. I.w. ist es jetzt nur noch etwas lästiger Kleinkram bis ich durch bin. Dann geht es an Spezialitäten. Die Sicherung mache ich aktuell mit einem "dd" das ich durch "gzip" und "split" pipe. Das wird gelegentlich anders gelöst, aber auch mit der nunmehr neuen SSD gilt: besser eine umständliche Sicherung als gar keine!

Nochmals vielen Dank. Falls noch Impulse bzgl der Lokalisierung hier hineinkommen werde ich sie aufmerksam lesen.

VLG
Stephan
 

berni51

OpenBSD user & NetBSD newbie
#8
Wahrscheinlich ist es bei slim ähnlich: Beim xdm musste ich einen separaten Aufruf von setxkbmap in /etc/X11/xdm/Xsetup_0 vornehmen.
 

pit234a

Well-Known Member
#9
https://www.bsdforen.de/threads/alles-auf-deutsch.33558

Lies dich mal da durch.

Zwar bin ich mit der deutschen Tastatur bei der Anmeldung - was Slim betrifft - noch nicht weiter,
Slim braucht bestimmt passende Konfiguration für X. Das macht man heute zB in einer:
Code:
cat /usr/local/etc/X11/xorg.conf.d/keyboard.conf
Section "InputClass"
    Identifier    "KeyboardDefaults"
#    Driver        "keyboard"
    MatchIsKeyboard    "on"
        Option          "XkbModel" "pc105"
    Option        "XkbLayout" "de"
    Option        "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
Und dabei ist wichtig, dass man keinen Driver mehr setzt und dass die XkbOptions von oben ein Killen von X erlauben (also auch von einem normalen User und zwar immer oder solange X läuft.