• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Mate Desktop

Themenstarter #1
:confused: brauche mal dringend eure Hilfe. Mußte FreeBSD 12 an akta legen, weil ich es nicht im UEFI installiert bekomme! Habe mir Dragonfly 5.4 geladen und die Installation hat auch gleich beim ersten mal im UEFI-Modus funktioniert. So jetzt habe ich den Mate Desktop installiert, das läuft auch alles bis zum SlimManager durch. Dann möchte ich mich als root anmelden und dann bekomme ich folgende
Fehlermeldung :

failed to execute login command

Nach der Fehlerausgabe startet die mate-Session, sprich der login von vorne.
Super wenn ihr mir schreiben könntet wo mein Fehler ist damit ich Mate gestartet bekomme!

Abfolge als root

pkg install nano
pkg install xorg
pkg install mate-desktop
pkg install slim

nano /etc/fstab
proc /proc /procfs rw 0 0

nano /etc/rc.conf
dbus_enable="YES"
hald_enable="YES"
slim_"enable=YES"

nano. xinitrc
exec mate-session

Grüße aus Mannheim
Enrico :D
 

gadean

Well-Known Member
#2
Also nachdem was ich im Netz gefunden habe, ist der ".xinitrc" Kram unnötig oder du musst(?) in der "slim.conf" den Wert "sessiondir" auskommentieren.

Code:
+# Directory of session files.
+# They should be xdg-style .desktop files.
+# The "Name" entry in the session file would be used as session name.
+# The "Exec" entry would replace %session in login_cmd.
+sessiondir             %%LOCALBASE%%/share/xsessions
Edit: Lass dich nicht von "%%LOCALBASE%%" irritieren, hab den Ausschnitt aus dem Patch im Port kopiert.
 
Zuletzt bearbeitet:

holgerw

Well-Known Member
#3
Hallo,

ich vermute, ein Login als root in eine Mate-Sitzung ist durch das System nicht gestattet.

Ist zwar Deine Sache: Aber warum möchtest Du als root eine Mate-Sitzung starten?
 

ralli

BSD Fanboy
#4
Hab jetzt lange nichts mehr mit DragonFly gemacht. Wenn ich mich erinnere ist es erforderlich, das du als User in den Gruppen wheel,operator und video bist. Ich setze nach der Grundinstallation immer den Befehl ab:

Code:
pw usermod ralph -G wheel,operator,video
Du mußt natürlich ralph mit Deinem User ersetzen. Ob Du Dich dann in Slim als root anmelden kannst, habe ich nie ausprobiert. Aber um in der Konsole administrative Fähigkeiten zu erlangen mit su, ist es trotzdem nötig. Probier es aus. Probieren geht über studieren...;)
 

holgerw

Well-Known Member
#6
Hallo Ralph,

Ob Du Dich dann in Slim als root anmelden kannst, habe ich nie ausprobiert.
In diversen Linux-Distributionen und auch bei FreeBSD ist standardmäßig ein root-Login über Loginmanager wie sddm, slim, kdm in Xserver-Sitzungen abgestellt, und das schon seit zig Jahren.

Ich gehe davon aus, dass bei Deiner Empfehlung (Nutzer zur Gruppe wheel hinzufügen ) unter DragonFly - ähnlich wie unter FreeBSD - in einer Xserver-Sitzung es möglich gemacht wird, dass über ein Terminal per su + Root-Paßwort dann root-Rechte erlangt werden können. Und das sollte doch auch vollkommen ausreichen.

Wenn denn unbedingt GUI-Anwendungen als root gestartet werden sollen, gibt es doch mit gksu einen bequemen Weg, das ist vermutlich durch das Metapaket mate-desktop sogar schon mitinstalliert worden.
 
Themenstarter #7
Moin Moin
erst einmal vielen Dank dafür, dass viele um meine belange Gedanken machen.
Wie gesagt bin kein Bsd Profi. Hatte es nach einer Anleitung aus Youtube gemacht und auch so ausgeführt wie im Video, bei dem im Video ist es prompt gelaufen. Hatte es mit dem root und user probiert, nachdem beides nicht ging hatte ich mir die Arbeit sparen wollen und hatte es nur noch mit root probiert. Weiß garnicht wie oft ich Dragonfly schon installiert habe... Puh...
 
Themenstarter #8
Also nachdem was ich im Netz gefunden habe, ist der ".xinitrc" Kram unnötig oder du musst(?) in der "slim.conf" den Wert "sessiondir" auskommentieren.

Code:
+# Directory of session files.
+# They should be xdg-style .desktop files.
+# The "Name" entry in the session file would be used as session name.
+# The "Exec" entry would replace %session in login_cmd.
+sessiondir             %%LOCALBASE%%/share/xsessions
Edit: Lass dich nicht von "%%LOCALBASE%%" irritieren, hab den Ausschnitt aus dem Patch im Port kopiert.
Moin Danke für die Antwort, wo liegt die slim.conf versteckt?
 
Themenstarter #9
Hab jetzt lange nichts mehr mit DragonFly gemacht. Wenn ich mich erinnere ist es erforderlich, das du als User in den Gruppen wheel,operator und video bist. Ich setze nach der Grundinstallation immer den Befehl ab:

Code:
pw usermod ralph -G wheel,operator,video
Du mußt natürlich ralph mit Deinem User ersetzen. Ob Du Dich dann in Slim als root anmelden kannst, habe ich nie ausprobiert. Aber um in der Konsole administrative Fähigkeiten zu erlangen mit su, ist es trotzdem nötig. Probier es aus. Probieren geht über studieren...;)
Moin... hat leider nichts gebracht
 
#10
Startet der Mate Desktop denn ohne slim?

Um den Fehler einzugrenzen, einfach
Code:
# slim_"enable=YES"
auskommentieren und schauen, ob es ohne slim funktioniert oder nicht.
 

Rakor

Administrator
Mitarbeiter
#13
Moin Moin
erst einmal vielen Dank dafür, dass viele um meine belange Gedanken machen.
Wie gesagt bin kein Bsd Profi. Hatte es nach einer Anleitung aus Youtube gemacht und auch so ausgeführt wie im Video, bei dem im Video ist es prompt gelaufen. Hatte es mit dem root und user probiert, nachdem beides nicht ging hatte ich mir die Arbeit sparen wollen und hatte es nur noch mit root probiert. Weiß garnicht wie oft ich Dragonfly schon installiert habe... Puh...
Nur so als Hinweis: Ich habe bisher wenig bis keine Installationsanleitung auf Youtube gesehen die sonderlich viel taugt. Das sind meist sehr knapp gehaltene Aufnahmen ohne große Beschreibung was da gerade getan wird und warum. Auch habe ich das Gefühl, dass die Urheber da oft selbst nicht sonderlich tiefe Kenntnis haben. Mir kommt es manchmal so vor, dass die so froh sind, dass sie endlich eine lauffähige Installation hinbekommen haben, dass sie das unbedingt filmen müssen und der Welt zeigen.
Das mag nun überzogen sein und es mag Ausnahmen geben, aber ich möchte nur etwas Vorsicht empfehlen. (Wieso z.B. will sich der Urheber per root in Mate anmelden?!)
 

pit234a

Well-Known Member
#14
Wenn denn unbedingt GUI-Anwendungen als root gestartet werden sollen, gibt es doch mit gksu einen bequemen Weg,
das kenne ich nicht.
Was ich mache, ist ein Link aus roots Heimatverzeichnis auf die (eine) .Xauthority des users, als der ich grafisch arbeite. Bei mir ist das inzwischen einfach, weil ich nur noch einen User habe. Das sieht also so aus:
Code:
pit@Celsius ~:- > ll /root | grep auth
lrwxr-xr-x  1 root  wheel     25  3 Dez. 23:34 .Xauthority -> /usr/home/pit/.Xauthority
Damit kann ich einfach Anwendungen aus einem Terminal als root starten, etwa
Code:
# leafpad &
und dann in diesem Beispiel als root Dateien mit dem grafischen Texteditor leafpad bearbeiten.
 
Themenstarter #15
Hallo,

im Handbuch zu DragonFlyBSD steht, dass man das Metapaket mate installieren soll, und nicht mate-desktop:
https://www.dragonflybsd.org/docs/how_to_get_to_the_desktop/#index13h3

Vielleicht fehlen Dir Pakete.
Hi...
Das wollte ich übrigens auch schon installieren aber pkg install mate funktioniert bei mir leider nicht! Da kenn ich mich leider nicht so aus. Könntest du mir sagen wie ich das anstelle bei mir funktioniert nur pkg install mate-desktop....
 

holgerw

Well-Known Member
#17
Hi...
Das wollte ich übrigens auch schon installieren aber pkg install mate funktioniert bei mir leider nicht! Da kenn ich mich leider nicht so aus. Könntest du mir sagen wie ich das anstelle bei mir funktioniert nur pkg install mate-desktop....
Hmm, es kann auch sein, dass die Info im DFBSD veraltet ist und es tatsächlich mittlerweile nur das Metapaket "mate-desktop" gibt.

Ich habe hier zur Zeit kein BSD zur Hand, nur ein Win7. Also, bei den Dports von DFBSD gibt es das Metapaket "mate".

Vielleicht probierst Du mal:
Code:
pkg update -f && pkg install x11/mate
 
Themenstarter #18
Hmm, es kann auch sein, dass die Info im DFBSD veraltet ist und es tatsächlich mittlerweile nur das Metapaket "mate-desktop" gibt.

Ich habe hier zur Zeit kein BSD zur Hand, nur ein Win7. Also, bei den Dports von DFBSD gibt es das Metapaket "mate".

Vielleicht probierst Du mal:
Code:
pkg update -f && pkg install x11/mate
Probiere ich.... schön das ihr euch so ins Zeug legt, meine Frau fragt mich auch schon kaputt sei! Ich sagte ihr das ist moderne Textverarbeitung. Jetzt muß ich erstmal den Desktop zum Laufen bringen. Dann kommt noch eine Frage zum WLAN was bei FreeBSD gleich gefunden wird. Oh man hier wirklich viel händische Arbeit angesagt... :-)
 
Themenstarter #20
Probiere ich.... schön das ihr euch so ins Zeug legt, meine Frau fragt mich auch schon kaputt sei! Ich sagte ihr das ist moderne Textverarbeitung. Jetzt muß ich erstmal den Desktop zum Laufen bringen. Dann kommt noch eine Frage zum WLAN was bei FreeBSD gleich gefunden wird. Oh man hier wirklich viel händische Arbeit angesagt... :-)
I'm Repository wurde kein Paket kein Paket gefunden. ;-(
 

holgerw

Well-Known Member
#22
Habe mir mal über distrowatch die Pakete des aktuellen DF angeschaut, da gibt es kein Metapaket mate.

Dann lass das erst einmal mit weiteren Paketen und versuche, über startx Mate manuell zu starten.