Mausrad funktioniert nach portupgrade nicht mehr

moonlook

Meteorist
Hallo,

nachdem ich nun eine Weile gesucht habe und keine Loesung finde bzw. die genaue Ursache, wende ich mich an Euch hilfesuchend.
Ich habe mein System von 5.4 auf 6.0 gehoben und daraufhin ein portupgrade gefahren. Dies lief auch relativ problemlos durch (bis auf xchat, was jetzt ohne Fehlermeldung bei Aufruf 100% CPU verbraet und sonst nichts, aber das ist mir nicht so wichtig und ein anderes Thema).
Ich habe keinerlei Veraenderung an der xorg.conf vorgenommen, die derzeitig installierte Version von xorg ist xorg-6.8.2. Die Maus an sich funktioniert, aber das Mausrad nicht, was an einigen Stellen waehrend der Arbeit gewaltig nervt.
Der Eintrag in der xorg.conf ist folgender:

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/sysmouse"
Option "ZAxismapping" "4 5"
Option "Buttons" "5"
EndSection

Mit diesem ^^ hat es vorher problemlos funktioniert. Auch der Versuch mit anderen Protokollen erbrachte kein Ergebnis. In der /var/log/Xorg.0.log findet sich auch kein Hinweis auf eine Fehlkonfiguration der Maus:

(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: SetupAuto: hw.iftype is 4, hw.model is 0
(II) Mouse0: SetupAuto: protocol is SysMouse
(II) 3rd Button detected: disabling emulate3Button

Das Mausrad an funktioniert hardwaretechnisch (getestet an einer anderen Maschine), so wtf???
Hat jemand Anregungen oder Hinweise, die mich weiterbringen koennten. Weiss jemand etwas ueber grundsaetzliche Aenderungen an den Konfigurationsdateien oder aehnlichem, die das Problem versuchen koennten?

Danke schon einmal fuer Eure Muehe.
Gruess,
moonlook
 

cryptosteve

Ex-Steve`
Was sagt
Code:
ps ax | grep -i mouse
Ich habe kürzlich gehört, dass der Parameter "-V" das Funktionieren des Mausrades geblockt hat.
 

moonlook

Meteorist
Steve` schrieb:
Was sagt
Code:
ps ax | grep -i mouse
Ich habe kürzlich gehört, dass der Parameter "-V" das Funktionieren des Mausrades geblockt hat.

95061 ?? Ss 1:18,68 /usr/sbin/moused -z 4 -p /dev/ums0 -t auto -I /var/run/moused.ums0.pid

Auch das Aendern auf ZAxisMapping brachte keinen Erfolg. Any Ideas? Ich beschaeftige mich derweil wohl mal mit dem moused eingehender.

Gruesse,
moonlook

Nachtrag: Der Parameter -V fuer virtuelles Scrolling hilft ein wenig, ist aber nicht die Loesung. Mittlere Maustaste druecken und dann halt hoch- und runterschieben, hmm.
 
Zuletzt bearbeitet:

Fusselbär

Makefile Voyeur
Hallo,

ich habe ja noch FreeBSD 5.4,
aber in meiner "InputDevice" Section
ist das Mäuse Protkoll auf "SysMouse" eingestellt.

Auszug aus meiner: /etc/X11/xorg.conf
Code:
Section "InputDevice"
	Identifier "Keyboard0"
	Driver "kbd"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "de"
 Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "SysMouse"
	Option	    "Device" "/dev/sysmouse"
	Option	    "Buttons" "5"
	Option	    "ZAxisMapping" "4 5"
EndSection

Wäre ja vielleicht einfach mal einen Versuch wert...
(Falls Du das nicht schon durch hast)
Läuft der moused Daemon denn sonst ohne X-Server einwandfrei?

Viel Erfolg! :)


Gruß, Fusselbär
 
Oben