• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Mehrere IPv6-Adressen in der rc.conf

worker

Active Member
Themenstarter #1
Guten Aben zusammen,

ich suche und probiere mir den Wolf schon den ganzen Tag - ohne Erfolg.
Drum habe ich mich doch entschlossen einen Thread aufzumachen...

Habe eine Testkiste (zuhause hinter einem O2-Router) mit aktuellem FreeBSD 12 drauf.
Nun versuche ich mehrere IPv6 auf ein Netzwerk-device zu klatschen.

Meine 'rc.conf' sieht derzeit wie folgt aus:
Code:
clear_tmp_enable="YES"
keymap="de.kbd"
zfs_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"

# Network-config:
hostname="BSD-TestServer"
#ipv6_enable="YES"
ifconfig_rl0="DHCP"
ifconfig_rl0_ipv6="inet6 accept_rtadv"
rtsold_enable="YES"
ifconfig_rl0_ipv6_alias0="inet6 2a01:c22:xxxx:xxxx:xxxx:xxxx:fe58:1890 prefixlen 64"
ifconfig_rl0_ipv6_alias1="inet6 2a01:c22:xxxx:xxxx:xxxx:xxxx:fe58:1891 prefixlen 64"
ifconfig_rl0_ipv6_alias2="inet6 2a01:c22:xxxx:xxxx:xxxx:xxxx:fe58:1892 prefixlen 64"
ifconfig_rl0_ipv6_alias3="inet6 2a01:c22:xxxx:xxxx:xxxx:xxxx:fe58:1893 prefixlen 64"
ifconfig_rl0_ipv6_alias4="inet6 2a01:c22:xxxx:xxxx:xxxx:xxxx:fe58:1894 prefixlen 64"
ipv6_defaultrouter="2a01:c22:xxxx:xxxx:xxxx:xxxx:fec8:75b9%rl0"
#

sshd_enable="YES"
ntpdate_enable="YES"
ntpd_enable="YES"
apache24_enable="YES"
Seltsamer weise geht nach einem 'service netif restart' garnichts mehr (da ich per SSH auf der Kiste bin). Also Monitor auf die Kiste umgeschaltet und da meckert FreeBSD, dass der '/etc/rc.d/dhclient' wohl nicht läuft, wenn ich 'netif' neu starte und sowohl IPv6, wie auch IPv4 sind auf dem device nicht [mehr] gesetzt.
Okay, also Kiste rebootet - nun geht wenigstens IPv4 (per DHCP) und ne IPv6 (SLAAC) bekomme ich auch. Doch nur diese eine IPv6. Die in der rc.conf angegebenen IPv6 werden schlicht nicht an das device gebunden. Egal welche Schreibweise ich versuche.

'ifconfig':
Code:
rl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=2008<VLAN_MTU,WOL_MAGIC>
        ether 00:xx:xx:xx:xx:8f
        inet6 fe80::2e0:4cff:fe58:188f%rl0 prefixlen 64 scopeid 0x1
        inet6 2a01:c22:xxxx:xxxx:xxxx:xxxx:fe58:188f prefixlen 64 autoconf
        inet 192.168.1.195 netmask 0xffffff00 broadcast 192.168.1.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
        nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
Stehe ich hier dermassen auf dem Schlauch und habe iwo einen Fehler in der Config?

Grüssle
worker
 

roema

Well-Known Member
#2
Code:
ifconfig_rl0_ipv6_alias0="inet6 2a01:c22:xxxx:xxxx:xxxx:xxxx:fe58:1890 prefixlen 64"
ifconfig_rl0_ipv6_alias1="inet6 2a01:c22:xxxx:xxxx:xxxx:xxxx:fe58:1891 prefixlen 64"
ifconfig_rl0_ipv6_alias2="inet6 2a01:c22:xxxx:xxxx:xxxx:xxxx:fe58:1892 prefixlen 64"
ifconfig_rl0_ipv6_alias3="inet6 2a01:c22:xxxx:xxxx:xxxx:xxxx:fe58:1893 prefixlen 64"
ifconfig_rl0_ipv6_alias4="inet6 2a01:c22:xxxx:xxxx:xxxx:xxxx:fe58:1894 prefixlen 64"
ipv6_defaultrouter="2a01:c22:xxxx:xxxx:xxxx:xxxx:fec8:75b9%rl0"
Lass bei den Alias das "ipv6" weg, also so

Code:
ifconfig_em1_ipv6="inet6 accept_rtadv"
ifconfig_em1_alias0="inet6 fd7e:d071:2503::1 prefixlen 64"
ifconfig_em1_alias1="inet6 fd7e:d071:2503::2 prefixlen 64"
ifconfig_em1_alias2="inet6 fd7e:d071:2503::3 prefixlen 64"
ifconfig_em1_alias3="inet6 fd7e:d071:2503::4 prefixlen 64"
ifconfig_em1_alias4="inet6 fd7e:d071:2503::5 prefixlen 64"
Und kontrolliere bitte deine IPV6 Adresse.

Bei mir funktioniert es so.
 

worker

Active Member
Themenstarter #3
Ach du dicke Milchkuh! :-O
Also manchmal sieht man den Wald vor lauter Bäume wirklich nicht... :D

Ich danke dir herzlichst!

Und da drehe ich noch deswegen syslogd extra auf, aber nöö, keine Fehlermeldung, kein Meckern, Nix :-/ ...

Okay, wieder gelernt, dass wenn man nicht mehr weiter kommt, mal ruhig ne längere Pause einlegen ;)
 
#4
Hat sich immer noch keiner erbarmt und das hostname.if(5) Konzept von OpenBSD portiert?

Ich war mal kuz davor, hab dann aber FreeBSD bei mir abgeschafft ;-)
 

TCM

Well-Known Member
#5
Die Seuche des Zu-Tode-Abstrahierens. Anstatt einfach ein Shell-Skript reinzuziehen, wird alles zu Tode parametrisiert und ein sinnloser deklarativer Ansatz verfolgt. Ich glaube, mit solchem sinnlosen Debugging und noch dazu das Reinlesen, wie der Krempel funktioniert, wird mehr Zeit verschwendet als wenn man einfach sagen würde, "man ifconfig ist alles, was du brauchst".