MS Natural Ergonomic Keyboard 4000 kurzzeitig "tot"

Wasp

Insektenspray-Gegner
Hallo,

mir ist aufgefallen, daß der Bootloader von FreeBSD 6.2 stable keine Eingaben oben genannter Tastatur entgegennimmt. Ist das bei USB-Tastaturen so normal? Davor (im BIOS) und danach (auf der Konsole oder in X) funktioniert sie fehlerfrei (ohne Sondertasten).

Fragend in die Runde schaut
Wasp
 

soul_rebel

ist immer auf der flucht
Hm, weiß nicht.

Wozu genau kommen die Tastaturen denn mit USB? Bringt das irgendwelche Vorteile bei Tastaturen?
 

xbit

Well-Known Member
Hab zwar nur FreeBSD 7.0, aber ich habe beim Bootloader keine Probleme mit einer Tastatur, die ueber USB angeschlossen ist.

Die Tastatur hat eigentlich nur einen DIN Anschluss, der ueber einen PS/2 Adapter an einem USB Hub angeschlossen ist.

Ich nutze den GENERIC Kernel.

Hast Du vielleicht einen eigenen Kernel, der kein USB laedt?
 

mousaka

getting older
Bei mir geht's einwandfrei mittels USB-Keyboard (kein MS) und -Maus via eines KVM-Switches. Seit 6.0 nutze ich dieses Setup und hatte damit nie Probleme (auch im loader nicht) und kann im laufenden Betrieb umschalten, egal ob Konsole oder X.

Kannst du im BIOS etwas zu USB-Keyboards einstellen? Vermute das der Fehler ehr dort liegt als beim OS. Allerdings ist es merkwürdig das dein Keyboard im BIOS funktioniert.

mousaka
 

CommanderZed

OpenBSD User
Teammitglied
Ich hab die Erfahrun gemacht das USB Tastaturen nicht immer Korrekt unter Systemen funktionieren die versuchen über BIOS mit der Tastatur zu kommunizieren.
Das liegt meist in der Kombination aus verwendeter Tastatur, USB-Controller und verwendeten Bios, die Effekte können zuweilen etwas merkwürdig sein (Bios geht, Boot-Loader (auch bei Windows) nicht ist da durchaus drinn.
Das muss nicht heissen, das das in deinem fall zutrifft, aber es könnte durchaus sein.
Probier mal DOS o.ä. zu booten und schau ob da die Tastatur geht.
 

Wasp

Insektenspray-Gegner
xbit schrieb:
Hast Du vielleicht einen eigenen Kernel, der kein USB laedt?
Würde die Tastatur denn sonst auf der Konsole bzw. X funktioneren? ;)

mousaka schrieb:
Kannst du im BIOS etwas zu USB-Keyboards einstellen? Vermute das der Fehler ehr dort liegt als beim OS. Allerdings ist es merkwürdig das dein Keyboard im BIOS funktioniert.
Ja kann ich, und die Unterstützung für USB-Maus als auch USB-Tastatur sind beide aktiviert.

CommanderZed schrieb:
Probier mal DOS o.ä. zu booten und schau ob da die Tastatur geht.
Es ist ja nun nicht so, daß die Tastatur nicht funktioneren würde in BSD, es ist einzigst der bootloader, der sich weigert.

Windows 2000sp4 (gleicher Rechner): Tastatur geht garnicht(!). Lustigerweise wird sie namendlich richtig erkannt und ich solle einen Treiber für die Tastatur installieren. Doch nach installation der "Intelli-Software" zeigt die Tastatur auch keine reaktion. Praktischerweise funktioniert seitdem allerdings meine Maus endlich wieder mit allen Sondertasten. :ugly:

Windows Vista (notebook): reinstecken -- warten ... mehr warten -- fertig -- funzt (ohne Sondertasten)!

Windows XPsp2 (Dell): reinstecken -- funzt (ohne Sondertasten).

sich schon mal für die -- und die kommenden ;) -- Beiträge bedangt
Wasp
 
Zuletzt bearbeitet:

xbit

Well-Known Member
Würde die Tastatur denn sonst auf der Konsole bzw. X funktioneren? ;)


Ja kann ich, und die Unterstützung für USB-Maus als auch USB-Tastatur sind beide aktiviert.

Ist mehr ein Schuss ins Blaue, aber hast Du USB fest in den Kernel eingebunden (also einen eigenen Kernel gebaut oder nutzt Du den GENERIC Kernel)? Einige Module werden ja auch vor dem Aktivieren des Bootloaders geladen. Vielleicht steht zu dem Zeitpunkt noch kein USB zur Verfuegung.

Mir faellt dann eigentlich nur noch BIOS Einstellungen ein. Ich meine, ich kann dort sowas wie HID (Human Input Device) Support oder so aehnlich fuer USB aktivieren.
 

crotchmaster

happy BSD user
Ist mehr ein Schuss ins Blaue, aber hast Du USB fest in den Kernel eingebunden (also einen eigenen Kernel gebaut oder nutzt Du den GENERIC Kernel)? Einige Module werden ja auch vor dem Aktivieren des Bootloaders geladen. Vielleicht steht zu dem Zeitpunkt noch kein USB zur Verfuegung.

Mir faellt dann eigentlich nur noch BIOS Einstellungen ein. Ich meine, ich kann dort sowas wie HID (Human Input Device) Support oder so aehnlich fuer USB aktivieren.

Meinst Du vielleicht den 'USB Legacy Support'? Der hat mir auch bei uralt Boards geholfen.

Gruß c.
 

Wasp

Insektenspray-Gegner
xbit schrieb:
hast Du USB fest in den Kernel eingebunden (also einen eigenen Kernel gebaut oder nutzt Du den GENERIC Kernel)?
Ja ist in meinem eigenen Kernel mit uhci, ohc, ehci und ukbd drin.

crotchmaster schrieb:
Meinst Du vielleicht den 'USB Legacy Support'? Der hat mir auch bei uralt Boards geholfen.
Sollte wie gesagt auch alles an sein. Aber ich schau beim nächsten Neustart sicherheitshalber noch mal nach -- sollte es nicht drin sein, gebe ich noch mal bescheid.

Bin ansonsten für weitere Ratschläge dankbar, an irgendwas muß es ja liegen.
 

Daemotron

Well-Known Member
Das hat nichts mit dem Kernel zu tun - der wird ja vom Bootloader erst geladen. Ich kenne das Phänomen und kann es bestätigen. Die Tastatur funktioniert im Bios, im MS-Bootmanager und in Grub, aber nicht im FreeBSD-Loader (FBSD-7.0). War auch bei 6.2 schon so. Das Problem besteht insbesondere bei neueren USB-Tastaturen oder "Desktops" (Tastatur-/Maus-Combo) mit vielen Zusatzfunktionen.
 

crotchmaster

happy BSD user
Das Problem besteht insbesondere bei neueren USB-Tastaturen oder "Desktops" (Tastatur-/Maus-Combo) mit vielen Zusatzfunktionen.

Ich hatte so einen Desktop 'Cherry Barracuda', bzw. nur die Tastatur davon funktionierend an einem ASUS P2B-DS. Das Board ist nun wirklich uralt und dort klappte es nach aktivieren des USB Legacy Supports. Habe das Board jetzt allerdings nicht mehr, am neuen funktioniert die Tastatur aber auch.

Gruß c.
 

CommanderZed

OpenBSD User
Teammitglied
Also, ich kanns nur wiederholen: Dieses ganze USB-Zeugs ist alles nicht immer so super, und vermutlich hast du einfach den von mir oben geschilderten Fall - Boadloader, Bios, USB-Controller und Tastatur wollen in dieser Kombination einfach nicht zusammen.
Ich hatte derartige Probleme schon öfters, mit den verschiedensten Betriebsystemen die über die Standard-Bios-Routinen auf die Tastatur zugreifen wollen (DOS, Windows-Booloader, Windows-Installationsroutine, Selbstbootende Diagnoseprogramme e.t.c.) - da kann man idr nicht drann machen ausser zu versuchen einige der Komponenten zu tauschen.
Wirklich gut funkitoniert USB-Tastaturen nur unter Betriebsystemen die eigene Treiber verwenden, und nicht über diese Bios-Emulation - FreeBSD, OpenBSD, Linux, Windows zumindest ab 2000 e.t.c.
 

Wasp

Insektenspray-Gegner
Ogion schrieb:
Das hat nichts mit dem Kernel zu tun - der wird ja vom Bootloader erst geladen. Ich kenne das Phänomen und kann es bestätigen. Die Tastatur funktioniert im Bios, im MS-Bootmanager und in Grub, aber nicht im FreeBSD-Loader (FBSD-7.0). War auch bei 6.2 schon so. Das Problem besteht insbesondere bei neueren USB-Tastaturen oder "Desktops" (Tastatur-/Maus-Combo) mit vielen Zusatzfunktionen.
Also liegt das Problem eindeutig am FreeBSD Bootloader, der offensichtlich seiner Zeit etwas (sehr stark!) hinterher hinkt. Habe leider keine weitere USB-Tastatur zum Vergleich jedoch seh ich gerade, daß meine Tastatur (vermute mal wegen der Sondertasten, wie Du ja auch schon richtig erahnt hast) doppelt erkannt wird.
Code:
ukbd0: Microsoft Natural\M-. Ergonomic Keyboard 4000, rev 2.00/1.73, addr 4, iclass 3/1
uhid1: Microsoft Natural\M-. Ergonomic Keyboard 4000, rev 2.00/1.73, addr 4, iclass 3/1
 

mousaka

getting older
Naja, es gibt auch Hinweise, dass grub auch so seine Probleme damit haben kann.

Ich denke dies Aussage von CommanderZed triftt vermutlich zu. Was hast du dein für ein Mainboard? Sind alles die gleichen USB-Controller? Schon mal eine USB-Hub dazwischen gehängt?

mousaka
 

Daemotron

Well-Known Member
Also liegt das Problem eindeutig am FreeBSD Bootloader, der offensichtlich seiner Zeit etwas (sehr stark!) hinterher hinkt.
Oder an den Tastatur-Herstellern, die leider nicht immer und in allen Punkten der Spec für USB-Tastaturen folgen (Layout Self Announcement als Beispiel machen die meisten Consumer-Tastaturen nicht, obwohl im USB-Standard vorgeschrieben).
 

Wasp

Insektenspray-Gegner
CommanderZed schrieb:
(...) da kann man idr[R] nicht drann machen[,] ausser zu versuchen einige der Komponenten zu tauschen.


mousaka schrieb:
Ich denke dies Aussage von CommanderZed triftt vermutlich zu. Was hast du dein für ein Mainboard? Sind alles die gleichen USB-Controller? Schon mal eine USB-Hub dazwischen gehängt?

So ich habe die Tastatur jetzt noch mal an einem anderen Recher probiert (ja mit "BIOS:USB Keyboard Support=enable") und es liegt genau das gleiche Problem vor: Im BIOS gehts, in BSD gehts, nur im BSD Bootloader gehts nicht. Somit liegt es wohl aller Wahrscheinlichkeit nach nicht am USB-Controler. Schlecht aussehen läßt den BSD-Bootloader ebenso, daß ich auf diesem Rechner noch einen Disk-/Bootloader Plop habe, welcher mit der Tastatur auch zurande kommt. Nur der BSD-Bootloader rafft es nicht.

Nicht, daß ich jetzt groß Ahnung von der Programmierung eines Disk-/Bootloaders hätte, aber auf mich macht das mehr den Eindruck, daß der BSD-Boodloader eher etwas kaputt, als "richtig" macht. Denn wenn seit dem BIOS bis hin zu Plop -- der nun wirklich nur 512 Byte hat (im gegensatz zum BSD-Bootloader, der ja noch die BSD-Partition mit nutzen kann) die Tastatur funktional erkannt wird, dann dürfte der BSD-Bootloader garnichts mehr machen brauchen, außer die eine Ebene tiefer erkannte Tastatur nutzen.
 

Yamagi

Possessed With Psi Powers
Teammitglied
Es kann im Bootloader nicht gehen, da dieser in FreeBSD 7.0 gar nicht die Vorraussetzungen hat, problemlos mit USB umgehen zu können. Es funktioniert ab und an und mit Glück. aber garantiert ist es nicht. In FreeBSD 7.0-STABLE und auch 8.0-CURRENT sind boot0, boot, boot2, BTX und loader angepasst worden, wodurch sie mit USB deutlich besser klarkommen sollen. Zumindest bei USB-Platten funktioniert es gut und zuverlässig, wie es mit USB-Tastaturen ausschaut, weiß ich leider nicht.
 
Oben