• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Muß manchmal das Netzwerkkabel für DSL von einer auf die andere Netzwerkschnittstelle stecken

ralli

BSD Fanboy
Themenstarter #1
Ich habe hier ein Phänomen, was mir unerklärlich ist. Auf meinem Motherboard sind zwei Netzwerkschnittstellen verbaut:

Code:
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp2s0 state: down mac: 00:26:18:a7:58:4f
  Device-2: Realtek RTL-8110SC/8169SC Gigabit Ethernet driver: r8169
  IF: enp7s4 state: up speed: 100 Mbps duplex: full mac: 00:26:18:a7:67:fe
Innerhalb von 14 Tagen ist es nun das zweite Mal passiert, das ich das Netzwerkkabel von enp2s0 nach enp7s4 umstecken mußte. Oder auch umgekehrt. Weil es plötzlich keine Verbindung mehr gab. Was könnte das sein?
 

serie300

Well-Known Member
#3
Könnte im Prinzip auch der Router / Switch sein, der sich nach An / Abstöpseln neu synchronisiert.

Falls HW - aktuelle Hitze? Hatte mal ähnliche Probleme im Sommer bei einer Fritzbx bis ich die luftiger aufgestellt habe.
 

mr44er

Well-Known Member
#4
Falls du einen Router einsetzt, könnte der aktuell überhitzen.

Mal neu starten das Ding und vor einen Ventilator setzen, kann Wunder bewirken. :)

Oder dein Rechner 'pustet' nicht adäquat für die Jahreszeit. ;)
 

pit234a

Well-Known Member
#5
Muß manchmal das Netzwerkkabel für DSL von einer auf die andere Netzwerkschnittstelle stecken
...
Weil es plötzlich keine Verbindung mehr gab.
Das ist etwas undurchsichtig.
Ein DSL-Modem ist heute ja allermeist als ein Router ausgeführt. Demgemäß muss man unterscheiden, welches Netzwerk erreichbar ist und welches nicht.
Dazu gehört der Aufbau des/der Netzwerke und ich benutze nicht gerne den Begriff Topologie, weil im einfachsten Fall der Router direkt am PC hängt und es deshalb quasi gar kein Netzwerk auf dieser Seite (LAN) gibt.
Auf der anderen Seite gibt es natürlich immer das WAN (Internet), wenn denn der Router hier auch mit einer Adresse versorgt und vom Provider eingebunden ist. Das ist durchaus nicht immer der Fall und diese Adressen wechseln auch im Betrieb.
Auf der LAN-Seite gibt es selbst im allereinfachsten Fall, dass also der Router direkt am PC angeschlossen ist, nochmal mehrere Möglichkeiten, von denen mir spontan DHCP ja/nein in den Sinn kommt. Sehr oft stellen moderne Router auch weitere Dienste zur Verfügung, wie etwa einen DHCP-Server und sie fungieren nicht selten auch als DNS (das machen die nicht wirklich, aber man behandelt sie so, als ob und sie leiten dann die Anfragen zu einem DNS im WAN weiter). Das sind in einem Satz gleich zwei Möglichkeiten für ein Versagen. Wenn DHCP benutzt wird, bekommt der PC (= Client) vom Router (= Server) eine IP-Adresse und die Adresse eines DNS (meist die LAN-Adresse des Routers, aber je nach Konfiguration sind andere möglich). Klappt dies nicht, geht auch keine Verbindung und zwar, je-nachdem, was fehlt, weder ins LAN noch ins WAN.
Dies erkläre ich deshalb, weil es mir wahrscheinlich erscheint, dass du DHCP benutzt. Sonst müsstest du unterschiedliche (oder gar identische) Konfigurationen für die beiden Netzwerk-Karten manuell erstellt haben. Erhält eine Netzwerkkarte plötzlich eine Verbindung (Kabel gesteckt) und steht auf DHCP, wird sie nämlich versuchen (bzw das Betriebssystem), sich vom Server eine Adresse etc zu besorgen.
In FreeBSD kann dieser Prozess mittels dhclient(8) (plus passende Option) auch von der Konsole angestoßen werden, also eine Anfrage an den DHCP-Server veranlasst werden.

Aber ich möchte das nicht endlos vertiefen, zumal ich hier auch kein Experte bin. Ich wollte nur darauf hinweisen, dass man mit diesen wenigen Angaben schlecht was sagen kann, selbst für den einfachsten Fall einer direkten Verbindung von Router zu PC.
 

ralli

BSD Fanboy
Themenstarter #6
Und was passiert, wenn du das Kabel abziehst und in die selbe Buchse erneut reinsteckst?
Nichts. Natürlich habe ich das als erstes versucht.
Könnte im Prinzip auch der Router / Switch sein, der sich nach An / Abstöpseln neu synchronisiert.

Falls HW - aktuelle Hitze? Hatte mal ähnliche Probleme im Sommer bei einer Fritzbx bis ich die luftiger aufgestellt habe.
Schon möglich, ich bin kein Experte und verlasse mich daher auf Eure Kompetenz.

Falls du einen Router einsetzt, könnte der aktuell überhitzen.

Mal neu starten das Ding und vor einen Ventilator setzen, kann Wunder bewirken. :)
An die Hitze habe ich auch schon gedacht. Aber dann dürfte es ja auch nicht kurze Zeit später an der anderen Schnittstelle wieder funktionieren.

Oder dein Rechner 'pustet' nicht adäquat für die Jahreszeit. ;)
Hmm die Temperatursensoren haben aber nur so um die 38 Grad angezeigt.

Dies erkläre ich deshalb, weil es mir wahrscheinlich erscheint, dass du DHCP benutzt.
Danke, sehr interessant. Ja, ich benutze DHCP und habe eine FritzBox 7560. Wahrscheinlich werden wir das nicht wirklich abklären können, daher werde ich das weiter beobachten.

Danke Euch allen für die Anteilnahme und Unterstützung.

PS: Ich habe dann mal Debian oder Linux Mint installiert. Die bekamen dann aber auch keine DHCP Verbindung zustande und konnten daher nicht das Netz initialisieren. Erst nach ein paar Minuten und dem Umstecken des LAN Kabels funktionierte es wieder. Werde mal die Temperaturen schärfer beobachten. Scheint wohl doch ein Hitzeproblem zu sein.
 
Zuletzt bearbeitet:

pit234a

Well-Known Member
#7
Ja, ich benutze DHCP und habe eine FritzBox 7560. Wahrscheinlich werden wir das nicht wirklich abklären können
Aber näher heran kann man sich schon tasten.
Hast du nur einen Rechner im Netz und den direkt am Router? Kannst du einen zweiten Rechner (vorübergehend) anschließen, um mit dem mal genauer hinschauen zu können?

Selbst, wenn nur ein PC am Router direkt hängt, kannst du weiter hinsehen und erkennen, ob du eine gültige IP innerhalb deines LAN auf dem PC hast. Kannst du dann damit den Router pingen?
Was die resolv.conf?
Kannst du den DNS erreichen?
Und so weiter...

Natürlich. Die Konfiguration deines Routers solltest du kennen. Schau dir die doch mal an. Meist geht das über ein WebIf auf die LAN-IP des Gerätes.
 

medV2

Well-Known Member
#9
Bevor wir hier lustige Rätselraten spielen: Was sagt im Fehlerfall /var/log/messages und /var/log/dmesg.today ? Dazu vielleicht netstat -rn und arp -an einmal je im "guten" Zustand und einmal im Fehlerfall.
 

ralli

BSD Fanboy
Themenstarter #10
Hast Du evtl. zwei DHCP-Server im Netz haengen, die sich gegenseitig stoeren?
Hier ist noch ein Smart TV an die Fritzbox angeschlossen, ist das ein DHCP Server?

Code:
Philips-TV
LAN 4
192.168.178.20
Könnte das zu Konflikten führen?

Ich sehe, das ich mich mal näher mit Netzwerk, DHCP usw. beschäftigen muß, habe da wohl einen Nachholbedarf.
 

ralli

BSD Fanboy
Themenstarter #11
Bevor ich mich an die Einarbeitung mache, eine Verständnisfrage:

Erkennt ein Betriebssystem beim Booten automatisch, an welcher Schnittstelle ein DSL Kabel eingesteckt ist?
 

holgerw

Well-Known Member
#13
Zu dem SmartTV: Ich kenne es von netzwerkfähiger Multimedia-Periphärie bisher nur so, dass man ihr entweder eine statische Adresse verpast, oder sie als DHCP-Client konfigurieren kann.
Es würde mich etwas wundern, wenn Dein Fernseher auch als DHCP-Server fungieren kann.
 

SierraX

Well-Known Member
#14
Hier ist noch ein Smart TV an die Fritzbox angeschlossen, ist das ein DHCP Server?
Unwahrscheinlich. DHCP steht für Dynamic Host Configuration Protocol. Der Server dazu vergibt üblicherweise Ip Adressen, Subnetmask, default route und so weiter. Ein Smart TV ist zwar nicht unmöglich dass da so ein Server drin ist... aber ich halte es für recht unwahrscheinlich... Da schon eher ne smarte Steckdose halt irgend was ohne Display aber mit Netzwerk Kabel, ein HUE Hub z.B..

Code:
Philips-TV
LAN 4
192.168.178.20
Könnte das zu Konflikten führen?
Die Adresse (mit der 20 am ende) sieht so manuell vergeben aus. Wenn sich eine manuell vergebene Adresse in dem Bereich der durch die Fritzbox verwalteten Dynamischen Adressen befindet, kann das zu Konflikten führen.
@midnight spielt aber eher darauf an, das sich 2 DHCP Server (z.B. 2 Fritzboxen die dem gleichen Subnet angehören) zu einem Problem führen können. Wenn sich ein Rechner mit dem Netzwerk verbindet hat er üblicherweise noch keine IP Sdresse und ruft nur ins Netz "bin da, kann mir jemand ne Adresse zuweisen?" Antwortet keiner... generiert er zufällig nach nem Timeout ne eigene glaube 167. irgendwas. Antwortet einer Schreibt er die erhaltenen Informationen in seine Netzwerk Konfiguration. Erhält er 2 oder mehr nimmt er afaik das erste was ihn an Antwort erreicht. Der DHCP Server Seinerseits schreibt die IP adresse die er verschickt hat und die MAC (Media Access Control) der Netzwerkkarte von der die Frage kam in eine lease Tabelle. Sind es mehrere DHCP server könnte für eine MAC verschiedene Adressen IP in lease Tabellen existieren. Was dann zu Konflikten mit der Datenweiterleitung führt.

Ich sehe, das ich mich mal näher mit Netzwerk, DHCP usw. beschäftigen muß, habe da wohl einen Nachholbedarf.
Ist nie verkehrt. Wenn du eh ein FreeBSD benutzt kannst du dir ein Virtuelles Netzwerk mit mehreren VirtualBox Hosts zusammen bauen. Da entstehen dann auch keine Konflikte mit dem physischen Netz.
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#15
Die Log-Ausgabe oben kommt ja von einem Linux. Tritt das Problem nun nur unter Linux auf, oder auch unter FreeBSD? Wenn nur unter Linux, würde ich in deiner Stelle mal mit journalctl schauen, ob es dort sinnvolle Hinweise gibt. Wenn unter beiden Systemen kann man einen Softwarefehler wohl ausschließen und müsste die Hardware schrittweise durchgehen.
 

SierraX

Well-Known Member
#16
Bevor ich mich an die Einarbeitung mache, eine Verständnisfrage:

Erkennt ein Betriebssystem beim Booten automatisch, an welcher Schnittstelle ein DSL Kabel eingesteckt ist?
Er erkennt nur beim booten automatisch ob da ein Kabel dran steckt noch nicht wofür dieses Kabel auf den OSI-ISO Layern oberhalb Layer 4 vorgesehen sind. Du meintest auch dass du eine Fritzbox verwendest, also das DSL Kabel garnicht direkt an den Rechner ansteckst. Das DSL Kabel ist nur das was von der Fritzbox in die Wand führt. Der Rest ist LAN.
 

ralli

BSD Fanboy
Themenstarter #19
Die Log-Ausgabe oben kommt ja von einem Linux. Tritt das Problem nun nur unter Linux auf, oder auch unter FreeBSD? Wenn nur unter Linux, würde ich in deiner Stelle mal mit journalctl schauen, ob es dort sinnvolle Hinweise gibt. Wenn unter beiden Systemen kann man einen Softwarefehler wohl ausschließen und müsste die Hardware schrittweise durchgehen.
@Yamagi merkt aber auch alles.;) Das Problem tritt nur unter Linux auf. Ich hatte ein Problem unter FreeBSD 12, das stürzte ein bis zwei Mal täglich ab (mit Sicherheit der GraKa Treiber für die Radeon). Jetzt aber habe ich FreeBSD 12 neu installiert und fange klein an (erst mit Windowmanager). Wenn ich jetzt den Rechner ausschalte, das Kabel an die andere Schnittstelle stecke, wird das automatisch erkannt? Mach ich mal, es kann ja nichts passieren.
 

ralli

BSD Fanboy
Themenstarter #20
Rechner ausgestellt, Kabel umgesteckt, bei Ping:

Code:
ping: cannot resolve www.google.de: Host name lookup failure
Geht also nicht. Mal ins BIOS geschaut, beide LAN Schnittstellen waren aktiviert, habe jetzt bei beiden auch mal das Bootrom aktiviert.
 

ralli

BSD Fanboy
Themenstarter #21
In meiner rc.conf steht:

Code:
ifconfig_re1="DHCP"
Wenn ich das ändere auf:

Code:
ifconfig_re0="DHCP"
sollte es gehen oder?

Im übrigen sagt ifconfig:

Code:
re0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
        ether 00:26:18:a7:58:4f
        media: Ethernet autoselect (10baseT/UTP <half-duplex>)
        status: no carrier
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
re1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
        ether 00:26:18:a7:67:fe
        inet 192.168.178.24 netmask 0xffffff00 broadcast 192.168.178.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=680003<RXCSUM,TXCSUM,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
        inet 127.0.0.1 netmask 0xff000000
        groups: lo
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
Hilft das weiter?
 

ralli

BSD Fanboy
Themenstarter #22
So, worum ging es mir eigentlich? Ich wollte ausschließen, das die Netzwerkschnittstelle defekt ist. Das habe ich jetzt ausgeschlossen, denn nachdem ich in der rc.conf eingetragen habe:
Code:
ifconfig_re0="DHCP"
das Kabel umgesteckt und den Rechner neu gebootet, funktioniert es.:)

Für FreeBSD überlege ich mir, doch eine Nvidia der Mittelklasse anzuschaffen, habe ja bald Geburtstag. Wenn es allerding jetz zu keinen neuen Abstürzen kommt, bleibt es bei der Radeon. Sorry ist OT, weil ja ein anderes Thema.
 

holgerw

Well-Known Member
#23
Hallo Ralph,

ich wollte darauf hinaus, dass Du Mal eine der beiden Lan-Schnittstellen abschaltet. Dann kann sich das System beim Booten nicht mit der Reihenfolge verhaspeln.
 

ralli

BSD Fanboy
Themenstarter #24
Hallo Holger,

ich wollte darauf hinaus, dass Du Mal eine der beiden Lan-Schnittstellen abschaltet. Dann kann sich das System beim Booten nicht mit der Reihenfolge verhaspeln.
Das dachte ich mir schon, eine gute Idee, das funktioniert bestimmt. Bei der Grundinstallation erkennt er ja beide Schnittstellen und ich kann die wählen, die benutzt werden soll. Bisher dachte ich immer, das das beim Booten vom OS automatisch bestimmt wird, das heißt es wird automatisch erkannt, an welcher Schnittstelle das LAN Kabel hängt. Aber es wird in die rc.conf geschrieben, was zuvor bei der Grundinstallation gewählt wurde.