• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

mutt + GMX IMAP + x Minuten = Mailbox closed

rMarkus

Chuck The Plant
Themenstarter #1
Hallo,

seit einiger Zeit hat mein IMAP-Provider GMX irgendwas ungestellt, so dass ich mit mutt (mutt-devel-lite-1.5.20_5) nach etwa 5 bis 10 Minuten immer herausfliege mit der folgenden Meldung:

Code:
Mailbox closed
Habt Ihr eine Idee, was man da machen könnte?


PS: Der Support von marcell d ́avis hat entgegen des Werbungsversprechen nur ein Mal mit einer Standardantwort bezüglich Einrichtung von GMX und Outlook geantwortet und schweigt nun.
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#3
Und die maximale Anzahl der IMAP-Verbindungen auf 5 begrenzen. Ich weiß nicht mehr wie die Option heißt, aber bei mit hatte es zu meiner mutt-Zeit wahre Wunder gewirkt.
 

rMarkus

Chuck The Plant
Themenstarter #4
Vielen Dank für die Antworten

@auge:
imap_timeout hilft mir leider nicht. Ich habe es sogar runter bis auf eine Minute gesetzt.


@jamagi:
Die passende Option konnte ich in der Doku nicht finden.
Es gibt nur eine übersichtliche Menge von imap-Optionen für die .muttrc .

Hast Du noch einen Tipp, der mir beim Auffinden der Option helfen könnte?
 

xbit

Well-Known Member
#5
Ich hab hier in der muttrc (man muttrc) gefunden:
imap_keepalive
Type: number
Default: 900

This variable specifies the maximum amount of time
in seconds that mutt will wait before polling open
IMAP connections, to prevent the server from clos-
ing them before mutt has finished with them. The
default is well within the RFC-specified minimum
amount of time (30 minutes) before a server is
allowed to do this, but in practice the RFC does
get violated every now and then. Reduce this number
if you find yourself getting disconnected from your
IMAP server due to inactivity.
Ansonsten habe ich noch das hier in derselben Man-Page gefunden:
imap_idle
Type: boolean
Default: no

When set, mutt will attempt to use the IMAP IDLE
extension to check for new mail in the current
mailbox. Some servers (dovecot was the inspiration
for this option) react badly to mutt's implementa-
tion. If your connection seems to freeze up period-
ically, try unsetting this.
Ich nutze auch mutt mit IMAP, aber nur mit cyrus-imapd als Server. GMX habe ich noch nicht ausprobiert.

Vielleicht helfen diese Optionen weiter.

Ergaenzung:
Mit ist noch aufgefallen, dass ich folgende Optionen in der muttrc habe:
Code:
set imap_passive="yes"
set mail_check=15
Damit wird alle 15 Minuten auf neue Mails ueber eine bestehende Verbindung geprueft.
 
Zuletzt bearbeitet:

rMarkus

Chuck The Plant
Themenstarter #6
Code:
set imap_passive="yes"
set mail_check=15
Das habe ich jetzt in verschiedenen Kombinationen ausprobiert:
imap_passive yes oder no erzeugt keinen Unterschied.
mail_check auf 15 Sekunden oder 60 Minuten auch nicht.

Wenn ich nach der Meldung "mailbox closed" eine Taste betaetige, dann kommt uebrigens folgende Statuszeile:
Code:
---Mutt: (no mailbox) [Msgs:0 Post:2 Inc:1]---(reverse-date/date)-------(all)---
No mailbox is open.

Weitere Vorschläge?
 
Zuletzt bearbeitet:

xbit

Well-Known Member
#7
So spontan faellt mir da nichts ein, ausser dass deren IMAP Server schlecht konfiguriert ist. ;)

Vermutlich wollen sie nicht, dass die Leute lange Connections aufhalten.

Mit den Optionen von oben kann ich zu Hause stundenlang mit meinem IMAP Server verbunden sein.
 

rMarkus

Chuck The Plant
Themenstarter #8
GMX ist auch unfreiwillig komisch und schreibt mir:
Code:
Der Sachverhalt, den Sie beschreiben, wurde bereits behoben. Es wurde kein
Fehler mehr festgestellt. Daher gehen wir davon aus, dass sich Ihre Anfrage
erledigt hat.
Der Fehler besteht natuerlich weiterhin und ich bin auch der Meinung, dass es an deren Servern liegt.
Ich hatte ausserdem keinen Anlass gegeben, dass die denken koennen, dass das Problem behoben ist. Ich hatte sogar noch mal per E-Mail nachgehakt und ständig durch das Testen weitere Abbrüche erzeugt.

Das ist ja wirklich ein furchtbarer Verein!
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#9
*Seufz* Ich bin mir nun gar nicht mehr sicher, dass ich seinerzeit die Anzahl Verbindungen nicht doch am Server eingestellt hatte. Aus meiner damaligen muttrc:
Code:
# Wie oft nach Mails schauen?
set mail_check=120
set timeout=30
set imap_check_subscribed

# IDLE Erweiterung nutzen
set imap_idle

# Nachrichten erst beim Beenden markieren
unset imap_peek

# Alle 30 Sekunden ein "keepalive" an den Server
set imap_keepalive=30
 

rMarkus

Chuck The Plant
Themenstarter #10
Vielen Dank Yamagi,

Deine Einstellungen habe ich gerade probiert und es half nichts.

Die Komiker vom GMX-Support behaupten übrigens weiterhin, dass keine Fehler bei denen liegen würden und dass ich nur die falschen Ports verwende für IMAP:
Code:
Bitte richten Sie in Ihrem E-Mailclient folgende Ports unter Verwendung von SSL

Postausgang: 465
Posteingang: 993
Der erste ist SMTP, das hilft mir "bestimmt" unheimlich bei meinem IMAP-Problem.

Den zweiten habe ich gerade ausprobiert und was sagt das Zertifikat dort:
Code:
Certificate host check failed: certificate owner does not match hostname imap.gmx.de
Und da fiel mir wieder ein, wieso ich vor einiger Zeit SSL bei GMX abschalten musste.
 

auge

Well-Known Member
#11
Hi rMarkus,

ich würde erst mal pobieren ob die kommunikation unverschlüsselt über Port 143 problemlos funktioniert. Sobald das klappt kannst du ja auf "imaps" und Port 993 umstellen.

das mit dem certificate, löst du mit einem account-hook:

account-hook imaps://dein_imapserver.irgendwas/ 'set ssl_verify_host = no'

vor deinen Eintägen für folder und spoolfile in .muttrc
 

rMarkus

Chuck The Plant
Themenstarter #12
Danke für den Hinweis Auge.
Das mit dem Hook scheint mir eine gute Loesung fuer das Zertifikat-Problem zu sein.

Ich hatte zuvor auch von IMAP auf IMAPS gewechselt, um SSL aus der Liste der möglichen Ursachen auszuschließen.
Leider bestand der GMX-Support darauf, das ich IMAPS verwende. Dort ist der Fehler aber genauso.

Eben habe ich übrigens von mutt-devel (Version 1.5.20_5) auf mutt (Version 1.4.2.3_4) ein Downgrade gemacht.

Hier tritt der Verbindungsabbruch bei IMAP weiterhin auf, jedoch ist die Fehlermeldung leicht anders:
Code:
CLOSE failed
Ich bin immer mehr der festen Meinung, dass die Schuld GMX traegt.
 

rMarkus

Chuck The Plant
Themenstarter #13
Die Ursache des Problems konnte ich jetzt endlich lokalisieren und umgehen:


Ursache:
Wie vermutet trägt GMX die Schuld an dem Problem, denn ich lasse meine teilweise manuell angelegten Mailboxen von Mutt nach neuer Mail überprüfen:
Code:
mailboxes +Inbox +test +Anderer_Account
Zuerst habe ich festgestellt, dass GMX vor nunmehr rund 4 Wochen diese Mailboxen umgenannt hat und z.B. eigenmächtig die Gross-/Kleinschreibung geändert hat. Ausserdem ist mindestens heute deren Server Case-Sensitiv.

Bei der primären Inbox und Outbox machte sich das ziemlich deutlich bemerkbar, da ich man sie dann gar nicht mit Mutt öffnen kann oder keine Mails versendet bekommt.

Bei den sekundären Mailboxen, die in dem o.g. Parameter zusätzlich aufgeführt sind, hat eine abweichende Konfiguration zuerst keine Auswirkungen. Im Hintergrund versucht Mutt aber weiter brav eine leicht unterschiedlich geschriebene Mailbox abzufragen, was der GMX-IMAP-Server in sehr unterschiedlichen Zeitspannen (30 Sekunden bis 60 Minuten) damit quittiert, dass er dich komplett aus dem Server wirft.

Schuldfrage
Der Fehler hatte damit eindeutig als Ursache eine Veränderung bei dem GMX-Server:
  1. Mutwillige Umbenennung meiner IMAP-Ordner
  2. Umstellung des IMAP-Servers auf Case-Sensitive
  3. Verzögerte Verbindungstrennung bei (mehrfach) falschem Ordnerzugriff

Zudem trennte deren IMAP-Server die Verbindung aus deren Inintiative einfach, was man mit Sicherheit auch irgendwo in deren Logs hätte sehen können.
Der Support braucht aber leider immer je knapp eine Woche für eine Antwort und diese sieht dann immer so aus, dass behauptet wird, dass kein Fehler auf deren Seite festzustellen sei und dass sie festgestellt hätten, dass alles problemlos funktioniert.
Da die Verbindungstrennungen von deren Seite sogar ausgelöst werden, ist das eine ganz klare Lüge.

Und entgegen der Werbung mit Marcell Davis sind sie nicht erst gegangen, als alles wieder lief, sondern haben das einfach nicht reagiert und das Problem dann als gelöst erklärt.
Ich bin übrigens seit über 10 Jahren zahlendes Mitglied bei GMX/1&1 und bin der Meinung, dass ich dann auch Anspruch auf anständigen Support habe - gerade dann, wenn die Schuld bei denen liegt.


Workaround
Da sich über das Web-Interface von GMX die genau vom IMAP benötigte Schreibweise nicht ermitteln lässt, habe ich:
  1. Alle Ordner in Kleinbuchstaben und nur mit Buchstaben ohne "_" oder "@" umgenannt über das GMX-Webinterface.
  2. Die Anzahl der Buchstaben in den Ordnernamen dort reduziert
  3. Langsam die Liste der Mailboxen in in der .muttrc einzeln gesteiert und dann je eine Stunde gewartet, ob die Verbindung wegen unterschiedlicher Schreibweise getrennt wird.
  4. Wenn die Verbindung getrennt wurde innerhalb der Stunde, dann habe ich die Schreibweise erneut verändert und vereinfacht.

Letztlich bin ich nach einigen Stunden Arbeit dann so weit, dass wieder alles funktioniert - bis zur nächsten mutwilligen Umbennenung meiner Ordner durch GMX/1&1.
 

xbit

Well-Known Member
#14
Das hoert sich ja echt gut an. :( Vor allem, da sie erstens rumfummeln, das nicht zugeben und dann nicht Mal Kunden supporten.

Erfreulich, dass du den Fehler lokalisieren konntest. Das spricht dafuer, seine Mails abzuholen. ;)

Danke fuer die Info.