• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Nach Upgrade 10.4 => 11.3 Release: PKG- und lib-Fehler (libelf.so.1)...

testit

Well-Known Member
Themenstarter #1
Leider kann ich mich all die Jahre nicht daran erinnern, dass ich es einmal geschafft hätte, mit den in der Dokumentation angegebenen Vorgehensweisen ein FreeBSD-System zu aktualisieren, ohne dass anschließend diverse Fehler auftauchen.

Typisch und - glaubt man Google - weit verbreitet scheinen bspw. die anschließenden Lib-Fehler zu sein, wie etwa folgender:
apachectl -t

httpd: Syntax error on line 180 of /usr/local/etc/apache24/httpd.conf: Cannot load libexec/apache24/libphp7.so into server: Shared object "libelf.so.1" not found, required by "libphp7.so"


Ähnliche Fehler tauchen hinsichtlich libssl etc. auf.

Als workaround fällt mir bis dato immer nur die Symlink-Methode ein, aber das kann auch nicht im Sinne des Erfinders sein.

==================

Ebenfalls nervend ein pkg-Problem:

pkg upgrade -f

Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking for upgrades (158 candidates): 34%
mod_php56 has no direct installation candidates, change it to mod_php72? [Y/n]: n
mod_php56 has no direct installation candidates, change it to mod_php73? [Y/n]: n
mod_php56 has no direct installation candidates, change it to mod_php74? [Y/n]: n
Checking for upgrades (158 candidates): 38%
llvm35 has no direct installation candidates, change it to llvm? [Y/n]: y
Checking for upgrades (158 candidates): 100%
Processing candidates (158 candidates): 100%

pkg: sqlite error while executing UPDATE packages SET name=?1 WHERE name=?2; in file pkg_jobs.c:1734: UNIQUE constraint failed: packages.name
Checking integrity...Assertion failed: (strcmp(uid, p->uid) != 0), function pkg_conflicts_check_local_path, file pkg_jobs_conflicts.c, line 386.
Child process pid=21045 terminated abnormally: Abort trap

Viele Grüße und Danke im voraus
testit
 

Kamikaze

Warrior of Sunlight
#2
Da fehlt das misc/compatX Paket das Library-Kompatibilität zu älteren Versionen liefert. Wenn man das Installiert läuft erst mal alles weiter.

Danach kann man mit pkg_libchk nachsehen was alles neu verlinkt werden muss um ohne das compat Paket auszukommen.