• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Nach Xorg upgrade: Tastaturlayout kaputt

Rosendoktor

Well-Known Member
Themenstarter #1
Hallo zusammen,

das heutige pkg Upgrade war so ziemlich ein halbes Desaster...

Zwar hatte ich hier im Forum schon mitbekommen dass das Upgrade auf xorg-server-1.20 Probleme mit älteren Nvidia Karten machen kann, mich diesbezüglich aber nach Recherche mit meiner GeForce 9300 GE auf der sicheren Seite wiedergefunden.

Das stattdessen Veracrypt kaputtgeht und die Tastatur völlig spinnt hatte ich nun nicht erwartet.

Gut, Veracrypt liess sich aus den Ports bauen und funktioniert wieder. Nach kurzer Recherche von der Umstellung im xserver von devd auf udev erfahren und durch auskommentieren des Teribers in der xorg.conf funktionierte auch die Tastatur wieder.

Na ja, so halb.

Jetzt sind halt sämtliche Cursor/Bildlauf/Entf/Pos1/Ende Tasten, die zwischen Tastatur und Nummernblock liegen, mit irgendwas anderem belegt. Die AltGr Taste tut auch nicht was sie soll.

Ich hab' keine Ahnung wie ich das jetzt wieder hinbiegen soll, zumal ich erst kürzlich schon (wie so oft nach Upgrades) irgendein Tastaturproblem beheben musste.

Hier mal der Schnipsel aus meiner bis vor kurzem funktionierenden xorg.conf:
Code:
Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputClass"
    # generated from default
    Identifier       "Keyboard Defaults"
    #Driver           "keyboard"    # <--- Damit geht's wenigstens so halb...
    MatchIsKeyboard  "on"
    Option           "Protocol" "standard"
    Option           "XkbRules" "base"
    Option           "XkbModel" "pc105"
    Option           "XkbLayout" "de"
EndSection
Leider stehe ich mit der xorg.conf seit jeher auf Kriegsfuss, ich kapier die einfach nicht...

Hat jemand ein ähnliches Problem gehabt und eine Lösung?

Danke für Hilfe,

Robert
 

Zirias

Well-Known Member
#2
Den Kern der Sache hast du ja schon gefunden, Driver "keyboard" wird nicht mehr funktionieren. Jetzt frage ich mich, was die "InputDevice" Section soll, die diesen driver immer noch hat? Hast du die mal komplett entfernt?
 

cabriofahrer

Well-Known Member
#3
Zwei Fragen hierzu, die mich auch interessieren würden:

1.) Da Du eine Nvidia-Karte hast, was für eine xorg.conf generiert Dir jetzt nvidia-xconfig? Gibt es da einen Unterschied zu früher?
2.) Lässt sich xorg-server nicht weiterhin aus den Ports mit devd-Option kompilieren und bringt das was?
 

Rosendoktor

Well-Known Member
Themenstarter #4
So, jetzt geht's wieder wie es soll. Die xorg.conf sieht jetzt so aus:

Code:
Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputClass"
    # generated from default
    Identifier       "Keyboard0"
    MatchIsKeyboard  "on"
    #Option           "Protocol" "standard"
    #Option           "XkbRules" "base"
    #Option           "XkbModel" "pc105"
    Option           "XkbLayout" "de"
EndSection
Die 'Section "InputDevice"' hat das neue nvidia-xconfig so generiert, inklusive der 'Driver "keyboard"'. Da liess sich aber kein Layout angeben, also hatte ich vor längerem mal nach Recherche die 'Section "InputClass"' eingefügt.

Die xorg.conf sieht jetzt identisch zur alten aus, nur dass die drei 'Option "..."' Zeilen auskommentiert sind. So funktioniert's.

@cabriofahrer:

Zu 1.: Die neu generierte xorg.conf sieht identisch aus zur alten, ausser meinen Änderungen wegen Tastatur natürlich.
Zu 2.: Keine Ahnung, will ich aber auch nicht machen.

Grüße,

Robert