• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Net::FTPSSL - Nicht in den Ports?

Benedikt

Well-Known Member
Themenstarter #1
Hi,
Brauche für ein Skript die Perl-Bibliothek Net::FTPSSL, kann sie aber nirgends finden. Weiß jemand wo ich diese herbekomme?

Danke.
 

hijacker

Active Member
#2
Moin.

Entweder von hier manuell übersetzen oder es nach CPAN-Manier versuchen als Perl-Bundle zu installieren..

Code:
perl -MCPAN -e 'install Net::FTPSSL'
 

Benedikt

Well-Known Member
Themenstarter #5
1) cd /usr/ports/lang/perl5.8/ && make install clean
2) perl -MCPAN -e 'install Net::FTPSSL'
automatische konfiguration
Folgende Module werden mitinstalliert:
IO::Socket::SSL
Net::SSLeay::Handle

Fehler:
t/10-complex....Bareword "EXP_CRYPT" not allowed while "strict subs" in use at t/10-complex.t line 37.
Execution of t/10-complex.t aborted due to compilation errors.
# Looks like your test died before it could output anything.
t/10-complex....dubious
Test returned status 255 (wstat 65280, 0xff00)
Failed Test Stat Wstat Total Fail Failed List of Failed
-------------------------------------------------------------------------------
t/10-complex.t 255 65280 ?? ?? % ??
Failed 1/2 test scripts, 50.00% okay. 0/1 subtests failed, 100.00% okay.
*** Error code 255

Stop in /root/.cpan/build/Net-FTPSSL-0.04.
/usr/bin/make test -- NOT OK
Running make install
make test had returned bad status, won't install without force

Hm, das Problem scheint an p5-IO-Socket-SSL zu liegen. Werde das mal aus den Ports installieren. Gebe dann bescheid.
 
Zuletzt bearbeitet: