NetBSD: Keyboard leicht modifizieren

berni51

OpenBSD user & NetBSD newbie
Jetzt les ich schon seit Stunden manpages, komm aber nicht weiter! Ich möchte (muss) unter NetBSD die Tastaturbelegung ganz leicht ändern. Grund ist die Raspberry-Tastatur, die unter NetBSD und auf der Konsole keine Raute (#) darstellt. Die entsprechende Taste, beschriftet mit # und ' stellt statt dessen die Zeichen | und / dar, die aber auch an ihrer gewohnten Taste funktionieren. Unter xorg klappt alles perfekt.

Das macht NetBSD übrigens an jedem Rechner, nicht nur am RaspBerry, also egal, wo ich Raspi-Tastatur anstöpsel.

Dummerweise möchte ich werder auf NetBSD noch auf die Raspi-Tastatur verzichten, deshalb die Frage: Weiss jemand, wie ich es anstelle, diese eine Taste anders zu belegen?
In grauer Vorzeit habe ich sowas auf einem SCO-Rechner schon mal gemacht, aber das ist 30 Jahre (mindestens) her, und ich hab keine Ahnung, wie ich das damals angestellt hab.
 

franco98

NetBSDler aus Leidenschaft
@berni

Schau dir mal diese Files an:

/usr/src/sys/dev/wscons/wsksymdef.h
/usr/src/sys/dev/pckbc/wskbdmap_mfii.c

Diese Zeile sollte in der Kernel config angepasst werden:

options PCKBD_LAYOUT=KB_encoding

Dann muss der Kernel neu gebaut werden.

Ich denke so erstellst du dir deine eigenes Layout für die Konsole.

Ich bin über einen alten Artikel aus dem Jahre 2006 darauf gestoßen. Schreibe mal ob es funktioniert!

VG aus LE
Franco
 

berni51

OpenBSD user & NetBSD newbie
Hi @zoidb3rg ,
so einfach ist es leider nicht. Das deutsche Layout hab ich schon geladen und und es passt auch (fast) alles. Nur diese eine Taste mit # und ' (direkt neben der ENTER Taste) spielt nicht mit. Entgegen der AUfschrift liefert sie die Zeichen / und |. Aber nur unter NetBSD, bei OpenBSD und FreeBSD ist alles korrekt.
 

berni51

OpenBSD user & NetBSD newbie
Kurze Rückmeldung: Ich konnte das Problem mit Hausmitteln lösen, und zwar mit wsconsctl. Nachdem ich den Keycode der besagten Taste herausgefrickelt hab, hab ich sie mit wsconsctl -w map+="keycode 49=numbersign apostrophe" umbelegen.
Ruf ich im Moment in der /etc/profile auf, aber wahrscheinlich kann ich das auch in der /etc/wscons.conf machen.
 
Oben