• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Netzwerkverbindung friert ein

R

ralli

Guest
Themenstarter #1
Ich weiß nicht, ob der Titel richtig gewählt ist oder beschreibt, was für ein Problem ich habe. Ich bin kein Techniker und werde mit meinen Worten beschreiben, um was es geht.

Wie viele 1und1 DSL Kunden habe ich auch automatisch eine Cloud bekommen, die ich auch nutze. Der Zugriff ist entweder über einen Browser gewährleistet oder über das DAVS Protokoll (webdav), was Thunar, Dolphin und Nautilus auch gut beherrscht. Mit allen drei Dateimanagern hatte ich unter FreeBSD beim Datenaustausch nie Probleme. Leider ist das unter OpenBSD anders. Wenn ich aus der Cloud und meiner Musiksammlung einen Ordner in meinem Ordner Musik ins Homeverzeichnis kopiere, dann funktioniert das beim ersten Mal, wenn ich Glück habe, noch einwandfrei. Bereits bei einem zweiten Ordner oder einem gezippten Archiv, friert der graphische Balken unter Nautilus ein, es stoppt, obwohl die Verbindung nicht abgebrochen wird. In die Netzwerkkonfiguration greife ich manuell nie ein, weil das bisher auch nie nötig war. Alles läuft über die Fritzbox bezw, DHCP. Hatte mit der selben Hardwarearchitektur unter FreeBSD noch nie derartige Probleme. Das ist ärgerlich, wenn ich den Rechner herunter fahre und dann neu starte, geht es erneut los, einmal geht es und dann friert er ein. Ich hoffe, das ich beschreiben konnte, was für ein Anliegen und Problem ich habe. Muß da an der Netzwerkkonfiguration was geschraubt werden? Dann bräuchte ich die Hilfe von Experten, denn damit kenne ich mich nicht aus und bin leider damit überfordert.
 

Rakor

Administrator
Mitarbeiter
#2
Tritt das Problem nur bei webdav-Verbindungen auf, oder auch bei anderen umfangreichen Netzwerksktivitäten?
 
R

ralli

Guest
Themenstarter #3
Tritt das Problem nur bei webdav-Verbindungen auf, oder auch bei anderen umfangreichen Netzwerksktivitäten?
Guten morgen @Rakor, was ich bisher beobachtet habe, war mir das immer bei webdav Verbindungen aufgefallen. Wenn ich surfe, ist alles normal. An der Bandbreite kann es ja eigentlich auch nicht liegen, da ich 50/MBit habe. Kann ja mal versuchsweise einen Film mit mediathekwebview im Browser herunterladen und sehe was da passiert. Youtube-dl arbeitet auch störungsfrei und normal.
 
R

ralli

Guest
Themenstarter #4
Gut habe es getestet, download mäßig alles im grünen Bereich. Das es mal Schwankungen gibt, ist ja nicht unnormal und wahrscheinlich auch abhängig vom Server. Und die Stabilität von dav ist gewiss auch client abhängig. Jedenfalls hatte ich diese Probleme früher nie. Da fällt mir gerade noch ein, das der Dolphin unter KDE erst überhaupt keine Verbindung aufbaut mit webdav:// Auch das ist nur unter OpenBSD so. Es sieht so aus, das ich damit leben muß. Ich meine mich auch daran zu erinnern, das die Stabilität der Verbindung (speziell auf meine Cloud bezogen) von der Zeit abhängt. Morgens manchmal weniger bis keine Probleme, Mittags oder Nachmittags eher andauernd.
 
#5
Hast du deinen Dateimanager mal aus der Shell raus gestartet? Vielleicht gibt er irgendwelche Meldungen aus...

Ansonsten mal einen anderen Dateimanager versuchen und sehen, ob dabei das gleiche Verhalten Auftritt.
 
R

ralli

Guest
Themenstarter #6
Hast du deinen Dateimanager mal aus der Shell raus gestartet? Vielleicht gibt er irgendwelche Meldungen aus...
Nein, werde ich gleich mal ausprobieren.

Ansonsten mal einen anderen Dateimanager versuchen und sehen, ob dabei das gleiche Verhalten Auftritt.
Bliebe nur noch Thunar, bei Dolphin funktioniert es eh nicht. Werde ich auch antesten. Ich habe ja jetzt Gnome 3 installiert unter OpenBSD.
 
R

ralli

Guest
Themenstarter #7
So kleines Feedback .... Nautilus aus der Konsole, gleiches Problem, Thunar installiert. gleiches Problem. Könnte ja auch am 1und1 Cloud Clienten liegen, oder? Komisch ist nur, das es unter FreeBSD einwandfrei funktioniert, aber OpenBSD ist ja nicht FreeBSD.
 
R

ralli

Guest
Themenstarter #8
Jetzt habe ich mich mit Seamonkey bei der 1und1 Cloud angemeldet, das Herunterladen eines oder mehrerer Ordner funktioniert einwandfrei.
 
R

ralli

Guest
Themenstarter #13
Und hier das Ergebnis, ich habe 2 Ordner mit ca. 220 Musikstücke kopiert und prompt ist er nach 22 Dateien eingefroren und stehen geblieben:

Code:
load averages:  0.13,  0.12,  0.09    arbeit.fritz.box 06:15:21
99 processes: 97 idle, 2 on processor  up  0:19
CPU0 states:  0.2% user,  0.0% nice,  0.2% system,  0.4% interrupt, 99.2% idle
CPU1 states:  4.1% user,  0.0% nice,  2.0% system,  0.0% interrupt, 93.8% idle
CPU2 states:  1.4% user,  0.0% nice,  0.5% system,  0.0% interrupt, 98.0% idle
CPU3 states:  1.2% user,  0.0% nice,  0.6% system,  0.0% interrupt, 98.2% idle
CPU4 states:  0.7% user,  0.0% nice,  0.4% system,  0.0% interrupt, 98.9% idle
CPU5 states:  0.5% user,  0.0% nice,  0.4% system,  0.0% interrupt, 99.2% idle
CPU6 states:  0.3% user,  0.0% nice,  0.2% system,  0.0% interrupt, 99.5% idle
CPU7 states:  0.2% user,  0.0% nice,  0.2% system,  0.0% interrupt, 99.6% idle
Memory: Real: 615M/1678M act/tot Free: 14G Cache: 697M Swap: 0K/16G

  PID USERNAME PRI NICE  SIZE   RES STATE     WAIT      TIME    CPU COMMAND
74562 ralph      2    0   13M   24M idle      poll      0:06  3.56% gvfsd-dav
30823 ralph      2    0   17M   40M sleep/1   poll      0:05  0.10% nautilus
 3049 ralph      2    0 1115M  132M sleep/2   poll      0:17  0.00% gnome-shell
56243 _x11       2    0   17M   23M sleep/3   poll      0:17  0.00% Xorg
27238 ralph      2    0 5192K   12M idle      poll      0:10  0.00% gnome-sessi
42112 ralph     66   19   14M   26M onproc/2  -         0:02  0.00% tracker-min
    1 root      10    0  376K  420K idle      wait      0:01  0.00% init
18812 ralph      2    0   51M   85M idle      poll      0:01  0.00% evolution-c
87929 ralph      2    0   53M   84M idle      poll      0:01  0.00% evolution-c
 7277 ralph      2    0   53M   83M idle      poll      0:01  0.00% evolution-c
42739 ralph      2    0   12M   31M sleep/1   poll      0:01  0.00% gnome-termi
23898 ralph      2    0 7112K   19M sleep/0   poll      0:01  0.00% gsd-color
44941 ralph      2   19   18M   32M sleep/4   poll      0:00  0.00% tracker-ext
28900 ralph      2    0 1808K 3404K idle      poll      0:00  0.00% dbus-daemon
 9691 ralph      2    0 7736K   20M sleep/4   poll      0:00  0.00% gsd-media-k
84876 ralph      2    0 5816K   18M sleep/5   poll      0:00  0.00% gsd-clipboa
27731 ralph      2    0 7664K   21M sleep/2   poll      0:00  0.00% gsd-xsettin
78896 ralph      2    0 7400K   34M idle      poll      0:00  0.00% evolution-a
Ich kann nichts auffälliges entdecken, wunder mich nur, das da noch Evolution in den Prozessen auftaucht, obwohl ich nur die Basisinstallation gnome ohne Evolution, Epiphany und Totem vorgenommen habe.
 
R

ralli

Guest
Themenstarter #15
versuch doch mal ein Log zu erstellen:

https://wiki.gnome.org/Projects/gvfs/debugging

/usr/lib wird wohl /usr/local/lib sein müssen...
Danke Oliver, aber ich postete bereits, das dieses Problem nur unter OpenBSD auftritt. Habe noch diesen Link gefunden:

https://spackmat.de/spackblog/archives/698-Das-11-SmartDrive-ist-eher-enttaeuschend.html

Scheint eh etwas problematisch zu sein. Das debuggen funktioniert auch nicht, irgendwie ist die Syntax fehlerhaft. Ist aber nicht weiter schlimm, danke für Deine Unterstützung. Ich nehme ab sofort den Browser, da funktioniert es einigermaßen. Ich denke auch darüber nach die Cloud generell zu bannen. Für mich ist das Thema hiermit erledigt.
 
R

ralli

Guest
Themenstarter #17
#18
Wie so immer sollte man ein Auge auf die /usr/local/share/doc/pkg-readmes/ werfen. Ob es Abhilfe schafft, weiss ich nicht. Einen Versuch ist es aber wert.

https://cvsweb.openbsd.org/cgi-bin/...in?rev=1.41&content-type=text/x-cvsweb-markup
Code:
mDNS/DNS-SD support
===================
The avahi-daemon(8) daemon provides Zeroconf support (aka. Bonjour /
Rendezvous) in GNOME. Several applications can optionally benefit from
it (e.g. the "Network" shortcut in nautilus(1)) while some others
will not work at all without it (e.g. seahorse-sharing(1)).

To make use of it, rc.conf.local(8) needs to contain the following line:
    multicast=YES
and "avahi_daemon" must be added to "pkg_scripts" _after_ "messagebus".

Cheat sheet
===========
# rcctl disable xenodm
# rcctl enable multicast messagebus avahi_daemon gdm
# reboot
 
R

ralli

Guest
Themenstarter #19
Ob es Abhilfe schafft, weiss ich nicht. Einen Versuch ist es aber wert.
Hat leider nicht geholfen. Zumindest funktioniert gdm. Aber jetzt habe ich die Programme alle in englisch, obwohl in gnome alles auf deutsch eingestellt ist. Deutsche Umlaute funktionieren. Wertet gdm .xsession oder .xinitrc?
 
#20
Wie in der o.a. pkg_readme beschrieben, sollte folgendes Abhilfe schaffen:

Code:
GDM
---
Session management requires the use of GDM as login manager, otherwise
some key features like screen locking, session tracking... will not work
properly. To do so, "gdm" must be added at the end of "pkg_scripts" in
rc.conf.local(8) (and "xenodm_flags" commented or removed).

GDM greeter language and character set is configured in:
    ${SYSCONFDIR}/gdm/locale.conf
Note that the variables set in this file will be inherited by the user session.
They can be unset/overriden in the user's .profile file.

It is *not* possible to change the GDM greeter keyboard input layout due to the
lack of systemd-localed support on OpenBSD.
 
R

ralli

Guest
Themenstarter #22
So eine wichtige Ergänzung. Ich habe Gnome neu installiert und mich strict an die offizielle Anleitung /usr/local/share/doc/pkg-readme gnome-3.26 gehalten. Jetzt funktioniert alles, aber Gnome ist in englisch und gdm ist in englisch. Die deutschen Umlaute funktionieren im Texteditor, obwohl ich unter

Code:
Einstellungen - Region und Sprache
alles auf deutsch eingestellt habe.

Ich habe die Lösung gefunden. Im Ordner

/etc/gdm muß die Datei locale.conf editiert werden von:

Code:
LC_CTYPE="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
auf

LC_CTYPE="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"

Rechner neu starten und alles ist in deutsch, der Loginmanager sowie auch die Gnome Shell und alle Programme.