• Diese Seite verwendet Cookies. Indem du diese Website weiterhin nutzt, erklärst du dich mit der Verwendung von Cookies einverstanden. Erfahre mehr

Newbie wagt Freebsd i386 auf Pentium 3 - Auflösung Xserver fest auf 640x480

Themenstarter #1
Halli Hallo,

dies ist mein erster Post - halli, hallo :). Ich bin eher zufällig gerade zu BSD gestoßen, weil ich mit alter Hardware noch "sicher" ins Internet gehen möchte.

Meinen Compaq Deskpro EN Pentium 1.0Ghz betreibe ich hauptsächlich mit DOS und WinXp im Dualboot, um alte Eprom-Programmer (wiederum für Arcade Hardware) anzusteuern. Jetzt benötige ich auf gleicher Maschine am Reparaturplatz noch die Möglichkeit ins Internet zu gehen (für Anleitungen, Eprom-Hashes usw.).

=> Hey, da kann ich doch gleich mal den lange schon angedachten Gedanken Freebsd zu erfahren, in die Tag umsetzen. :D

Starte ich X / Openbox bleibt der Desktop jedoch auf 640x480 eingeforen. Ich weiß nicht so recht, wo ich anfangen soll. Soweit bin ich hier als totaler Newbie gekommen:

- /var/log/Xorg.0.log im Anhang. Soweit ich das verstehe, wird für meine "NVidia Corporation Riva TNT" der generische Vesa-Treiber verwendet.

- xrandr, die Ausgabe im Anhang. Da steht steht, dass mein "Screen" nux 640x480 kann.

- Websuche, Freebsd, Nvidia usw, für die uralte Karte sollte ich wohl den Treiber über den Port installieren x11/nvidia-driver-71xx. Leider finde ich diesen nicht mehr. Versuche ich den Treiber von Nivida zu verwenden (make install), dann kommen zahlreiche Fehlermeldungen, dass irgendwelche Datentypen nicht bekannt sind.

Kann mir jemand helfen ? :) Welchen Treiber verwende ich am Besten?

Beste Grüße aus Hamburg
Banane
 

Anhänge

Alexander88207

Well-Known Member
#2
Hallo Banane :)

Code:
[    30.858] (EE) open /dev/dri/card0: No such file or directory
Sieht aus als sei der gpu treiber nicht geladen.

Hier sind noch ein paar alte nvidia ports drine, weiss aber nicht ob die noch funktionieren.
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#3
Hi,
eine Riva TNT. Das ist verdammt lange her. :) Die alten Nvidia-Treiber werden nicht funktionieren, denn sie passen nicht mehr auf aktuelle Kernel und Xorg-Server. Die beste Chance dürfte xf86-video-nv sein: https://www.freshports.org/x11-drivers/xf86-video-nv/

Die nächste Herausforderung dürfte dann werden einen Browser zu finden, der auf so alter Hardware noch halbwegs brauchbar läuft und aktuelle Webseiten einigermaßen sauber rendert. Sowohl Firefox und Chrome brauchen SSE2 und werden daher nicht laufen.
 

Rosendoktor

Well-Known Member
#4
Bei Deinem Treiberproblem kann ich Dir jetzt leider nicht helfen. Sofern Du aber mit "ins Internet gehen" die Nutzung eines Browsers meinst, nur zur Info: Firefox und Chromium und deren Derivate werden auf dem P3 nicht mehr laufen, die setzen SSE2 voraus, das kann der P3 nicht. Nischenbrowser wie Epiphany und Midori laufen zwar, aber Spaß macht das nicht mehr auf so alten Maschinen.

EDIT: Grad mal mein Pentium 3 IBM x24 angeschmissen. Epiphany funktioniert noch am besten, braucht für heise.de etwa 2 Minuten zum laden+rendern, für bsdforen.de etwa 45 Sekunden. Viel Spaß! :D
 
Zuletzt bearbeitet:

cabriofahrer

Well-Known Member
#5
Themenstarter #6
@Yamagi: Jippie, vielen lieben Dank für die schnelle Antwort. Weiß ich zu schätzen, dann es kann schon nerven, wenn man immer wieder die gleichen Anfängerfragen liest.

Code:
cd /usr/ports/x11-drivers/xf86-video-nv/ && make install clean
pkg install xf86-video-nv
Der Treiber funktioniert.

Genau, jetzt zur nächsten Herausforderung, dem Browser ;-)
 

Yamagi

Possessed With Psi Powers
Mitarbeiter
#7
Was ist denn mit

https://www.freshports.org/x11-drivers/xf86-video-r128/

Da steht was von xorg-server-1.20.7? Und wie ist das mit nvidia-driver-304? Da steht in der Erläuterung auch etwas von xorg-server-1.20.7:

https://www.freshports.org/x11/nvidia-driver-304/
Okay, ich hatte mich etwas ungenau ausgedrückt. Ich meinte die alten, von Nvidia nicht mehr unterstützten Versionen ihres Blobs. Die letzte Version, die noch die TNT und TNT 2 unterstützt, war 71.86.15. Sie ist am 17.08.2011 erschienen und wird mit aktuellen Systemen nicht mehr funktionieren.