Nochmal: pkg version: needs updating / pkg upgrade aber => up to date

testit

Well-Known Member
Hallo,

ich hatte hier schon einmal das Problem beschrieben, dass bei mir ein
Code:
pkg version -vIL=
bspw. ausgibt:
php72-7.2.11 < needs updating (index has 7.2.31)
.

Aber ein
Code:
pkg upgrade php72-7.2.11

gibt aus:
Your packages are up to date.

In o. a. Thread wurde damals argumentiert, dass das "pkg version -vIL=" gegen die Port-Version prüfen würde (warum auch immer bei einem PKG-Kommando !?).

Dann frage ich mich allerdings, wieso bei FreeBSD 10.4 auch jetzt noch unter Nutzung von
Code:
url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest",
in der FreeBSD.conf mit anschließendem pkg update -f

bspw. das o. a. PHP 7.2.31 nicht als Paket bereitgestellt zu werden scheint?

Theoretisch müsste PHP 7.2.31 die letzte Paket-Version für den FreeBSD-Branch 10.4 sein, wenn zugleich 7.2.31 auch die letzte Port-Version war und zum heutigen Zeitpunkt die Nichtverfügbarkeit der 7.2.31-Version auch nicht mehr mit der zeitlichen Differenz zwischen dem Stable- und dem Latest-Zweig zu erklären ist.

Vielleicht kann mir von Euch jemand o. a. Sachverhalt erklären/begründen ...


Danke und viele Grüße
testit
 
Oben